WordPress.org

Ready to get started?Download WordPress

Forums

Sucuri Security - Auditing, Malware Scanner and Hardening
[resolved] Cannot modify header error (23 posts)

  1. jonahrbrown
    Member
    Posted 11 months ago #

    Plugin version 1.4

    /public_html/wp-content/plugins/sucuri-scanner/sucuri.php on line 625

    http://wordpress.org/plugins/sucuri-scanner/

  2. jonahrbrown
    Member
    Posted 11 months ago #

    The error seemed to have gone away.

  3. fruityoaty
    Member
    Posted 11 months ago #

    I am getting the same error as above when I login to WordPress. Plugin version 1.4 on WordPress 3.6.

    In addition, these other errors:
    /wp-content/plugins/sucuri-scanner/sucuri.php:360) in /public_html/wp-includes/option.php on line 571

    wp-content/plugins/sucuri-scanner/sucuri.php:360) in /public_html/wp-includes/option.php on line 572

    Unlike the above user, the "line 625" error has not gone away on my site. The previous version was working fine... until I updated to version 1.4.

  4. dremeda
    Sucuri Wizard
    Posted 11 months ago #

    Hi there! Are you still experiencing the issue? We are not able to reproduce here.

    What other plugins do you have enabled?

    Thanks!
    Dre

  5. streetlove
    Member
    Posted 11 months ago #

    Still doesn't solve the issue. There's an update a while ago. Now I ended with another box of error message after the update.

  6. streetlove
    Member
    Posted 11 months ago #

    Now all error message is gone.

  7. fruityoaty
    Member
    Posted 11 months ago #

    I updated to version 1.4.1. The "line 625" error disappeared, however, the "line 571" and "line 572" errors appeared on top of the "Last user login" yellow message box right after I updated the plugin.

    Strangely, after I logged out and then logged back in to WordPress, the ERROR MESSAGES ALL DISAPPEARED.

    I then cleared my browser cache and logged in again. The "line 571" and "line 572" errors again appeared on top of the "Last user login" yellow message box.

    It seems that the errors only appear:
    1. After updating the plugin.
    2. When the user logins to WordPress (and previous login cookie has expired/cleared from browser cache).

  8. mathewmackenzie
    Member
    Posted 11 months ago #

    OK Im getting the problem as well, but also something new. WP3.6. With version 1.4 I get this error message:

    http://www.flickr.com/photos/mathewmackenzie/9559542235/

    Like the others this error is intermittent, but keeps coming back.

    Then after upgrading to 1.4.1 I get a funny box with some code in it, that I can click a cross to close...

    http://www.flickr.com/photos/mathewmackenzie/9562334426/

    This across more than one site, with different plugins. All errors disappear when plugin deactivated, and return when reactivated.

    Afraid I'm going to have to shut down your plugin until this is fixed.

  9. saturnus
    Member
    Posted 11 months ago #

    I'm getting the modify header errors as well. They only go away when I deactivate this plug-in. So it's nothing to do with other plug-ins, this one just needs to be fixed. And yes I did update.

  10. dremeda
    Sucuri Wizard
    Posted 11 months ago #

    Thanks everyone for the input, we're testing right now to see what's going on. We'll update ASAP.

  11. rvconnelly
    Member
    Posted 11 months ago #

    I am getting the same error and I am now unable to login to my client's site.

      Any assistance would be appreciated!
    I am listing the entire set of errors (below) in case it helps. I get these by simply navigating to the site's WP login screen (i.e., /wp-admin) and the WP login box/fields is displayed below this long list of errors:

    Warning: Missing argument 2 for sucuri_login_redirect() in /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php on line 619

    Warning: Missing argument 3 for sucuri_login_redirect() in /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php on line 619

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 695

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 696

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 697

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 698

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 699

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 700

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 703

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 704

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 705

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 706

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 709

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 710

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 711

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 712

    When I do try to login I simply get the following 3 errors (and then whitespace -- no access to my client's site)...

    Warning: Missing argument 2 for sucuri_login_redirect() in /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php on line 619

    Warning: Missing argument 3 for sucuri_login_redirect() in /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php on line 619

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8175589/html/wp-content/plugins/sucuri-scanner/sucuri.php:619) in /home/content/89/8175589/html/wp-includes/pluggable.php on line 875

  12. rvconnelly
    Member
    Posted 11 months ago #

    I found out I was actually logged in to my client's WP site when I navigated to the site's home page. I then deactivated the Sucuri plugin and now can log in and out of the site with no problem.

    Here is some additional info I should have included in the above post...
    WP version: 3.6
    Theme: Atahualpa, current version: 3.7.12
    Other plugins installed: (all current versions) Share Buttons by AddToAny, Stop Spammer Registrations Plugin, WordPress Importer, Secure WordPress, and WP Security Scan.

    Thanks.

  13. dremeda
    Sucuri Wizard
    Posted 11 months ago #

    Hey there, the team is looking into it to try and reproduce. By chance did you try disabling all the other plugins to see if the error goes away?

    Thanks,
    Dre

  14. rvconnelly
    Member
    Posted 11 months ago #

    Sorry, I have not had the time to test by disabling the other plugins. I have highly customized some of then (e.g., stopspammers.) If I deactivate, I will need to reproduce the configurations which will take some time. I'm buried with work today. If your testers are not able to reproduce sooner than later, I will try to make time for it tomorrow.
    Cheers,
    Bob

  15. fruityoaty
    Member
    Posted 11 months ago #

    I updated to version 1.4.2. The update did not make errors go away. Instead, it introduced a new error that appears on my WordPress login page - /wp-login.php:

    Warning: Missing argument 2 for sucuri_login_redirect() in /wp-content/plugins/sucuri-scanner/sucuri.php on line 619

    The "line 571" and "line 572" still occur.

    The errors only occur after I login (when the WordPress cookie login has expired/been cleared from browser cache). If I logout out and then log back in the same open browser tab, the errors will not appear. But if clear the browser cache, close the browser, re-open the browser and log back in, the errors occur.

  16. fruityoaty
    Member
    Posted 11 months ago #

    OK, I updated now to version 1.4.3. The "line 619" error that was introduced to my blog in version 1.4.2 has now gone away.

    However, the "line 571" and "line 572" error messages that were introduced when I updated from 1.3 to 1.4 (1.4.1, 1.4.2, 1.4.3) still persist after I login. I suppose I could live with the errors since they do not appear on the front-end... and they don't show up all the time. Still... kinda annoying. Hope it gets fixed, otherwise I guess I'll just revert to version 1.3.

  17. dremeda
    Sucuri Wizard
    Posted 11 months ago #

    Hi fruityoaty, we're checking out the issue to see what is going on. We'll answer back as soon as we can, and we apologize for the issues!

    Thanks,
    Dre

  18. dremeda
    Sucuri Wizard
    Posted 11 months ago #

    Hi Fruityoaty, we're not able to reproduce on our end, and the code is correct there. Can you please post the exact errors you're seeing?

    Thanks!
    Dre

  19. fruityoaty
    Member
    Posted 11 months ago #

    Hi!

    Just wanted to say I updated to version 1.4.4 today and this update has fixed the problems on my blog. Tested it a few times - the error messages have not returned. THANK YOU!!!

  20. saturnus
    Member
    Posted 11 months ago #

    Updated to 1.4.4 and it's fixed now. I don't see the errors anymore.

    Thank you for acting so quickly on this and for responding.

  21. brent3721
    Member
    Posted 7 months ago #

    just noticed we have the same issue -- on wordpress 3.8

    Updated some other plugins (Sucuri didn't have an update available) and it seems to have gone away... odd...

    Warning: Cannot modify header information - headers already sent by (output started at /nfs/c05/h03/mnt/40749/domains/condensed.io/html/wp-content/plugins/sucuri-wp-plugin/sucuri.php:201) in /nfs/c05/h03/mnt/40749/domains/condensed.io/html/wp-includes/option.php on line 563

    Warning: Cannot modify header information - headers already sent by (output started at /nfs/c05/h03/mnt/40749/domains/condensed.io/html/wp-content/plugins/sucuri-wp-plugin/sucuri.php:201) in /nfs/c05/h03/mnt/40749/domains/condensed.io/html/wp-includes/option.php on line 564

  22. brunoaborges
    Member
    Posted 6 months ago #

    Hello,

    What's the plugin version you are using? The old versions doesn't have an update function but the new releases already have it. Make sure you are using the latest. You may need to disable this one and install the new.

    Thanks,

    Bruno
    [ Signature moderated. ]

  23. Yorman
    Member
    Plugin Author

    Posted 1 week ago #

    We were having some troubles debugging the plugin to prevent these issues, since most of the actions (from older releases) were returning and printing data at the same time. In newer releases we implemented a template system that is working better and is helping us to avoid these annoying warnings.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.