WordPress.org

Ready to get started?Download WordPress

Forums

Cannot login to my admin page with FIREFOX (18 posts)

  1. J3r0m3
    Member
    Posted 9 years ago #

    I have just reformatted my comp and switched to the Firefox 1.0 Previously, i was using Firefox 1.0PR

    Now the problem is this, i tried to get to the admin page of my blog and i cannot even get to the login page.

    All i get is a
    "Redirection limit for this url exceeded. Unable to load the requested page. This may be caused by cookies that are blocked."

    How do i solve this problem?
    I tried with IE and i also cannot get to my admin page. They just keep on hanging at the login page.

    The Offending page

  2. TomPreuss
    Member
    Posted 9 years ago #

    The login page loads just fine for me.

    Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

    I was unable log in after registering, however.

    My error was the same:
    Reirection limit for this URL exceeded. Unable to load the requested page. This may be caused by cookies that are blocked.

  3. I registered as testuser8, but had the same problem. You might want to try replacing wp-login.php with a fresh copy from a fresh WP download. Do not overwrite the file. Delete the old one first, then upload the new one. Overwriting files via FTP can lead to incomplete transfers.

  4. J3r0m3
    Member
    Posted 9 years ago #

    ok, i give it a try first then get back to you all.

  5. J3r0m3
    Member
    Posted 9 years ago #

    still cannot login with it.

    i forgot to mention that i was using wordpress 1.2.2

    After i deleted the wp1.2.2 version and put in the older wp-login, it works

    using the wp-login.php from wp 1.2, i am using it to login now. But i would still like to find out why and also to use the newer login page.

  6. NuclearMoose
    Member
    Posted 9 years ago #

    Sounds like you may need to delete all of your files (except your modified site-theme files) and upload a fresh copy. When you went to run 1.2.2, did you remember to run .../wp-admin/upgrade.php?

  7. J3r0m3
    Member
    Posted 9 years ago #

    yeah i did that.
    hmm, delete everything...

  8. Yes, I'm going to second NM's suggestion. "Upgrade" again by follow the steps here: http://codex.wordpress.org/Upgrading_WordPress

  9. J3r0m3
    Member
    Posted 9 years ago #

    inadvertently, i get introduced to a new WP help site.
    Think i will get round to doing it, the moment my hands are not so tied up

    Thanks for the second opinion. NM and macmanx.
    And also to all who contributed

  10. NuclearMoose
    Member
    Posted 9 years ago #


    inadvertently, i get introduced to a new WP help site.

    If you are referring to the Codex, then yes, it's relatively new, but it will eventually serve as the location for all of WP's documentation. The original wiki is still online at http://wiki.wordpress.org .

  11. Glad I could help. I hope it works out.

  12. rossz
    Member
    Posted 9 years ago #

    In Firefox, Tools->Options->Privacy, then click on "Exceptions" under "Cookies". Locate the entry for your blog domain. It probably says "blocked". Delete that. Now reload your blog. And log in. Make sure you allow the cookie. Also, make sure you have cookies enabled.

  13. Daisyhead
    Member
    Posted 9 years ago #

    I am also experiencing this same problem. I changed my cookie settings in FF like Rossz recommened and attempted to access my login page again and I am getting the same erorr message:

    "Redirection limit for this url exceeded. Unable to load the requested page. This may be caused by cookies that are blocked."

    I now have to use IE to login or post to WP and it's getting old. I didn't have this problem until I upgraded my WP to the latest version. =(

    Any more ideas? Anyone else experiencing this problem?

  14. teammurder
    Member
    Posted 9 years ago #

    I had this precise problem and doing the re-upgrade as described above solved it. I was also using an old version of wp-login.php from a local install as a temporary solution. Any devs know what the reason for this sudden failure might be? I'm just curious as a preventive measure in the future. Thanks to everyone for all of the suggestions and solutions.

  15. If you have phpmyadmin access, make sure your site_url and home values are set correctly.
    http://www.tamba2.org.uk/wordpress/site-url/

  16. teammurder
    Member
    Posted 9 years ago #

    I'm glad that link made into this thread but between the two installs nothing about the mySQL databases changed. I'm going to dig around a little bit in my logs as well as the db tables to see if I can figure anything else out (despite being glad to be functional using an up-to-date copy of wp-login) that might cause things to go funky.

  17. Well, just in case, here's a whole pile of things to try:
    http://codex.wordpress.org/Login_Trouble

  18. error
    Member
    Posted 9 years ago #

    When I first started using WordPress 1.2, I ran into this same problem - at new installation! I think I reinstalled it about five or six times, including completely dropping all the tables and starting with a fresh empty database. Never could log in. I finally went to the latest nightly and they've been working very well, aside from the occasional upgrade strangeness (what happened to my theme?). But I knew what I was getting in to when I started using nightlies, and it's definitely not for everyone. You should have a strong grasp of PHP and being self-hosted makes things easier. :) I know it doesn't exactly solve the problem, but it's an option.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.