WordPress.org

Ready to get started?Download WordPress

Forums

Cannot login or log out. Searched other threads, have not found answer. (3 posts)

  1. johnsexton82
    Member
    Posted 6 years ago #

    I've got problems logging in, logging out, and registering on one of my WP 2.5 installations.

    It is installed to a subfolder, but everything besides those functions is working perfectly. I can make posts, edit posts, everything works exactly as it should. I have custom permalinks and they work great.

    I can access the admin dashboard through my bookmark of the [wordpress url]/wp-admin/ link.

    Except for when I try to log-out, or login, or register.

    With my custom permalinks on, clicking log-out takes me to my custom 404 error page.

    With the default permalinks structure, clicking log-out takes me to an Internal Server error page.

    This is what I have tried and what I know:

    • I have deactivated every plugin and it did not help.
    • I have tried renaming my plugins folder so WP couldn't find it at all, and that did not help either.
    • I have tried completely removing my .htaccess file and it did not help.
    • I have tried re-uploading my wp-login.php file from a brand new WP2.5 folder.
    • It happens in every browser.
    • It happens on Windows XP and Mac OSX 10.5.1.
    • I have never received the common "cookie" error.

    One thing that makes this installation unique is that it was previously in the root directory of my site, and I moved it to a sub-directory (an addon domain) through the instructions presented at wordpress.org and through many other online tutorials.

    I was very careful and everything besides the login/logout seems to be working perfectly, but it is possible there is a file I forgot to edit or a setting I forgot to change somewhere.

    I have looked around everywhere I could think of yet I have not been able to find any solution to my problem.

    I am totally stuck and would much appreciate some help!

    Thank you!

  2. dvdizon
    Member
    Posted 6 years ago #

    I have this problem, and I have tried everything you tried,

  3. johnsexton82
    Member
    Posted 6 years ago #

    Ultimately I couldn't find a solution to this problem.

    I think it had to do with a botched integration between bbPress and WordPress.

    It seemed to be working ok in that my users were represented in both places, and once I started messing around with bbPress I discovered that I could log in and log out through bbPress only, and not through WordPress.

    In the end, though, I deleted both my bbPress and WordPress installation, exported my blog posts, deleted my database, made a new database, installed a fresh wordress, and imported my blog posts.

    Everything is back up and running now, but it took several hours to clear everything out and start over again.

    You can visit my site at http://www.fuseboxtheatre.com

Topic Closed

This topic has been closed to new replies.

About this Topic