WordPress.org

Ready to get started?Download WordPress

Forums

cannot login - (50 posts)

  1. Anonymous
    Unregistered
    Posted 11 years ago #

    for some reason whenever I log into b2login.php, it just goes back to the login page, no errors or other indications.
    I've read the b2 forums @ cafelog.com and nothing posted there seems to apply.
    b2 worked fine, it does not seem to be IE6 related, index.php loads fine.
    any ideas ? very much appreciated!
    -dave
    davehoo.net

  2. southerngal
    Member
    Posted 11 years ago #

    I had a problem too, till I realized that the login is now in the wp-admin folder. wp-admin/b2login.php

  3. Anonymous
    Unregistered
    Posted 11 years ago #

    thanks, my b2login is in the root folder, moving it had no effect other than an error about /usr/share/pear...

  4. Tom
    Member
    Posted 11 years ago #

    go to http://YOUSITE.COM/b2login.php?action=logout then try logging in again.
    might work, might not.

  5. Anonymous
    Unregistered
    Posted 11 years ago #

    Thanks, it didn't same...just reloads b2login.php with either the admin account or the other account I registered
    I switched browsers, cleared cookies etc...
    could it be a permissions issue ?
    it appears permissions are set to 644 except weblogs.com.changes.cache which is 666.
    thanks

  6. southerngal
    Member
    Posted 11 years ago #

    Dave, I didn't move my b2login.php, there are two. Did you try the path that I mentioned?

  7. Anonymous
    Unregistered
    Posted 11 years ago #

    I am having the same issue with a clean install. I tried the suggestions listed here (there was no b2login.php in the wp-admin folder, however).
    Any more suggestions?

  8. thomas
    Member
    Posted 11 years ago #

    I think, when downloading WordPress, there is no b2-login.php in our /wp-admin/
    So, when we want to login, we use the b2login.php in our WP files .. it will be http://www.myurl.com/b2login.php
    BUT, after login, we will directly go to /wp-admin/ where all admin area scripts resides...

  9. Anonymous
    Unregistered
    Posted 11 years ago #

    has anyone that experienced this found a fix ? b2 works great but still get the perpetual login screen with wordpress.
    Thanks

  10. JoshuaClinard
    Member
    Posted 11 years ago #

    I'm having this same issue myself. It's funny that none of the developers have posted in this thread.

  11. Mike Little
    Member
    Posted 11 years ago #

    You are right Joshua, none of the devlopers have posted in this thread. Until now.
    A couple of points first:
    There is only one b2login.php and it resides in the wordpress directory.
    It requires cookies .
    I'm not sure what the problem is. Unfortunately the page sets an error message but then redirects which loses the error!
    Thomas is correct when he says that after a successful login you are redirected to wp-admin/b2edit.php
    Do the other parts of the blog work?
    Can you display the home page index.php?
    If you try to go directly to wp-admin/b2edit.php what does that do?
    I hope we can get to the bottom of this.
    Mike

  12. davehoo
    Member
    Posted 11 years ago #

    >If you try to go directly to wp-admin/b2edit.php what does that do?
    leads me right back to /b2login.php
    as does everything...what am I missing here? :)
    thanks

  13. davehoo
    Member
    Posted 11 years ago #

    >Do the other parts of the blog work?
    yes, index.php loads
    give my install a try if you would like @
    http://davehoo.net/wordpress
    Thanks

  14. Anonymous
    Unregistered
    Posted 11 years ago #

    When I'm trying to login, this error appears. What can I do to solve it!
    Fatal error: Failed opening required 'http://assmebler.port5.com/wordpress/b2-include/b2template.functions.php' (include_path='') in /host/a/s/s/p/o/r/assembler.port5.com/wordpress/b2login.php on line 3

  15. tulim
    Member
    Posted 11 years ago #

    Sorry the last post was mine, i did'nt have registered!
    now i've!

  16. Matt Mullenweg
    Troublemaker
    Posted 11 years ago #

    See this.

  17. JoshuaClinard
    Member
    Posted 11 years ago #

    When I went directoy to the b2edit.php file, it took me to the login screen as well. Just for funzies, I tried logging in again, and this time, it worked.

  18. davehoo
    Member
    Posted 11 years ago #

    maybe its time to revert to moveable type :(

  19. Mike Little
    Member
    Posted 11 years ago #

    Davehoo,
    Have you tried the latest beta? There is a fix included which relates to not detecting cookies after loging in. This may fix your problem.
    Mike

  20. davehoo
    Member
    Posted 11 years ago #

    yeah, its not cookies. same no login with different browsers, different OS, etc. I'll give it another spin when I get my own server back up.

  21. davehoo
    Member
    Posted 11 years ago #

    success, moved to a different server , repeated and rinsed..all is groovy !!!

  22. Matt Mullenweg
    Troublemaker
    Posted 11 years ago #

    Very glad to hear that!

  23. dawolf
    Member
    Posted 11 years ago #

    Being an addicted b2 user I want to move to wordpress - I think. I mean, I really would like to try it at least. It runs locally (wordpress-071-gold @ Apache 2.0.44/MySQL 3.23.55/PHP 4.3.0 under WinXP Pro). After a login an empty page appears. Going directly to b2edit gives and empty page. Index.php and b2.php work.
    Ruud

  24. Anonymous
    Unregistered
    Posted 11 years ago #

    I have seen nothing here to help with this problem. I install wordpress, but it won't let me log in. The log in window actually says error logging in before I even enter anything.

  25. Anonymous
    Unregistered
    Posted 11 years ago #

    Sorry. Have to eat my words. Just deleted all cookies. Then logged in. It worked.

  26. getzdan
    Member
    Posted 11 years ago #

    I had the same problem when installing both wordpress and b2, just yesterday.
    I think I managed to trace the problem to the path specification when setting cookies.
    When I added an explicit path argument to the setcookie() function, the cookies became available to the verifyauth php script which requires them.
    It then seemed to work. The fix I made was to b2login.php. I added the extra parameter to all setcookie() calls.
    The original path for the cookies included the "b2login.php" filename which prevented them to be accessed from within a directory.
    I would be happy to know if this is the correct explanation....
    Thanx.

  27. getzdan
    Member
    Posted 11 years ago #

    the changes i made to the setcookie function in b2login.php is to add the parameter "/b2/" (which is the directory where the b2 or wordpress stuff is in my system. specifically:
    setcookie("cafelogpass",md5($user_pass),time()+31536000);
    changes to
    etcookie("cafelogpass",md5($user_pass),time()+31536000,"/b2/");
    ok... i hope this answers your question minimism.
    dan getz

  28. Anonymous
    Unregistered
    Posted 10 years ago #

    I can't log in either. All I get is the same login page, no matter what user name or password I type in. I would expect to get some sort of error message?
    Why is this so. It makes it hard to adopt this product if the login doesn't work.

  29. Anonymous
    Unregistered
    Posted 10 years ago #

    I just did a fresh install of the .71 code. No matter what I type in the login screen, I'm cycled back to it. The index page shows up fine, I can register new users without a problem. None of those users can log in, however.
    I've cleared my cookies, tried two different browsers, same problem. Do I really need to make those edits suggested above, or has the team discovered a different problem source?

  30. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Double-check your siteurl settings.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.