WordPress.org

Ready to get started?Download WordPress

Forums

Cannot login (16 posts)

  1. sonium
    Member
    Posted 9 years ago #

    I just installed WP and now I cannot login http://angua.upb.de/~sonium/wp-login.php . I get no error message. I tried also tried two different browsers. As I tried another script I had the same probem, so here is what phpinfo say if this migth be usefull: http://angua.upb.de/~sonium/info.php

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I just registered and logged in fine.
    - You will want to delete me when you do get back in -
    What exactly happens when you try ?
    Have you then tried to go to http://angua.upb.de/~sonium/wp-admin/post.php ?

  3. sonium
    Member
    Posted 9 years ago #

    ok, this is very strange. I can login using another PC. But I cannot login from here. Other sites work and cookies are accepted normaly. Just not from WP.

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Have you cleared the cache and cookies ?

  5. sonium
    Member
    Posted 9 years ago #

    yes

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    You enter your name and password, click Login .. and what happens ?

  7. stephanie
    Member
    Posted 9 years ago #

    I am having the same problem. No error message, but can not login either. I wonder if it has something to do with my database as I can reload the database, reinstall the program and login the first time. Can not do that everytime though :-)

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Login problems
    http://faq.wordpress.net/view.php?p=68
    Try those ?
    After you have logged in, even if the browser does nothing, can you get to /wp-admin/post.php by entering the full address into the browser address bar ?

  9. stephanie
    Member
    Posted 9 years ago #

    Thank you so much! If the above person had the same problem, it may be that he/she had never used a mysql db before either. I did not know that you had to create a user in the db (grins sheepishly). it seems obvious, though! Thanks again!

  10. Anonymous
    Unregistered
    Posted 9 years ago #

    My problem turned out as some kind of firefox bug. Had to make a new profile to get it working. But thx for support.

  11. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I get that firefox thing too sometimes.
    I have to use ctrl-alt-del to find the rogue 'firefox.exe' that is running somewhere, then kill it and all is then well.

  12. hartley_h
    Member
    Posted 9 years ago #

    WordPress 1.2, Apache 2.0, PHP 4.3.8, MySQL 3.23.58, FedoraCore1, https instead of http (in case that matters)
    I've just experienced this on a new install (using Firefox, Mozilla or IE). I go to the login screen, enter the information and I get redirected back to the login screen. No error message or anything. If I type in an invalid password, same thing. No error message. I register as a new user, that works fine. When I try to log on with that, however, no dice. I look in the wp_user table and the new user is there. I added a print statement to wp-login.php to show me the sql statement created on line 89. I then cut and pasted that and ran it on the mysql command line and it returned the expected record (for both admin and the new user I created).
    There's reference above to "that firefox thing" and "rogue 'firefox.exe'" problems but I'm not sure what that means. Can someone elaborate?

  13. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Have you been able to login yet ?
    The link above shows how to modify the code for a https login.
    The 'rogue firefox' - is when I have done something that causes FF to start up again, but run invisibly. Doesn't happem often, and I don't know what it is I'm doing to cause it, but a ctrl-alt-del does the trick.
    Are you able to try from another computer, or give us a link so we can try to register and login ?
    Have you cleared your cache and cookies then tried ?

  14. hartley_h
    Member
    Posted 9 years ago #

    Now I feel stupid. I saw that link but thought it was to a page I'd read. It wasn't and it included the solution to my problem. In retrospect, it was obvious that anywhere "http://" was hard coded it would need to be changed to "https://". I might suggest that in some future version, those pieces be pulled out and put in wp-config.php so that they can be changed in one place. Anyway, things seem to be working now. Thanks.

  15. hartley_h
    Member
    Posted 9 years ago #

    Update: October 7, 2004
    The new version (1.2.1) has been released. If you upgrade, even if you follow the instructions, it will break https installations. You need to edit login.php and replace http:// with https:// in two places (lines 153 and 155). Otherwise it will "update" your database with the WRONG form when you log in. It would REALLY be nice if this were a parameter that we could set in wp-config.php.

  16. bestfoot
    Member
    Posted 9 years ago #

    I have a prior version installed in a diff. directory and log in fine. I have 1.2.1 installed and cannot log in. I logged in fine the first time. I have deleted cache and cookies. It is something in the "new" and not necessarily improved version, cause if I cannot log in, what good is it? I have had many many installations and never had a problem before. Help :-)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.