WordPress.org

Ready to get started?Download WordPress

Forums

Cannot Install/Update Plugins Since Upgrade to 3.2 (26 posts)

  1. Jimmy
    Member
    Posted 3 years ago #

    Hi,

    I wonder if anyone has had this same issue since upgrading to 3.2 -

    When I try to install/update plugins I get an error:

    'Download failed. Destination directory for file streaming does not exist or is not writable.'

    I had a feeling this would be a permissions problem so I went about checking all the permissions on the installation. However, they all seem to be correct.

    I assume I will have the same problem when trying to upgrade my WP installation the next time an update is available.

    Has anyone had any experience with this? Perhaps it's a problem with my server's PHP installation.

    Jimmy.

  2. xxxxbyte
    Member
    Posted 3 years ago #

    Seems a problem of permissions after the installation as it happens with the buttons of the Visual Editor.

    As I said on this post:
    http://wordpress.org/support/topic/upgraded-to-32-visual-editor-buttons-missing/page/2?replies=41#post-2214530

    Check folders & files and change 600 permissions to 644. I'll look first on:
    /wp-content/plugins/PLUGIN-WITH-PROBLEM/
    and the others Plugin folders.

  3. Jimmy
    Member
    Posted 3 years ago #

    Hi xxxxbyte,

    Thanks for your reply.

    I read through the 'Visual Editor Buttons' post and didn't find too much that was helpful. I did recall not updating the wp-config.php when I installed 3.2, so I tried that, but no improvement.

    I'm going to pursue with the permissions on the file system, as you suggested.

    Can anyone tell me the correct permissions for the following files and directories? I've indicated what mine are currently set to.

    / (755)
    wp-includes/ (755)
    wp-admin/index.php (644)
    wp-admin/js/ (755)
    wp-content/themes/ (755)
    wp-content/plugins/ (755)
    wp-admin/ (755)
    wp-content/ (755)

    In answer to your questions, all my plugin directories are set to 755. Does that sound right to you?

    Thanks for your help with this.

    Jimmy.

  4. xxxxbyte
    Member
    Posted 3 years ago #

    Folders are ok.., but what about the files?

    A folder with 755 didn't have to be full of 755 files. Check the files of the plugin folder and you'll see ;)

  5. Jimmy
    Member
    Posted 3 years ago #

    Hi,

    OK, I've checked all the directories and files within the plugins directory and they seem fine. 755 on the directories and 644 on the files.

    This isn't really a problem that exists with one single plugin. More of an issue with the installation/update process.

    I've got a feeling that this is a hosting/PHP config issue. I'm going to do some digging on this.

  6. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    Those permissions look alright, This could very well likely be a server configuration issue, specifically, the Download might be attempting to save it in a temporary directory which you don't have write access to.

    As a test only, can you try changing the permissions on wp-content to 775 or 777?

  7. Jimmy
    Member
    Posted 3 years ago #

    Thanks for that, Dion.

    I tried changing the permissions on wp-content to both 775 and 777 with no joy.

    I just remembered from the previous version of WP I had installed that the temp files were saved in the plugins directory. However, I'm not sure I've ever been able to carry out an auto-install of any plugin/update before on this particular site.

    I seem to recall clearing out a lot of these temp install files that never completed.

    I think I am going to get in touch with the host and see if we can work this out.

    Thanks for your input.

  8. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    If your host can't help, Please give me a yell, as there are a few other options I can think of as "workarounds"

    (I've got email notifications of this thread, so just post :))

  9. Jimmy
    Member
    Posted 3 years ago #

    Hey, anything you can tell me would be great. I'm open to anything at this point :)

    My host is notoriously hard to get hold of and I'm short on time to complete the re-vamp of the website in question.

  10. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    It sounds like your host might have your Temporary files directory set to one which you don't have access to.

    I'd try adding the following to your wp-config.php file to force it to use the wp-content directory
    define('WP_TEMP_DIR', ABSPATH . 'wp-content/');

    It's not the best idea to do that as a first and final resort, as other things within WordPress (and PHP in general) may need to store temporary files as well (and only the upgraders will respect that constant I believe)

  11. Jimmy
    Member
    Posted 3 years ago #

    Hi!

    OK, I added that line to the wp-config.php file and tried it again, no joy, same error.

    So I tried easing the permissions on the wp-content directory to 775 and got the same error.

    Finally, I tried again after chmod to 777 and it worked!

    It seems like the server can't handle the normal WP permission structure for some reason. Kind of sounds like a user or role-based server issue to me.

    What do you think?

  12. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    Sounds like

    1. The server has set the Temporary directory to a directory which you don't have write access to
    2. You've had to create a temporary directory yourself (by chmod'ing it to 777 and setting the constant).

    So, definately sounds like a server configuration issue to me, one which WordPress (and any other web based application) can't really work around.

  13. Phil
    Member
    Posted 3 years ago #

    I had this issue and resolved it by turning off 'php safe mode' from server control panel.

  14. Jimmy
    Member
    Posted 3 years ago #

    Thanks guys. I finally got in touch with my host and they got back to me saying that they'd fixed the issue (it does work now) but from what I can see, all they've done is relax the permissions on all of the WP directories.

    Not a fix in my eyes!

    I will get back to them about the 'PHP safe mode' option and post back here.

    Dion - They did fix the temp file issue, so it's now using wp-content as the temp directory. Thanks for your input.

  15. southsideslim03
    Member
    Posted 3 years ago #

    PHP Safe Mode was "On" and I turned it off and everything worked fine...

  16. tatylic
    Member
    Posted 2 years ago #

    Yes, that's right! I have the same error and just turned PHP safe mode off. Everything working fine. :)

  17. Phil
    Member
    Posted 2 years ago #

    I had same problem again. Came here and found I had answered it myself. Lol

  18. cburger
    Member
    Posted 2 years ago #

    All,
    I´m a wordpress dummy and have the same message trying to install simple twitter plug in.
    See the advice as below, but I really don´t know how to find this is my wordpress, so I can try to change.
    Can one of you pls let me know where to find these settings?
    thanks
    claudia

    1)You've had to create a temporary directory yourself (by chmod'ing it to 777 and setting the constant

    2)PHP Safe Mode was "On" and I turned it off

  19. mdjasper
    Member
    Posted 2 years ago #

    For posterity:

    I run WP on a windows server with the PHP module in IIS. I recently encountered this error, and solved it by adding the iuser (IIS User process) permissions to the entire wordpress sub-directory. Previously, only wp-content needed write permissions.

  20. Heather Acton
    Member
    Posted 2 years ago #

    I just figured this out on the site I'm having this issue with. It's a site I built on a dev server, then haven't been able to update successfully since, with the same "destination directory doesn't exist or isn't writable". For me, the answer was in wp-config.php, in this line:

    define('WP_TEMP_DIR', '/home/xxxxxx/public_html/wp-content/uploads');

    It was all set up for the dev host, and for some reason the settings didn't change with the BackupBuddy migration.

    Obviously not sure if this is the same as anyone else's issue, but a good thing to check.

  21. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    @Heather Acton

    Please post a new topic.

  22. Heather Acton
    Member
    Posted 2 years ago #

    @kmessinger - I wasn't posting a problem, but rather a solution to the problem here.

  23. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    @Heather Acton

    ahah! You have caught a error in my speed reading! We are both up too late!

  24. imergeandsee
    Member
    Posted 2 years ago #

    @Jimmy
    What host do you have?

    @ Everyone
    I have GoDaddy 4GH Deluxe hosting (unlimited sites, unlimited bandwith, 150gb storage and 25 MySql databases etc) which they tell they made specifically for using WordPress self hosted - including the WordPressMU or MS. Its a shared server. Do I have to have a dedicated server to get these permissions?

    My back story on this:
    Everything worked fine regarding permissions until I added the OSCommerce to my account, its an App available in my Application admin like word press. Its recommended in their top apps right below WordPress. And lots of plug ins on the WordPress.org say their based on OSCommerce so I installed it.

    Godaddy says they answer all issues within a 3hr time line, I'm on hour 5 waiting going into 6 hrs so i came back here hoping to find an answer.

  25. imergeandsee
    Member
    Posted 2 years ago #

    Hey All,

    I think I found the solution on my end. On the same manage my applications page GoDaddy has (thats where you install/update/uninstall your applications like wordpress)

    I updated my version of WordPress from 3.2.1 to 3.3.1 and THAT was the issue. I did a full rollback to 3.2.1 and BAM! everything is Just fine and dandy joy joy joy out the wazoo.

    So on my end (might just be my install alone) something with version 3.3.1 doesn't jive and causes a fail on updates or installs of plug ins and themes. So if your on version 3.3.1 and having this issue do a rollback.

    I told the GoDaddy support member that same news. They finally answered me after 6.5 hrs 3.5 hrs later than their 3hr posted response time but reliable hosting for wordpress is an issue for another topic post.

  26. bellarush
    Member
    Posted 2 years ago #

    It may be a problem with the .htaccess file preventing updating.

Topic Closed

This topic has been closed to new replies.

About this Topic