WordPress.org

Ready to get started?Download WordPress

Forums

Cannot install WordPress (20 posts)

  1. normantang
    Member
    Posted 8 years ago #

    Hello,

    I cannot install WordPress. When I click on "wp-admin/install.php" I get an error message:

    "wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require_once('./upgrade-functions.php'); $schema = ( isset($_SERVER['HTTPS']) && strtolower($_SERVER['HTTPS']) == 'on' ) ? 'https://' : 'http://'; $guessurl = str_replace('/wp-admin/install.php?step=2', '', $schema . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) ); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; header( 'Content-Type: text/html; charset=utf-8' ); ?>"

    I have already created a wp-config.php file. Why does this happen?

    Thank you,

    Norman Tang

  2. dlf8
    Member
    Posted 8 years ago #

    Same thing is happening to me. I can do a local install with xampp, but I cannot get this running on my host. I've confirmed that my host and my account support the following:

    -Mysql and PHP has been installed on our server by default.
    PHP version is 4.3.10 and mysql version is 3.23.58 .
    Also mod_rewrite is enabled on the server by default.

    Any help for Norman and I appreciated :)

    Dan

  3. dlf8
    Member
    Posted 8 years ago #

    Actually, just figured out what I was doing wrong. I was double clicking the install.php file when FTP is open in IE. You need to type in the http://www.yourwebsite/blog/wp-admin/install.php, and it runs properly.

    Dan

  4. normantang
    Member
    Posted 8 years ago #

    Thank you Dan.

  5. maryp
    Member
    Posted 7 years ago #

    I got this same error.
    I know that the server (IPower) I am trying to install on is set up screwy so that it doesn't let php programs recognize the absolute path.
    For another program installed on the same server, I had to change the require to the exact path with no short cuts
    like this:
    require("/var/www/vhosts/booktalkauthors.com/httpdocs/FORMfields/FORMfields.php");

    So I assume that is what I have to do with Word Press, however I don't know which files I will have to do this on.. is it alot that have that "require_once" code??

    This server is actually owned by the woman I work with.. I installed Word Press on my own server.. with a different host.. and it worked perfectly. So I know what I'm doing.. just want to do all of the changes at once.

    Anyone know which files need to be changed??

  6. Chris_K
    Member
    Posted 7 years ago #

    If you have to change core WP files to get it installed, then I'd seriously suggest not bothering... every WP upgrade is going to kill ya.

    But first, I'd search here on iPower and see what other folks have learned or tried.

  7. Samuel B
    moderator
    Posted 7 years ago #

    I have 2 blogs set up on IPower and do not have to do what you suggest.
    You're doing something wrong.
    What kind of errors do you get? If it has to do with wp-config.php?

    If stuck:
    http://install4free.wordpress.com

  8. maryp
    Member
    Posted 7 years ago #

    I am doing EXACTLY the same thing that I did when I installed it on my other server..
    But with IPower I get this:

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('/var/www/vhosts/ebooktalk.net/httpdocs/wp-config.php'); require_once('/var/www/vhosts/ebooktalk.net/httpdocs/upgrade-functions.php'); $schema = ( isset($_SERVER['HTTPS']) && strtolower($_SERVER['HTTPS']) == 'on' ) ? 'https://' : 'http://'; $guessurl = str_replace('/wp-admin/install.php?step=2', '', $schema . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) ); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; header( 'Content-Type: text/html; charset=utf-8' ); ?>

    hide_errors(); $installed = $wpdb->get_results("SELECT * FROM $wpdb->users"); if ($installed) die('
    '.__('Already Installed').'
    '.__('You appear to have already installed WordPress. To reinstall please clear your old database tables first.').'

    '); $wpdb->show_errors(); switch($step) { case 0: ?>
    ReadMe documentation at your leisure.'), '../readme.html'); ?>

    *************
    The config file is there..and has correct info.
    I just checked the database..was going to clear tables and hit install again.. there are no tables.

    So far I put in that full path on the config file and on the wp-admin/install.php

    As I said.. I've had this same problem with another program.. that was installed perfectly on my server, but wouldn't work on IPower. Once I put the full paths in for FORMfields.. it worked.
    I just can't seem to get this to work.

    Perhaps it is different because this IPower account is a "Virtual Server" ???

  9. Dickie
    Member
    Posted 7 years ago #

    To be honest this looks like php is not running on the server.. I have taken install.php and opened it in a browser straight and your error messages are exactly what you get...
    To me this says that the server is just returning the RAW php,rather than processing it.

    Just out of interest, if you point your browser at the wp-config.php file what do you see?
    eg http://www.example.com/myblog/wp-config.php

    You should get a blank page... if you get anything else (including your database info) then PHP is NOT running on that server.

    P.S. For security reasons don't post the exact results here. just let us know what happens.

  10. Samuel B
    moderator
    Posted 7 years ago #

    None of that should affect it. Something is incorrect in your wp-config.php.
    Where exactly are you putting the "full path"?

    edit - at IPower php is running by default.

  11. Dickie
    Member
    Posted 7 years ago #

    Sorry, but if your browser is showing you this

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require_once('./upgrade-functions.php'); $schema = ( isset($_SERVER['HTTPS']) && strtolower($_SERVER['HTTPS']) == 'on' ) ? 'https://' : 'http://'; $guessurl = str_replace('/wp-admin/install.php?step=2', '', $schema . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) ); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; header( 'Content-Type: text/html; charset=utf-8' ); ?>

    Then PHP is not being parsed, as this IS the content of the intall.php as rendered by a browser.

    Try it !

  12. maryp
    Member
    Posted 7 years ago #

    How do I get the php to be parsed?
    As I said.. I've got a php Forum on this server and a program called Formfields on this server.. so the php is working for some things.

    To answer the question about where I'm putting in full path...
    It's whereever it says "require_once.."
    Instead of the "short" version ..I put:
    require_once("/var/www/vhosts/domainname.com/httpdocs/filename.php");

  13. Samuel B
    moderator
    Posted 7 years ago #

    Again:
    http://install4free.wordpress.com
    Let one of those guys take a look. This is unusual to say the least for IPower. It's one of the most straightforward install hosts we do.

  14. maryp
    Member
    Posted 7 years ago #

    This is what my config file looks like right now:

    ********
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', '***'); // The name of the database
    define('DB_USER', '***'); // Your MySQL username
    define('DB_PASSWORD', '***'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', /var/www/vhosts/ebooktalk.net/httpdocs/(__FILE__).'/');
    require_once(' /var/www/vhosts/ebooktalk.net/httpdocs/wp-settings.php');
    ?>

    I just tweaked some things and tried again.. same problem:
    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('/var/www/vhosts/ebooktalk.net/httpdocs/wp-config.php'); require_once('/var/www/vhosts/ebooktalk.net/httpdocs/upgrade-functions.php'); $schema = ( isset($_SERVER['HTTPS']) && strtolower($_SERVER['HTTPS']) == 'on' ) ? 'https://' : 'http://'; $guessurl = str_replace('/wp-admin/install.php?step=2', '', $schema . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) ); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; header( 'Content-Type: text/html; charset=utf-8' ); ?>

    hide_errors(); $installed = $wpdb->get_results("SELECT * FROM $wpdb->users"); if ($installed) die('
    '.__('Already Installed').'
    '.__('You appear to have already installed WordPress. To reinstall please clear your old database tables first.').'

    '); $wpdb->show_errors(); switch($step) { case 0: ?>
    ReadMe documentation at your leisure.'), '../readme.html'); ?>

    etc.. etc...

  15. Dickie
    Member
    Posted 7 years ago #

    All the stuff below the comment
    /* That's all, stop editing! Happy blogging. */

    should be left as it is from your downloaded files
    You should not need to change anything below there...hence the comment.
    You should be able to leave them as

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');

  16. Samuel B
    moderator
    Posted 7 years ago #

    EXACTLY!

  17. maryp
    Member
    Posted 7 years ago #

    Ok.. I went back to the original below Happy blogging..
    uploaded..
    ran the install.php
    Same problem!
    ( p.s. I do have a support ticket into IPower)

  18. Dickie
    Member
    Posted 7 years ago #

    if that's the case then you could try


    define('ABSPATH', '/var/www/vhosts/ebooktalk.net/httpdocs/');
    require_once('/var/www/vhosts/ebooktalk.net/httpdocs/wp-settings.php');

    As the lsdt two things in your file... what you had before would not have worked anyway.
    This assumes that your blog is at the root of your site.

  19. maryp
    Member
    Posted 7 years ago #

    Fixed it.. the php was not turned on for this particular domain name.. it was newly added to the server.
    Thanks for the help.

  20. Dickie
    Member
    Posted 7 years ago #

    Thought so... I assume that you have left the last two lines untouched?

Topic Closed

This topic has been closed to new replies.

About this Topic