WordPress.org

Ready to get started?Download WordPress

Forums

Cannot import WordPress.com blog into WordPress.org site (9 posts)

  1. Al
    Member
    Posted 9 months ago #

    Hi,

    I cannot import WordPress.com blog into WordPress.org site.

    I have been trying to import my wordpress.com blog - https://alexinwonderlandyoucankissmyart.wordpress.com -- into my new wordpress.org site - http://www.AlexInWonderland.co.uk

    I followed the instruction and exported my WordPress.com blog as a file (xml).
    I then followed the instructions to import it into my WordPress.org site - I used the WordPress importer Version 0.6.1 but it did not work - it just said that the files already exists.
    So I installed and tried the WP Re-Importer Version 1.1 but it still says that the posts already exists.

    I'm pretty sure that the WordPress version I am using is 3.6.1 - my hosting is at 123-reg.

    Please could someone help me with this, I really don't understand what to do and the tools that are meant to help do not work. Thank you.

  2. Terry Sutton (saltcod)
    Member
    Posted 9 months ago #

    ok. So.

    You've got an export file (xml) from .com, and a blank self-hosted site.

    You need to make sure that there's literally nothing in the new site. No posts, pages, menus, photos, nothing.

    When the new site is completely blank, go to Tools > Import > WordPress and go through that install screen. Then upload the xml file and let WP do it's thing. That should import all of your posts, pages, media, etc...(Make sure to click "Download media files" or whatever that option is at the bottom of the import screen.

    (you can't upload images here either. You'll need to use a third party service for that — imgur or similar —and post them here.)

    Good luck!

    Terry

  3. Al
    Member
    Posted 9 months ago #

    Hi, I have re done everything again, just as above, but it still isn't working. This is what I get when it finishes uploading:

    Media “72450_159740180723368_3632334_n” already exists.
    Media “Alexandra Carus Bowker | Visual Artist and Designer | Manchester” already exists.
    Media “Alexandra Carus Bowker | Visual Artist and Designer | Manchester” already exists.
    Media “Alexandra Carus Bowker | Visual Artist and Designer | Manchester” already exists.
    Media “ACarusBowker” already exists.
    Media “FACEBOOK | My Page | Album | Doodles & Sketches” already exists.
    Media “Final Year Degree Show 2008” already exists.
    Media “CAREER OBJECTIVE” already exists.
    Media “....a week @ Byam Shaw : metal & sculpture” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “Final Year Degree Show 2008” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “....a week @ Byam Shaw : metal & sculpture” already exists.
    Media “CAREER OBJECTIVE” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “....a week @ Byam Shaw : metal & sculpture” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “....a thing for hot metal...” already exists.
    Media “....a thing for hot metal...” already exists.
  4. Terry Sutton (saltcod)
    Member
    Posted 9 months ago #

    Right. Looks like you're not deleting your media first. Or else, it already exists from a previous import and is fine.

    Did you posts/pages import ok? Are the images hooked up right there?

  5. Al
    Member
    Posted 9 months ago #

    I followed all of the instructions to export my wordpress.COM blog - there didn't seem to be any problems in that.

    It was a brand new wordpress.ORG site, and it still did the above the first time.

    there is nothing that imported into my .ORG site from my exported .COM blog except a few categories, some media images and a load of tag -- but everything was jumbled and could only be found within my dashboard??

    I have just re deleted everything again..

  6. Terry Sutton (saltcod)
    Member
    Posted 9 months ago #

    Hey there,

    Ok. So here's the thing: the importer will download all of your images only if it needs to. If you already have the images in your Media Library, it won't download them again — it will give you those "Media already exists errors".

    > there is nothing that imported into my .ORG site from my exported .COM blog except a few categories, some media images and a load of tag

    So none of your posts or pages were imported? That's really really weird.

    Again, the only thing I can suggest is to delete everything — posts, pages, cats, tags, menus, media — and import again. Other than that, I'll really need to see some screenshots to be able to help.

    Terry

  7. nativenyker
    Member
    Posted 3 months ago #

    i am having the same problem. initially i was told the xml file was to large & caused a time out. but i found a splitter & it didnt fix it. & from what I can see many people have this problem & there is no answer any one can give to resolve it other than the post already exist = false & hostgator tried that from an old forum posting for old version & it didnt work on the new .org version.

    i wish someone could resolve this & give a definitive answer on how to correct this. very frustrating.

    was told that procuring the SQL Dump file from .com would work in the relocating of blog but they wont. i have made repeated request for it & they never even bother to answer my inquiry on the topic.

    SOMEONE PLEASE HELP! AM BEING HELD HOSTAGE BY WORDPRESS.COM!

  8. Terry Sutton (saltcod)
    Member
    Posted 3 months ago #

    hey @nativenyker. You're definitely not being held hostage by wp.com =) But you are having trouble.

    I'll do what I can here, but you really should start a new thread with a new issue.

    So you have an xml export AND a sql dump of your site? Is that right?

  9. nativenyker
    Member
    Posted 3 months ago #

    NO @Saltcod @TerrySutton - I have a XML file & wordpress.com wont give me a SQL Dump file. I'm just about giving up on it ever being able to migrate. was trying to get ahold of dreamhost - but they dont even have people to speak with. HostGator & GoDaddy dont know how to resolve the failure to import the XML file.

Reply

You must log in to post.

About this Topic