WordPress.org

Ready to get started?Download WordPress

Forums

WP Ultimate CSV Importer Plugin
[resolved] Cannot import to shared hosting (9 posts)

  1. ScroogeHDL
    Member
    Posted 1 year ago #

    I have two versions of the same WordPress site. One is on my localhost and the other is on shared hosting. I am able to import a csv file with 43 posts on my localhost without a problem. But I cannot duplicate this effort on my shared hosting site. The latest error message I received is "The connection to the server was reset while the page was loading." The file size is only 18.4 KB. I have ensured that the file permissions for the folder "imported_csv" are set to 777. All activated plugins are the same on the two sites. Any ideas?

    http://wordpress.org/extend/plugins/wp-ultimate-csv-importer/

  2. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Can you please check your php.ini and server related settings? As it is working in local, it should be because of server isuue.

  3. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Can you please check your php.ini and server related settings? As it is working in local, it should be because of server isuue.

  4. ScroogeHDL
    Member
    Posted 1 year ago #

    Here is a comparison between critical settings in my php.ini files:

    Dev Site || Localhost
    max_execution_time 30 || max_execution_time = 600
    max_input_time -1 || max_input_time = 300
    memory_limit 32M || memory_limit = 128M
    register_long_arrays On || register_long_arrays = Off
    upload_tmp_dir /data/tmp || upload_tmp_dir = \tmp
    post_max_size 25M || post_max_size = 128M

    Our upload file is only 18.4KB. The only significant difference that I can see is that on the dev site there is no upload_tmp_dir folder. Note that on the localhost, the file transfer takes less than a second. Any ideas?

  5. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Kindly update to version 2.5, hope this solves your issue as this version is updated with a fix for memory related issues.

  6. ScroogeHDL
    Member
    Posted 1 year ago #

    Just updated. Works perfectly on my localhost. Does not work on my shared hosting. Server times out :-(

  7. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Can you edit max execution time from 30 to 600? Other wise get support from hosting to solve this.

  8. ScroogeHDL
    Member
    Posted 1 year ago #

    I'm allowed to increase the max execution time to 60, but that's all. As I mentioned before, the execution time on my localhost is almost instantaneous. My client would rather avoid changing this parameter since it would also include our live site. I have asked hosting for support and they do not have any additional ideas. :-(

  9. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    I am sure that this issue is not because of our plugin. Cant find the reason? You can migrate your db from local to live temporarily.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags