WordPress.org

Ready to get started?Download WordPress

Forums

AutoNav Graphical Navigation and Gallery Plugin
[resolved] cannot get output from autonav (6 posts)

  1. hooklinesinker
    Member
    Posted 2 years ago #

    Hi,

    I am using autonav to create a category page with a grid of thumbnails and titles, listing all the posts in that category. i have used the following but it is not working.

    [autonav display="posts" postid="category:Attachments" columns="3" size="thumb"  titles="1"]

    I have put this on a page, (i am intending to make a page for each post category, so maybe it is something to do with there being no children, but i thought the postid bypassed that.

    I am not experienced with php, and by no means an expert in wordpress, but i can usually bend stuff to my will.

    Am I doing something simple wrong or is a fundametal misunderstanding on my part?!

    thanks for any advice,
    Luke

    http://wordpress.org/extend/plugins/autonav/

  2. hooklinesinker
    Member
    Posted 2 years ago #

    PS Sorry please do not be confused - Attachments is an actual post category, not a reference to wordpress post attachments

  3. wlindley
    Member
    Plugin Author

    Posted 2 years ago #

    That works correctly for me, with "Attachments" changed to a post category on a sample site. What exactly happens? Perhaps a URL to see. Also, what version of AutoNav? And, do the selected posts have thumbnails?

  4. hooklinesinker
    Member
    Posted 2 years ago #

    Hi, thanks for the response, re what happens, there is just no output at all, not even in the source. The version is 1.4.2. I am happy to give url but would rather pm it to you or somehow get it to you privately if possible.
    Cheers,
    Luke

  5. hooklinesinker
    Member
    Posted 2 years ago #

    and sorry yes all the posts have thumbnails as far as i understand it, the 'normal' category pages all have thumbs. Also I have titles switched on, so even if there were no thumbnails, i would have expected some output?

    Thanks again!

    Cheers,
    Luke

  6. wlindley
    Member
    Plugin Author

    Posted 2 years ago #

    The argument to the category tag is the slug of the category, not the category's title. In your case it would be something like this:

    postid="category:promotion-item-attachments"

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags