WordPress.org

Ready to get started?Download WordPress

Forums

CANNOT get JavaScript to show in a post (8 posts)

  1. Dawa1
    Member
    Posted 5 years ago #

    So I am trying to write a new post and use the britepic javascript with it. Whenever I put the javascript into the post, and click save draft, it always erases the <script> and </script>tags from it. I dont know why it does this, but it is very annoying. What can I do so that it does not take out the script opening and closing tags. And yes I am using the HTML view when writing a new post. It also inserts br tags after each line.

  2. iridiax
    Member
    Posted 5 years ago #

  3. Dawa1
    Member
    Posted 5 years ago #

    I have tried following those instructions, but no matter which one I try it still erases the script tags. I only havent tried the CDATA one, but I have tried implementing the others.... The thing is that I got it somehow into another post, but when I go into that one post, and copy everything to try to put it into the new post, it still erases the script tags, and replaces everything with br tags....

  4. Dawa1
    Member
    Posted 5 years ago #

    IT IS DRIVING ME CRAZY!!!

    Alright here is the code I am trying to put in:

    <script>
     britepic_id="919";
     britepic_src="http://www.muskiematt.com/images/Muskie%20Hold%20web.jpg";
     britepic_keywords="demo, keywords, shark, these are just tags, funny pic";
     britepic_show_ads=1;
     britepic_show_menu=1;
     britepic_href="http%3A//google.com";
     britepic_caption="Angry shark";
     britepic_width=400;
     britepic_height=380;
    </script>
    <script src="http://www.britepic.com/britepic.js"></script>
    <noscript><img src="http://www.muskiematt.com/images/Muskie%20Hold%20web.jpg" width="400" height="380"></noscript>

    and every time I hit save draft, it erases the script tags, as well as the noscript. WTH is going on?

  5. Dawa1
    Member
    Posted 5 years ago #

    Should I maybe try putting the source of the script into the header? Would that really do anything? I dont know what else to try

  6. Dawa1
    Member
    Posted 5 years ago #

    Any super smart goorus out there who can help? I got it working once, but cannot get it to do it again. Why the @#$% would this be happening now?? Just one of those weird things, but I have no clue where to go

  7. Dawa1
    Member
    Posted 5 years ago #

    WHAT?!?! I just noticed that I was trying this as a user who only has author privileges, is there a way to allow this for the authors? I will have authors who will have to put JavaScript in, so what is the issue here and how can I get it to allow JavaScript for those users?

  8. Dawa1
    Member
    Posted 5 years ago #

    What is the minimum level I can give a user permissions to be also able to use JavaScript?

Topic Closed

This topic has been closed to new replies.

About this Topic