WordPress.org

Ready to get started?Download WordPress

Forums

Cannot get Custom Fields to show ALL the time (3 posts)

  1. Strictly Software
    Member
    Posted 5 months ago #

    I have two sites on the same server.

    On one site when I go to Add/Edit a post the custom fields are all shown underneath (WordPress SEO, Robots, my own plugin values etc).

    However on another site I have to always go to the top, hit "screen options", tick the "Custom Fields" box to get them to show.

    However when the page refreshes the fields go away again. So I don't know how I can save these settings so they are always used on every post.

    I don't want to have to do all that work all the time to see which custom fields have been populated.

    Is there a setting somewhere OR a constant I need to set in my wp_config.php file to get them to show all the time?

    Thanks for your help!

  2. blacklinemedia
    Member
    Posted 5 months ago #

    Hi you can create a metabox to display these custom fields every time on the back end. http://codex.wordpress.org/Function_Reference/add_meta_box

    However if you want to avoid programming I would use a custom post type plugin to create the custom fields and meta boxes using a nice user friendly UI. I would recommend the types plugin http://wordpress.org/plugins/types/

  3. Strictly Software
    Member
    Posted 5 months ago #

    Hi

    Well can you tell me why on two different sites with the same set-up I get 2 different behaviours?

    Both have the same plugins installed but one always shows the custom fields the other one never - unless I press the "screen options" button and then tick the "custom fields" option.

    That is what I don't understand.

    Thanks

Reply

You must log in to post.

About this Topic