WordPress.org

Ready to get started?Download WordPress

Forums

Cannot find Content directory (WP-Content) (11 posts)

  1. bernatagullo
    Member
    Posted 5 years ago #

    I have the website up and running and this is the only thing I haven't managed to get running so far: installing plugins from the online interface.

    when I click install I just get the message "Unable to locate WordPress Content directory (wp-content)."

    the information that I need to enter to install a plugin is the login for the FTP server right? or is it something else?

    I tried to change the permissions of wp-content to 757 but to no effect

    all help welcome

    regards

  2. iridiax
    Member
    Posted 5 years ago #

    You can always install plugins by downloading them, using ftp to upload them to your plugins directory, and then activating them in the dashboard.

    http://codex.wordpress.org/Managing_Plugins#Plugin_Installation

  3. Shane G
    Member
    Posted 5 years ago #

    Hi,

    You can either install wordpress plugin from FTP service of your domain or there is an option in wordpress 2.8 that from wordpress admin area you can directly install the theme and plugins..

    If you have set the proper permissions to the blog then have a check with any of these options...

    Thanks,

    Shane G.

  4. bernatagullo
    Member
    Posted 5 years ago #

    2.8 that from wordpress admin area you can directly install the theme and plugins..

    If you have set the proper permissions to the blog then have a check with any of these options...

    Thanks,

    yes that's what I am talking about I want to set this to work properly by I get this error.

    Also could you specify a bit more about the "proper permissions" part?

    thanks a lot

  5. robballan
    Member
    Posted 5 years ago #

    Ha. Problem here is that the automatic upgrade scheme in WordPress is looking for the wp-content folder at the root level of the ftp directory – it isn’t if the blog is in a lower-level folder in the web folder hierarchy.

    So the fix is to

    a) create a local user whose home folder is the blog folder itself

    b) enable ftp for that user

    Then when you use the auto-update feature in WordPress, enter the login username and password for that user. Bingo.

    You may need to do this with a separate user for each blog (since the blog folders are in different locations).

  6. Samuel B
    moderator
    Posted 5 years ago #

    Problem here is that the automatic upgrade scheme in WordPress is looking for the wp-content folder at the root level of the ftp directory – it isn’t if the blog is in a lower-level folder in the web folder hierarchy.

    that is simply not true
    I have several installs in folders and subdomains and do not have to do any of that
    I think your problem may be the owner/group for the /wp-content has changed from primary ftp user being the owner to the web server being the owner
    This happens on some hosts when you upload media from wordpress admin

  7. robballan
    Member
    Posted 5 years ago #

    that is simply not true
    I have several installs in folders and subdomains and do not have to do any of that
    I think your problem may be the owner/group for the /wp-content has changed from primary ftp user being the owner to the web server being the owner

    Doesn't work that way for me. I'm the sysadmin for my server, and the entire content tree of the web server is owned by my username. All blog folders are owned by me. The blog folders' wp-content folders are owned by me. But I can't update any of the blogs using the auto tools without getting the error message that bernatagullo mentioned before.

    I've done a series of tests. If the home folder of the ftp user is not the blog folder itself, then the auto-install fails. Every time. If you change the home folder of the ftp user to the blog folder, it works. Every time.

    So what do you do if you have several blogs, all contained in separate folders inside the web folder? You can't use a single ftp user, unless you change his home folder to the desired blog folder every time you want to update it. Or you can create separate users, each of whose home folders are the separate blog folders, and then execute the ftp update using the appropriate username and password.

  8. rspindel
    Member
    Posted 4 years ago #

    Yes, this is true, this really should be fixed so that there is an extra field in the admin to allow a path to be set. Time to go write a plugin...

  9. dswordpress
    Member
    Posted 4 years ago #

    I *believe* this is a server configuration difference = 'file system method'.

    If you enter this in the wp-config.php it will work:

    if(is_admin()) {
    	add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
    	define( 'FS_CHMOD_DIR', 0751 );
    }
  10. peder77
    Member
    Posted 4 years ago #

    dswordpress - that snippet works perfect for me - and solved a lot of problems!
    Thank you very much for posting!

  11. junior_s85
    Member
    Posted 4 years ago #

    Thanks dswordpress, works for me too - wp v3.

Topic Closed

This topic has been closed to new replies.

About this Topic