WordPress.org

Ready to get started?Download WordPress

Forums

Cannot edit using the web editor (6 posts)

  1. scf1984
    Member
    Posted 4 years ago #

    I have just installed WordPress 2.8.4 on my Win2003 machine.
    When I use the web editor (for example, Plugins->edit), when I click the update button it just loads up the old version of the file...
    I did not change the theme nor did I install any plugin yet.
    I checked to see if the WordPress files are read-only, which they were, but the problem persists even after I unchecked their read-only attribute.

    Anyone knows what to do?

  2. Adam Harley
    Member
    Posted 4 years ago #

    Try clearing your cache and/or using Ctrl+F5 to ensure you're getting a fresh copy of the page.

  3. scf1984
    Member
    Posted 4 years ago #

    Thanks for the quick reply :)

    After I try updating a file I look at it with a text editor (Crimson) and the change does not show, even though WordPress claime the update was successful.
    So it is unfortunately not a cache problem.

  4. Adam Harley
    Member
    Posted 4 years ago #

    Try putting error_reporting(E_ALL); or error_reporting(E_ALL ^ E_NOTICE); at the bottom of your wp-config.php and see what it says when you try saving. WordPress likes hiding errors.

  5. scf1984
    Member
    Posted 4 years ago #

    I do not see any error showing up on the updating page after adding either of the two options you suggested...

  6. scf1984
    Member
    Posted 4 years ago #

    Ok the problem was permissions mishandle...
    I gave the user "Everyone" full control over these files, and now it works.
    However, I would like not to allow "Everyone" to mess around with my files... Which local user does the PHP script uses to edit those files?

Topic Closed

This topic has been closed to new replies.

About this Topic