WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot edit page with visual editor (8 posts)

  1. eharris
    Member
    Posted 5 years ago #

    My wife was trying to update a page on her site, and when she hit update, she got the message saying:

    Are you sure you want to navigate away from this page?
    The changes you made will be lost if you navigate away from this page.
    Press OK to continue, or Cancel to stay on the current page.

    When clicking "ok," it reloaded the edit window for that page without saving any of the changes, and when clicking "cancel," nothing happens. I tried disabling all of the site's plugins, in case that was the problem, but it did not help. I tried editing another page, and I could do so without any problem.

    I did find that I can edit this page from the HTML editor, and it's only in the visual editor that this problem occurs. On the other pages I tested, I could edit with either the visual or the HTML editor without any problem.

    Please note that the link I included is essentially a commercial link, but since it's for a small, local class of very limited interest, I hope it will be obvious that I'm genuinely trying to report a WordPress 2.7 problem, and not trying some lame SPAM attempt.

  2. cnymike
    Member
    Posted 5 years ago #

    I've suddenly started having this problem today with WP2.7. I have no idea what caused it to suddenly start doing this. I have installed a couple plugins since yesterday so hopefully that is it. but I've deinstalled them and the problem persists.

    Not only is the visual editor window blank, but each time I try to save changes, I get the message about are you sure you want to navigate away from the page, that you get.

    This is quite confounding.

  3. cnymike
    Member
    Posted 5 years ago #

    Isolated the problem to the cForms 10.2 plugin. Deactivated it and things are back to normal. will contact the developer and see what he has to say.

  4. dragontheory
    Member
    Posted 5 years ago #

    Any response from the plug-in dev?

  5. cnymike
    Member
    Posted 5 years ago #

    Was a conflict with the theme I was using. iThemes Flexx. Given that the plugin is more valuable than the theme, I dumped the theme and kept the plugin. Now using a different theme from StudioPress. All is well.

  6. sistemcrew
    Member
    Posted 5 years ago #

    go to the user Option and set the visual PANEL and save.

    All things ok,...

  7. eharris
    Member
    Posted 5 years ago #

    This problem eventually fixed itself, or updating to WP 2.7.1 did it, or something. Very strange that it only affected that one page.

  8. Genella
    Member
    Posted 4 years ago #

    My problem was not being able to navigate from the stylesheet in appearance/edit themes. After trying the change permissions and every thing else, it turned out to be my themes-Switch plugin. I just deactivated it and everything worked fine.

Topic Closed

This topic has been closed to new replies.

About this Topic