WordPress.org

Ready to get started?Download WordPress

Forums

Cannot disable comments on individual pages (8 posts)

  1. ungrim_7
    Member
    Posted 9 months ago #

    Website: piketourism.com

    No matter what I set in both the discussion settings or on screen options for individual posts, I cannot seem to get comment boxes to disappear from posts.

    I am using a slightly modified twenty thirteen template. VERY slightly modified. I only changed CSS, and inserted some code into the header that should not change the behavior of the site.

    I have disabled all plugins but this did not correct the issue.

    I have in no way modified the loop.

    Any idea how I can fix this issue?

  2. Tara
    Member
    Posted 9 months ago #

    - Allow/Disallow comments on specific page: - Where you create/edit posts or pages in admin, check if you have ticked comments for your posts/pages in the "discussion" box below the editor. If you don't see the "discussion" box there, in the 'screen option' dropdown field (located near the top right), there are tickboxes to show the 'discussion' box for the posts/pages. Tick mark it. In the 'discussion' box below the post/page editor, you can then allow/disallow comments for the page.

  3. ungrim_7
    Member
    Posted 9 months ago #

    This functionality is working on pages (when I un-tick the boxes for discussions/comments on edit pages it does remove).

    Screen Options are not working for posts. I uncheck the boxes you suggest and update, but they are still showing.

  4. Tara
    Member
    Posted 9 months ago #

    - Which theme are you using?

    - Test by switching to the default theme for a moment with ALL plugins disable.

  5. ungrim_7
    Member
    Posted 9 months ago #

    TwentyThirteen, very little modifications to it.

    Mainly just CSS changes.

  6. Tara
    Member
    Posted 9 months ago #

    Have you tested by switching to the UNMODIFIED default theme for a moment with ALL plugins disable?

  7. ungrim_7
    Member
    Posted 9 months ago #

    I apologize. I just figured something out. Screen Options does not disable comments, it disables items in the edit view.

    It is working afterall. I just thought you disabled comments from the screen options menu.

  8. Tara
    Member
    Posted 9 months ago #

    It is working afterall. I just thought you disabled comments from the screen options menu.

    Glad uou got it working :-)

Reply

You must log in to post.

About this Topic