WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Cannot deactivate nor uninstall W3 Total Cache (8 posts)

  1. centepines
    Member
    Posted 3 years ago #

    Hi
    I only find this problem in one particular blog of mine (same server).

    If I deactivate (or uninstall, delete) W3 Total Cache, every page of my blog (except the home page) shows this

    The requested URL /category/single-page/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I already checked that my .htaccess file it's clean of any W3TC directions.

    What can I do? The only way to keep my pages working fine is activating again the plugin.

    Thanks for your help

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. centepines
    Member
    Posted 3 years ago #

    Ok, I found another topic on this
    adding
    RewriteEngine On
    RewriteBase /

    fixed it.

    Just to clear up, I was using the last stable version - but also tried the development version 0.9 and it happened again.

    Cheers

  3. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    That doesn't clear anything up for me in terms of preventing the issue. Can you give steps to duplicate?

  4. centepines
    Member
    Posted 3 years ago #

    I deactivated W3TC, startet to get 404 error results for all my pages except home.

    Looked into my .htaccess file to see if there was some W3TC code leftover - there wasn't.

    Searched the forums a little more, come up with a fix: http://wordpress.org/support/topic/382725?replies=3

    Added

    RewriteEngine On
    RewriteBase /

    to my htaccess file, and everything was fixed.

    I don't know what else you need to know, if I can help you more, please let me know.

    As I told you before, I'm using version 0.9

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I'm not able to duplicate this. If you want to submit a bug submission form from the support tab of the plugin.

  6. MK Safi
    Member
    Posted 3 years ago #

    I added the magic two lines to my .htaccess and the same problem is fixed too! Thanks

  7. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Great.

  8. Prashrocks
    Member
    Posted 3 years ago #

    @frederick..

    i also started facing the same problem...
    i have done step by step all the procedure to uninstall the w3 total plugin as you said over here (http://wordpress.org/support/topic/plugin-w3-total-cache-unable-to-uninstall)

    now my .htaccess file and wp-config file are clean like before..

    but then to my website speed is not back to normal

    what to do???

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic