WordPress.org

Ready to get started?Download WordPress

Forums

Cannot Create New Blogs (10 posts)

  1. CliveSH
    Member
    Posted 3 years ago #

    Hi People, I have checked out other forum entries on this topic the main one that seemed to relate to my problem I found here; http://wordpress.org/support/topic/multisite-sub-directories-sub-sites-get-created-but-dont-work

    I've been running a multisite for almost a year. I've only a dozen sites created, the last time I created a site successfully was about 5 weeks ago. I've use few plugins with all active plugins disabled including buddypress I still cannot create new sites. The only 'new' theme I've used in the last weeks I've deactivated too and this makes no difference. I've updated WP to 3.03 and BP to latest version - makes no difference. With create a blog active and using this page it tells me there is a problem and to reenter my details AND nothing is created. If I use superadmin and list sites and create a site there I have the site added to the 'sites' list BUT edit gives me everything minus the Site Options (wp_25_options) and no database tables are created.

    I've tried the; define('DB_COLLATE','latin1_general_ci');
    suggestion, this causes no problems but I still cannot create a site. However, most of my sub-sites have pages / comments imported from WP sites created probably 3 years ago. Also, I remember seeing some error in the past relating to 'latin_sw' I cannot remember the exact spelling but I'm pretty sure it was sw on the end because I do have a Swedish client but everything is written in English.

    I'm using sub-domains x.example.com y.example.com. I have three MS installs on the same host SYN hosting and the others I can create new sites, so it's not a server change problem.

    Server error log gives nothing I can relate to with regards this problem. error log within WP gives repeated entries of;
    [06-Dec-2010 14:29:39] WordPress database error Table 'justbcsh_wpmu.wp_20_options' doesn't exist for query SELECT * FROM wp_20_options WHERE option_name = 'blogname' made by require, require_once, do_action, call_user_func_array, redirect_mu_dashboard, get_dashboard_blog, get_blog_details, get_blog_option

    Any suggestions would be gratefully received. thanks

  2. CliveSH
    Member
    Posted 3 years ago #

    I've checked that the db user has full privileges which is the case too . . .

    Error log within wp-admin gives plenty of errors relating to the COLLATE change;
    [11-Dec-2010 14:30:51] WordPress database error COLLATION 'latin1_general_ci' is not valid for CHARACTER SET 'utf8' for query CREATE TABLE wp_29_terms (
    term_id bigint(20) unsigned NOT NULL auto_increment,
    name varchar(200) NOT NULL default '',
    slug varchar(200) NOT NULL default '',
    term_group bigint(10) NOT NULL default 0,
    PRIMARY KEY (term_id),
    UNIQUE KEY slug (slug),
    KEY name (name)
    ) DEFAULT CHARACTER SET utf8 COLLATE latin1_general_ci made by wpmu_create_blog, install_blog, make_db_current_silent, dbDelta
    [11-Dec-2010 14:30:51] WordPress database error COLLATION 'latin1_general_ci' is not valid for CHARACTER SET 'utf8' for query

    The previous attempt '28' to create a site before the COLLATE change gave loads of error (I've just listed the first few here);

    [11-Dec-2010 14:03:36] WordPress database error Table 'justbcsh_wpmu.wp_28_options' doesn't exist for query SELECT option_name FROM wp_28_options made by wpmu_create_blog, install_blog, populate_options
    [11-Dec-2010 14:03:36] WordPress database error Table 'justbcsh_wpmu.wp_28_options' doesn't exist for query INSERT INTO wp_28_options (option_name, option_value, autoload) VALUES ('siteurl', 'http://main.just-2bme.com', 'yes'), ('blogname', 'My Site', 'yes'), ('blogdescription', 'Just another WSW Clients Information & Resources site', 'yes'), ('users_can_register', '0', 'yes'), ('admin_email', 'you@example.com', 'yes'), ('start_of_week', '1', 'yes'), ('use_balanceTags', '0', 'yes'), ('use_smilies', '1', 'yes'), ('require_name_email', '1', 'yes'), ('comments_notify', '1', 'yes'), ('posts_per_rss', '10', 'yes'), ('rss_use_excerpt', '0', 'yes'), ('mailserver_url', 'mail.example.com', 'yes'), ('mailserver_login', 'login@example.com', 'yes'), ('mailserver_pass', 'password', 'yes'), ('mailserver_port', '110', 'yes'), ('default_category', '1', 'yes'), ('default_comment_status', 'open', 'yes'), ('default_ping_status', 'open', 'yes'), ('default_pingback_flag', '1', 'yes'), ('default_post_edit_rows', '10', 'yes'), ('posts_per_page', '10', 'yes'), ('date_format', 'F j, Y', 'yes'), ('time_format', 'g:i a', 'yes'), ('links_updated_date_format', 'F j, Y g:i a', 'yes'), ('links_recently_updated_prepend', '', 'yes'), ('links_recently_updated_append', '', 'yes'), ('links_recently_updated_time', '120', 'yes'), ('comment_moderation', '0', 'yes'), ('moderation_notify', '1', 'yes'), ('permalink_structure', '/%year%/%monthnum%/%day%/%postname%/', 'yes'), ('gzipcompression', '0', 'yes'), ('hack_file', '0', 'yes'), ('blog_charset', 'UTF-8', 'yes'), ('moderation_keys', '', 'no'), ('active_plugins', 'a:0:{}', 'yes'), ('home', 'http://main.just-2bme.com', 'yes'), ('category_base', '', 'yes'), ('ping_sites', 'http://rpc.pingomatic.com/', 'yes'), ('advanced_edit', '0', 'yes'), ('comment_max_links', '2', 'yes'), ('gmt_offset', '0', 'yes'), ('default_email_category', '1', 'yes'), ('recently_edited', '', 'no'), ('template', 'twentyten', 'yes'), ('stylesheet', 'twentyten', 'yes'), ('comment_whitelist', '1', 'yes'), ('blacklist_keys', '', 'no'), ('comment_registration', '0', 'yes'), ('rss_language', 'en', 'yes'), ('html_type', 'text/html', 'yes'), ('use_trackback', '0', 'yes'), ('default_role', 'subscriber', 'yes'), ('db_version', '15477', 'yes'), ('uploads_use_yearmonth_folders', '1', 'yes'), ('upload_path', '', 'yes'), ('blog_public', '1', 'yes'), ('default_link_category', '2', 'yes'), ('show_on_front', 'posts', 'yes'), ('tag_base', '', 'yes'), ('show_avatars', '1', 'yes'), ('avatar_rating', 'G', 'yes'), ('upload_url_path', '', 'yes'), ('thumbnail_size_w', '150', 'yes'), ('thumbnail_size_h', '150', 'yes'), ('thumbnail_crop', '1', 'yes'), ('medium_size_w', '300', 'yes'), ('medium_size_h', '300', 'yes'), ('avatar_default', 'mystery', 'yes'), ('enable_app', '0', 'yes'), ('enable_xmlrpc', '0', 'yes'), ('large_size_w', '1024', 'yes'), ('large_size_h', '1024', 'yes'), ('image_default_link_type', 'file', 'yes'), ('image_default_size', '', 'yes'), ('image_default_align', '', 'yes'), ('close_comments_for_old_posts', '0', 'yes'), ('close_comments_days_old', '14', 'yes'), ('thread_comments', '1', 'yes'), ('thread_comments_depth', '5', 'yes'), ('page_comments', '0', 'yes'), ('comments_per_page', '50', 'yes'), ('default_comments_page', 'newest', 'yes'), ('comment_order', 'asc', 'yes'), ('sticky_posts', 'a:0:{}', 'yes'), ('widget_categories', 'a:0:{}', 'yes'), ('widget_text', 'a:0:{}', 'yes'), ('widget_rss', 'a:0:{}', 'yes'), ('timezone_string', '', 'yes'), ('embed_autourls', '1', 'yes'), ('embed_size_w', '', 'yes'), ('embed_size_h', '600', 'yes'), ('page_for_posts', '0', 'yes'), ('page_on_front', '0', 'yes') made by wpmu_create_blog, install_blog, populate_options
    [11-Dec-2010 14:03:36] WordPress database error Table 'justbcsh_wpmu.wp_28_options' doesn't exist for query SELECT option_value FROM wp_28_options WHERE option_name = 'home' made by wpmu_create_blog, install_blog, populate_options, __get_option
    [11-Dec-2010 14:03:36] WordPress database error Table 'justbcsh_wpmu.wp_28_options' doesn't exist for query SELECT option_value FROM wp_28_options WHERE option_name = 'siteurl' made by wpmu_create_blog, install_blog, populate_options, __get_option, __get_option
    [11-Dec-2010 14:03:36] WordPress database error Table 'justbcsh_wpmu.wp_28_options' doesn't exist for query INSERT INTO wp_28_options (option_name, option_value, autoload) VALUES ('home', 'http://main.just-2bme.com', 'yes') ON DUPLICATE KEY UPDATE option_name = VALUES(option_name), option_value = VALUES(option_value), autoload = VALUES(autoload) made by wpmu_create_blog, install_blog, populate_options, update_option, add_option
    [11-Dec-2010 14:03:36] WordPress database error Table 'justbcsh_wpmu.wp_28_options' doesn't exist for query SELECT autoload FROM wp_28_options WHERE option_name = 'blodotgsping_url' made by wpmu_create_blog, install_blog, populate_options, delete_option
    [11-Dec-2010 14:03:36] WordPress database error Table 'justbcsh_wpmu.wp_28_options' doesn't exist for query SELECT autoload FROM wp_28_options WHERE option_name = 'bodyterminator' made by wpmu_create_blog, install_blog, populate_options, delete_option


  3. Error log within wp-admin gives plenty of errors relating to the COLLATE change;

    And that's exactly what the issues is.

    When you changed things to laitn_whatever, that was part of the issues.

    Change *everything* you can find to UTF-8, general. (or whatever that exact syntax is.

  4. CliveSH
    Member
    Posted 3 years ago #

    Hi Andrea, so are you saying that I should COLLATE to UTF-8 or should I follow what is written on this page;
    http://www.blogsuccessjournal.com/blog-tips-and-advice/wordpress-tips-advice/seeing-weird-characters-on-blog-how-to-fix-wordpress-character-encoding-latin1-to-utf8/

  5. That link explains the collate issue and is the exact same thing I'm talking about - it was the link I was hunting down.

    they had the same issue you did, even though their post doesn't mention it.

  6. CliveSH
    Member
    Posted 3 years ago #

    One last question Andrea. Should I return the COLLATE line to what it was before attempting this?

    i.e. to;

    define('DB_COLLATE','');

    Also, having thought about this. My MS sites were all created as blank MU sites with wordpress MU 2.90. I imported some pages / posts / comments from established 'normal' WP sites to populate some of the blogs. So, in that respect each of my current MS sites should all be UTF-8 by default and they should not have this issue. Is that correct? Or does importing include the original character format and of it does then why are the dangers of this not mentioned / some work around written.

    Either way I've not imported anything since I created a new blog about 5 weeks ago, so it seems to me that this is a serious issue because any MS site could suddenly develop this problem (which seems to be the case when I look at other posts here).

    As others have mentioned here if this was a 'development' site then fair enough but it's not. I've three MU sites including one to test significant MS changes before implementing these on a 'real' MS site because I cannot afford my real sites to go down. Now I'm left in an uneasy space of not knowing if my MU site is going to 'freeze' at some point in the future for some 'vague' reason. It seems to me that deleting the entire MS site that is afflicted and importing my posts, pages and comments for each sub site again won't guarantee that this will solve this problem. Is this correct?

    I'm not an expert in php or linux or telnet so I'll be asking my host support if they can convert the database for me. BUT, this is a WORDPRESS site with an army of coders and yes I'm not one of those people but perhaps Andrea you can talk to the developers and ask that some effort is put into tracking this problem down and maybe writing a plugin to do the conversion, including copying the database before hand just in case?

    In the mean time thanks for your help.

  7. It's 100% a server issues. You;re now running server-level software and whiole you do not need to be an expert, you DO need to either start learning or hire someone if it;s that crucial. ;)

    I, and the devs, alreayd know why this occired - because some webhosts don't bother to look at server defaults and have it go to latin encoding, which is not correct. then when it gets sorted out on their end, *your* database gets screwed up.

    honestly in all the help I've done around here, I can count on one, maybe two hands where this exact issue occurred. I know you said you saw other threads, but they aren't all the same issue.

    Should I return the COLLATE line to what it was before attempting this?

    i.e. to;

    define('DB_COLLATE','');

    Try it like that AND try it with utf-8.

    Also if you're concerned about the characters inside an import file... open one up and LOOK at it.

  8. CliveSH
    Member
    Posted 3 years ago #

    OK Andrea.

    I've tried both (COLLATES) and all sites MS work but still no new sites can be created. I'll ask my hosting people to convert the database and see what happens with that. Thanks for your time.

  9. CliveSH
    Member
    Posted 3 years ago #

    Just to let everyone know I had my web site hosts change the DB base as per advice here; http://www.blogsuccessjournal.com/blog-tips-and-advice/wordpress-tips-advice/seeing-weird-characters-on-blog-how-to-fix-wordpress-character-encoding-latin1-to-utf8/

    and this made no difference. Although they are now checking everything else they can and if we do find what is wrong / a solution I'll post this here.

  10. make sure the db user has ALL permissions on the db.
    make sure all plugins are turned OFF before creating a blog, just to see if any of them were interfering.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.