WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot connect to dashboard of sub site (13 posts)

  1. BitchSpot
    Member
    Posted 3 years ago #

    I have just changed my single blog to a multi site network using the multi-site enabler plug-in. I got the sub site created. It's one sub folders instead of domains. When I click on Backend to set up the new sub site, it takes me to an unformatted front page, with no theme and the line Page Not Found at the top. Typing in the url with /wp-admin at the end brings up the same page.

    I have searched here and on Google, but can't seem to find any one else that has had the same problem. I know the server side is set up correctly, because my husband did this same thing before me and his multi-sites work fine.

    Any help of advice would be greatly appreciated.

  2. Funny, we have all kinds of threads about it...

    mod_rewrite is not reading your htaccess file properly.

  3. BitchSpot
    Member
    Posted 3 years ago #

    I didn't see any threads about it in the first couple of pages I looked at, sorry.

    I was looking at both my .htaccess and one that I know works, plus comparing it to some that have been posted here and I'm not seeing any commonality between any of them. Since I know that my server's mod_rewrite does support multisite, maybe there's something wrong with the .htaccess itself. Here's what mine says:

    #Made Multi-Site with Multi-Site Enabler 1.4#

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index\.php$ - [L]

    # uploaded files

    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule ^ - [L]

    RewriteRule . index.php [L]

    Is there something I need to fix?

  4. The htaccess is fine.

    mod_rewrite can be enabled & running on the server, but instructed to NOT read particular folders.

    So you have to tell it specifically to read this.

  5. kateM82
    Member
    Posted 3 years ago #

    I am having the same problem - how do you do that? I tried searching for similar posts but can't find any recent ones?

  6. Got access to Apache files and the httpd.conf? If you can shh via root, then you do. ;)

    AllowOverride FileInfo Options

    is what you need.

  7. BitchSpot
    Member
    Posted 3 years ago #

    Unfortunately, as far as I can tell, we don't have access to those files. However, as I said, there's already a multisite WP install running on the site, therefore I know it works, I just can't get this install to operate properly.

  8. kateM82
    Member
    Posted 3 years ago #

    Hi Andrea,

    Were are those files, and what needs to be done to them? Everything you just said went over my head?

  9. @Bithchspot - but this is in a second web account, right? Apache can be told to read the htaccess file in one folder and not in the other. Contact your webhost. Tell them the htaccess is not kicking in.

    @dddaily - same as above. Contact your webhost. Tell them the htaccess is not kicking in.

  10. BitchSpot
    Member
    Posted 3 years ago #

    It's running in a second subdirectory on the same account so I would assume that it's all running under the same rules. However, I will put in an IT request and see what they say.

  11. It's a web server. You can't assume these things. ;)

  12. BitchSpot
    Member
    Posted 3 years ago #

    After explaining things to them several times, they did something that fixed the problem, not quite sure what, but it works. Thanks for your help.

  13. For searchers:

    AllowOverride FileInfo Options may have to be in the vhost in Apache for that web account.

Topic Closed

This topic has been closed to new replies.

About this Topic