WordPress.org

Ready to get started?Download WordPress

Forums

Cannot configure or Arrange widgets. (36 posts)

  1. Intrepide1
    Member
    Posted 8 years ago #

    I am unable to move any widgets while in Presentation/Sidebar Widgets. Also, I cannot configure any of them. There is absolutely no response to clicking or dragging; only highlighting. Furthermore, if I access the page with Firefox 1.5.0.4, my widgets for Sidebar 1 appear behind the creme-colored "Default Sidebar" box rather than below it.

  2. yosemite
    Member
    Posted 8 years ago #

    Try turning off any admin-themes and check to see if the /scriptaculous directory is in /wp-includes/js/

  3. Intrepide1
    Member
    Posted 8 years ago #

    I'm not familiar with admin-themes. Also, that directory does not exist in my installation.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    Well then you need to put it there.

    When you installed the widgets plugin, one of the things in the instructions was to move the scriptaculous folder (the one that came with the widgets plugin) into the /wp-includes/js directory. If you don't do that then it doesn't work, as you have discovered.

  5. Intrepide1
    Member
    Posted 8 years ago #

    Alright, I fixed that, but it hasn't resolved my issue, and now the Sidebar 1 column appears above the Available Widgets Column.

  6. Intrepide1
    Member
    Posted 8 years ago #

    I just changed some security settings in my Internet Options, and that only changed one thing; namely, I can now drag the widgets. Clicking on the Configure box still does nothing, and the page display is still out of wack.

  7. yosemite
    Member
    Posted 8 years ago #

    Try deactivating any other plugins and test again?

    EDIT: And make sure you clear the cache.

  8. Intrepide1
    Member
    Posted 8 years ago #

    Alright, deactivating Now Reading 4.2 fixes the issue of not being able to configure any widgets, but the display is still messed up. The "Sidebar 1" column is completely left, while the "Available Widgets" column is below it and is nearly the full width of the screen with the widgets inside being mis-shapen as well

  9. Intrepide1
    Member
    Posted 8 years ago #

    I've even updated to the newest trunk of the widgets plugin now, and still nothing.

  10. yosemite
    Member
    Posted 8 years ago #

    Sorry, think I ran outta steam.

    It appears there have been multiple releases of "Version 1.0" of widgets.php. One I tried (from svn) has all the 'unused' widgets sitting in a box at bottom of screen. That one won't work for me.

    Another one that I originally downloaded from Automattic (not the same one there now), has the 'unused' widgets sitting in a 'sidebar' arrangement on the left side of the screen, stacked vertically. That one does work for me.

    The included scriptaculous files changed as well. I see no difference in behavior regardless of those (either 'version' seems to work fine).

  11. skeltoac
    Member
    Posted 8 years ago #

    Sorry about the lack of version numbers, folks. We'll shore that up for you.

    The latest change (90 minutes ago) fixed a behavior like the one you describe, which only happens with certain themes. You can get the latest plugin file here:

    http://svn.wp-plugins.org/widgets/trunk/widgets.php

  12. yosemite
    Member
    Posted 8 years ago #

    Just tried it, looks good so far (as in public page shows widgets). Very cool.

    Thanks! (Andy?)

  13. Intrepide1
    Member
    Posted 8 years ago #

    I've updated everything, and my problems persist. I don't understand what I could have wrong.

  14. Intrepide1
    Member
    Posted 8 years ago #

    Nothing changes if Widgets is the only enabled plugin; except that deactivated widgets disappear, of course.

  15. yosemite
    Member
    Posted 8 years ago #

    Sure your cache is clear (browser/server/wp-cache)?

  16. katesgasis
    Member
    Posted 8 years ago #

    In the latest version of Widgets plugin, I was able to make it work by just uploading the whole folder in the plugins dir. Didn't moved the js to the wp-include/js folder.

  17. skeltoac
    Member
    Posted 8 years ago #

    The scriptaculous directory can be in the widgets directory or the js directory. It doesn't matter.

    I updated the plugin a short while ago for backwards compatibility. If something is still wrong, I'm going to need more details or more access. If you want me to log in to your system and check it out, email creds to my username at gmail.com.

  18. Intrepide1
    Member
    Posted 8 years ago #

    I updated, and still trouble. I've cleared my cache a hundred times. I'll email you, and hopefully you can pick out the problem.

  19. Alienboy
    Member
    Posted 8 years ago #

    I've just installed the widgets files and although I can drag and drop the widgets, I can't configure them and the following appears at the bottom of the screen:-
    Fatal error: Call to undefined function: wp_nonce_field() in /home/zeitungt/public_html/wp-content/plugins/widgets/widgets.php on line 635

    Any ideas please?

  20. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    The scriptaculous directory can be in the widgets directory or the js directory. It doesn't matter.

    You might want to give that particular code another look then, because it certainly does matter on my blog. If the scriptaculous directory is in the widgets directory, then it certainly doesn't work on my box.

  21. Intrepide1
    Member
    Posted 8 years ago #

    Another note, I have a little error symbol show up in IE when I'm on the Sidebar Widgets page.

    Line: 279
    Char: 5
    Error: 'Draggables.drags[...].element.id' is null or not an object
    Code: 0
    URL: http://sperolaus.com/wp-admin/themes.php?page=widgets/widgets.php

  22. yosemite
    Member
    Posted 8 years ago #

    The plot thickens! *grabs some popcorn*

  23. Intrepide1
    Member
    Posted 8 years ago #

    I suppose I should mention that I'm running WP 2.0.3. Nothing I do helps this. Am I the only one experiencing this?

  24. yosemite
    Member
    Posted 8 years ago #

    What theme are you using?
    Can you list the active plugins here?

  25. Intrepide1
    Member
    Posted 8 years ago #

    I've already disabled all of them, with one obvious exception. The theme is Dusk, but that doesn't affect the admin section.

  26. yosemite
    Member
    Posted 8 years ago #

    You deactivated the 2.0.3 tuneup plugin?

  27. Intrepide1
    Member
    Posted 8 years ago #

    I don't have that as far as I know.

  28. Intrepide1
    Member
    Posted 8 years ago #

    Okay, I found it and installed and activated it. No changes to my issue.

  29. Intrepide1
    Member
    Posted 8 years ago #

    So, I just did a brand new install. Guess what, the Available Widgets is below Sidebar 1 and is full width. Pretty conclusive for me.

  30. yosemite
    Member
    Posted 8 years ago #

    Exactly what can be concluded from that?

    The "Sidebar 1" column is completely left, while the "Available Widgets" column is below it and is nearly the full width of the screen

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags