WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] [closed] Cannot checkout, "Purchase" button only refreshes the page (38 posts)

  1. robotor
    Member
    Posted 5 months ago #

    Using Plugin Version 3.8.13.3

    Customers cannot purchase anything, clicking on the "purchase" button just refreshes the page. Using Paypal standard.

    Have read other threads and cannot find a solution. Please help!

    https://wordpress.org/plugins/wp-e-commerce/

  2. dkbrown
    Member
    Posted 5 months ago #

    Same issue here.

  3. robotor
    Member
    Posted 5 months ago #

    I literally had to take the store down and post a bunch of messages asking people to email me to buy something.

  4. Mihai
    Member
    Plugin Author

    Posted 5 months ago #

    IF you guys are using Shipping same as billing try disabling that option and see if it works without it.
    Regards
    Mihai

  5. dkbrown
    Member
    Posted 5 months ago #

    Just tried, that did not work for me.

  6. robotor
    Member
    Posted 4 months ago #

    I'm about ready to abandon this plugin on all of my sites.

  7. Mihai
    Member
    Plugin Author

    Posted 4 months ago #

    Try enabling debug in wp-config.php file to see if any errors show up.
    If that does not help try posting a premium support topic with getshopped.

    Regards

  8. dans87
    Member
    Posted 4 months ago #

    I am having the same issue and not using the same as billing option. Since this is marked as resolved, what was the fix?

  9. Wilford
    Member
    Posted 3 months ago #

    Yes, please offer a true solution. I too am experiencing this issue and it is NOT resolved here.

  10. Justin Sainton
    Member
    Plugin Author

    Posted 3 months ago #

    Hi robotor, dans87 and Wilford,

    Would any of you be willing to share your URLs here? Feel free to shoot me an email at justinsainton at gmail, I'd be more than happy to help you debug this issue.

  11. Wilford
    Member
    Posted 3 months ago #

    I disabled the "Same Shipping Address" option and it works now. But this now creates a major hassle for my customers and will surely lead to cart abandonment. Is there a new version being cooked up to solve this??

  12. Justin Sainton
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Wilford,

    Indeed, we have fixed MANY "shipping same as billing" bugs in our impending 3.8.14 release, and have completely re-architected the theme engine entirely in the subsequent 3.9.0 release, which will be released in 4-5 weeks.

    If you have a staging environment for your website, I'd highly recommend testing out our master branch on GitHub. That has all the shipping same as billing fixes that will be included in 3.8.14, it may very well solve your issues, too.

    In 3.9.0, we've actually changed the behavior based on usability studies - instead of assuming that you DON'T want to ship to the same address by default, it assumes that you do.

    Hope that's all helpful!

  13. Wilford
    Member
    Posted 2 months ago #

    I upgraded to 3.8.14.1 and this still does not work. Whenever I click the Buy Now button, the page simply refreshes. I have PayPL PROPERLY SETUP AT THE PAYMENT GATEWAY. WHAT GIVES??

  14. SandraGaffney
    Member
    Posted 2 months ago #

    I have the same issue, I have wordpress 3.9.1. and wp e commerce VersiĆ³n 3.8.14.1

    The page only refreshes I have disabled shipping same as billing as stated above

    This is my stage site:
    http://domoproducciones.com/tienda/products-page/refacciones/

    I hope you can help

    Thanks,
    Sandra

  15. skviotu
    Member
    Posted 2 months ago #

    Same here after update to 3.8.14.1

    My website is sportstradingsystem.com

  16. Mihai
    Member
    Plugin Author

    Posted 2 months ago #

    @everyone above
    Can you make sure you have the Country/state fields enabled on your checkout form ? (Store -> Checkout)

  17. skviotu
    Member
    Posted 2 months ago #

    nothing changed, still only refresh page

  18. lakej
    Member
    Posted 2 months ago #

    I have the same problem. We need to solve this as soon as possible. This is not good.

  19. lakej
    Member
    Posted 2 months ago #

    My website:

  20. Jeff Pye Brook
    Member
    Posted 2 months ago #

    @skviotu I tried your site and went to paypal?

  21. Jeff Pye Brook
    Member
    Posted 2 months ago #

    @lakej what is your web site link, I can take a quick look

  22. lakej
    Member
    Posted 2 months ago #

  23. Mihai
    Member
    Plugin Author

    Posted 2 months ago #

    @lakej you seem to have a database connection issue

  24. lakej
    Member
    Posted 2 months ago #

    I know. But that is something new, and I am talking to serveradministrator right now. But the issue with eCommerce has nothing to do with that. We had no problem at all until we updated to latest version.

  25. lakej
    Member
    Posted 2 months ago #

    The problem with the database was only temporary. Seems to be solved now. But the problem with eCommerce persist? This must be a problem that comes with the latest update, or it depends on the update itself.

  26. Mihai
    Member
    Plugin Author

    Posted 2 months ago #

    @lakej
    Can you please enable the country and region fields on the checkout page and test again ?

  27. lakej
    Member
    Posted 2 months ago #

    Ok, have done it now. However, no difference

  28. Mihai
    Member
    Plugin Author

    Posted 2 months ago #

    @lakej mail me admin logins to mihai @instinct.co.nz

  29. lakej
    Member
    Posted 2 months ago #

    I have now send you admin logins!

  30. skviotu
    Member
    Posted 2 months ago #

    It work for me now, after change Country/State as above.

    But it only works while using other browsers than google chrome.

    So guys first check other browsers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic