WordPress.org

Ready to get started?Download WordPress

Forums

Cannot change homepage title (9 posts)

  1. victoriaann
    Member
    Posted 2 years ago #

    Hi all,

    I'm having problems changing the title of my homepage (http://www.victoriaphippsphotography.co.uk/). I've changed the site title in "general settings" and this alters the titles of all pages within the site EXCEPT the homepage which remains the same.

    I'm using a prophoto theme called 'after midnight' but have been trying to solve this problem since long before I swapped themes, so think it must be a wordpress thing.

    Any help would be greatly appreciated!

    Thanks in advance

  2. toddbublitz
    Member
    Posted 2 years ago #

    Vicoriaann - I'm having the same issue. I'll post here when I get it solved.

    By the way, what plugin are you using to display photos on your homepage? I really like it!

  3. dtrickky
    Member
    Posted 2 years ago #

    What exactly are you trying to change in the title? Is your front-page set to a specific page in the "reading" settings?

  4. toddbublitz
    Member
    Posted 2 years ago #

    Under Settings -> Reading, I have "Front page displays" -> "A static page" ("GET TO KNOW plum"). I choose a page that is not "Home" (in fact, I don't have a page named Home any more). But, in my menu, Home is still listed and does direct you to page I chose under Settings. I'd like "Home" in my menu to be "GET TO KNOW plum".
    Here is the site in progress:
    http://www.getsurfeddenver.com/thinkplum

    I think my problem may have possibly arisen because I originally created a few new pages, deleted the (stock) Home page and then changed my Settings -> Reading -> Front page displays to Static page. Perhaps I should have created the new page first, changed my Settings -> Reading -> Front page displays to Static page (chosen the correct page), then delete the stock Home page.

    Thoughts?

  5. toddbublitz
    Member
    Posted 2 years ago #

    I just uploaded my custom theme and the problem has resolved. Hmmmm...

    victoriaann - I'll keep my eye out for a solution to your issue.

  6. knownotknow
    Member
    Posted 2 years ago #

    I had the same problem with WP3.3.1. I began searching through the MySQL databases and found the entry that was retrieving the title text.

    After you get into your WP database:
    1) find table: wp_options
    2) search for option_name = aioseop_options
    3) you should see in the mess the text for your current title between quotes. Keep the qoutation marks, but replace the text with what you want your title to be.

    I wouldn't recommend this for anyone uncomfortable with MySQL, but this is how I fixed it.

  7. joanl
    Member
    Posted 2 years ago #

    I am having the same problem with http://www.woodworkerstudio.co.uk/ -when I view the page source, the homepage title tag is blank. With all other pages I have tried to make the titles more meaningful so they are picked up by search engines, however the titles also then appear within the site navigation making the the nav links far too long. Currently the page titles too simple ie 'about |', 'kitchens |' etc which is not obviously ideal for SEO.

    I am not familiar with MySQL and wondered if there was an alternative, simpler way to rectify this?

    Under Settings -> Readings, the front page is set to display a static page called 'home'. In Settings -> General, the Site Title is 'The Woodworker's Studio'.

    Thanks in advance

  8. toddbublitz
    Member
    Posted 2 years ago #

    joanl,

    I recommend you install "All in one SEO Pack". It's great for SEO, plus it allows you to rename the Titles of your pages, add descriptions, etc. These SEO fields appear for each page, below the editing area.

  9. joanl
    Member
    Posted 2 years ago #

    Thanks very much for your reply, I will give the 'All in one SEO Pack' a go.

    Cheers
    Joan

Topic Closed

This topic has been closed to new replies.

About this Topic