WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot change header image (11 posts)

  1. thestijg
    Member
    Posted 1 year ago #

    OS X
    Xampp

    I cannot change the header image of BlogoLife. Alternatively I also copied in Finder (the Mac Explorer) the image to the header file of the theme, but I get this error message: Unable to create directory wp-content/uploads/2013/04. Is its parent directory writable by the server?.
    I tried Twenty Ten as well and experienced the same problem.

    Hope anybody is able to help me out here.

    Thanks in advance,

    Cheers

  2. Lindsay T
    Member
    Posted 1 year ago #

    This is a permissions problem.

    As you appear to be developing on your local machine, security shouldn't be an issue so could just change the permissions on wp-content/uploads to 777.

  3. thestijg
    Member
    Posted 1 year ago #

    I saw there was no such directory as wp-content/uploads/2013/04, so I created the directory and folders myself. To be on the safe side, I also changed the permissions into "Read/Write".

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    No - that won't work in 99.9% of cases. WordPress must create the relevant folder. Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

  5. thestijg
    Member
    Posted 1 year ago #

    Well, it does work (locally) but I am afraid I don't understand what you mean with "try 767, 775 or 777" and what exactly I should do.
    Thanks for your help.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    See Changing_File_Permissions. This may not be an issue for you if you are running a local install using WAMP or similar.

  7. thestijg
    Member
    Posted 1 year ago #

    As I said in my first post, I have a Mac and use Xampp.
    Hope this helps.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    I'll see if I can get a Mac user to have a look at this. I'm not a Mac user myself, so I don't know if Mac/Xamp uses file or folder permissions. I knows Windows doesn't.

  9. Hi thestijg,

    On your local site's /uploads/ directory, you need to open the 'Info' window, either by right-clicking and selecting 'Get Info' or using CMD + i

    Under the 'Sharing & Permissions' section, check to make sure that your user account has 'Read & Write' permissions. If not, make sure it does. For example: http://cl.ly/image/261D1l0L2x26

  10. If you're using the built in apache/php/mysql localhost server under OS X, you need to change permissions in the terminal command line.

    But with XAMPP, see http://stackoverflow.com/questions/9046977/xampp-permissions-on-mac-os-x to change permissions within XAMPP.

    1- Open applications folder
    2 -Locate XAMPP folder
    3 -Right click, get info (as described above)
    4 - In pop-up window locate the 'sharing & permission' section
    5 -Click the 'locked' padlock symbol
    6 -Enter admin password
    7 - Change 'Everyone' permissions to read & write
    8 - In the get info window still, select the 'cog' icon' drop down option at the very bottom and select 'Apply to enclosed items' this will adjust the permission across all sub-folders as well.
    9 - Re-lock the padlock symbol
    10 - Close the 'Get Info' window.

    XAMP runs on its own and is separate from OS X localhost.

  11. vicchi
    Member
    Posted 1 year ago #

    As a Mac user I can say that Macs (running OS X at least) absolutely use file and folder permissions. OS X is basically a UNIX box with a rather nice UI over it (that's a gross simplification but will suffice for this point).

    You can either use Finder to set the permissions; navigate to /Applications, find your XAMPP app, control-click and select Show Package Contents, authenticating if needed and set the required permissions on the folders as needed.

    Or you can use the shell from within /Applications/Utilities/Terminal.app and navigate to within the XAMPP app and set permissions using the standard UNIX chmod command as documented here: http://codex.wordpress.org/Changing_File_Permissions

    Feel free to ask for more help as you go along; I can always install XAMPP on my Mac to help out here.

    -Gary

Topic Closed

This topic has been closed to new replies.

About this Topic