WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot Add Users (7 posts)

  1. Barry
    Member
    Posted 2 years ago #

    I cannot add any users. I am able to delete, but not add. It says that it adds the user but it does not. I also tried adding it from the WP registration page and I get the error message "ERROR: Couldn’t register you... please contact the webmaster !".

    It has been awhile since adding a new user, so I have not idea what has changed since then. But I did go back and add any plugins that I might have deleted to see if that would work and it did not.

    Any ideas would be appreciated.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  3. Barry
    Member
    Posted 2 years ago #

    Yes I just did a reinstall. Same issue. Checking plugins now. But I really do not have many installed.

    When I do register a new user I get this email message:

    New user registration on your site .....................:
    Username:
    E-mail:

    Note, username and password are blank.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    No one suggested a re-install. Please re-read the suggestions I gave above.

  5. Barry
    Member
    Posted 2 years ago #

    Thanks..... a re-install didn't hurt.

    But I found that a plugin left a table index in users that could not be null. After removing the index, things worked just fine.

    Thanks for pointing me in the right direction.

  6. jdimaging1
    Member
    Posted 1 year ago #

    I have been struggling with this since the week end.

    I have de-activated all my plug ins one by one and I still cannot add users from the back end and when I set up a new user.

    New user registration on your site .....................:
    Username:
    E-mail:

    I used softalicous on my server but I found when it auto installed there were tons of problems on the install.

    I manually reinstalled but no idea how to install the database.

    I have over 7000 linked so I surely hope I can get this going.

    Thank you for listening

    Darlene

  7. Barry
    Member
    Posted 1 year ago #

    Darlene,

    You probably have the same problem/error I did. Check your database under wp_users. I cannot remember exactly which one was null, that should fix it. If you can't do that, then maybe creating a new database and copying data over could fit it but it also might copy over the same table settings.

Topic Closed

This topic has been closed to new replies.

About this Topic