WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] cannot activate return fatal error (14 posts)

  1. Manoj Chacko
    Member
    Posted 1 year ago #

    cannot activate return fatal error

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Manoj Chacko
    Member
    Posted 1 year ago #

    Any updates on this my site is community.mis.temple.edu, we are using the genesis theme. This is very critical for our department, please provide any assistance possible.

    Thanks
    Manoj

  3. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Uninstall the plugin and reinstall through the dashboard. If the plugin still produces an error, you will have to check your server's error log for the actual error.

  4. Manoj Chacko
    Member
    Posted 1 year ago #

    This is the error

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 57 bytes) in E:\xampp\htdocs\wp-includes\meta.php on line 571

  5. esmi
    Forum Moderator
    Posted 1 year ago #

  6. Manoj Chacko
    Member
    Posted 1 year ago #

    still did not work

  7. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    If the error is the same, you either didn't increase the memory limit enough, or you did not increase the memory limit.

  8. Manoj Chacko
    Member
    Posted 1 year ago #

    My memory limit is currently set to 256M, I had increased it to 384M.

    But my question is why would it require that much memory to run this?

  9. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    The more plugins you use, the more memory is used. The more links and elements that are on your site, the more memory WordPress HTTPS will use.

  10. Manoj Chacko
    Member
    Posted 1 year ago #

    I still get a similar error. I think I figured out the problem.

    The wordpress admin memory limit, limiting it. Why would this script take more than the admin memory limit.

  11. Manoj Chacko
    Member
    Posted 1 year ago #

    I increased it from 256 (which was the admin memory limit) to 384

    message changed, looks like even that was not enough.I am kind worried increasing it because it might cause a performance issue?

    Any suggestion?

  12. Manoj Chacko
    Member
    Posted 1 year ago #

    I increased it from 256 (which was the admin memory limit) to 384

    message changed, looks like even that was not enough.I am kind worried increasing it because it might cause a performance issue?

    Any suggestion?

  13. Michael
    Member
    Posted 1 year ago #

    I was using WordPress 3.4.2 and WordPress HTTPS 3.2.2.

    After upgrading from WordPress HTTPS 3.2 to 3.2.2, I started getting error 500s when I tried to create new sites in a WordPress multisite environment. Even though the site was created, my custom settings defaults were not carried over to the new sites (I use the wpmu-new-blog-defaults plugin for that). I confirmed the problem only occurred when WordPress HTTPS was active in my dev environment, so I de-activated the plugin on our production environment, and confirmed the same thing there.

    We bumped up the memory via php.ini, but I could not re-activate the WordPress HTTPS plugin. On our QA system, I got the error "Fatal error: Allowed memory size of 268435456 bytes exhausted," so I figured that had to be default WP_MAX_MEMORY_LIMIT of 256M. I added the WP_MAX_MEMORY_LIMIT directive to my wp-config file and increased the value to 512M, and got another fatal error, 536870912 bytes exhausted. I increased the value 1024M, and I was finally able to activate the plugin.

    I tried the same thing on our production environment with a memory limit of 1024M; however, I got a "504 Gateway Time-out" error from our nginx proxy server after 120 seconds.

    My question is whether the new Network Settings feature causes the WordPress HTTPS to utilize an extraordinary amount of memory and time to activate if there are many sites in the network. My QA environment database hasn't been synched in awhile and only has 72 sites. My Production environment has 107 sites.

    Similarly, on the Network Settings page for WordPress HTTPS, I was able to set the "New Site Defaults" on an environment with only a dozen blogs. However, trying to set the "New Site Defaults" on my aforementioned QA and Prod environments caused the little spinner donut to spin and spin. I even let it spin for 10 minutes, but still could not change those settings.

    I downgraded WordPress HTTPS to version 3.2 on my production environment. I was able to activate the plugin with WP_MAX_MEMORY_LIMIT set to only 256M. I was also able to create new sites once again without error.

    I really love this plugin. It is the only one that reliably knocks out the secure and insecure content warnings over https. I hope that my lengthy issue report can help with the further development of this plugin.

  14. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    I don't see any reason that the plugin should be using that much memory just to set settings on multiple blogs. The code I'm using is pretty straight forward, so I'm not sure what's going on. I'll set up some tests on my site and see what I can figure out. Thanks for the feedback.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.