WordPress.org

Ready to get started?Download WordPress

Forums

Cannot activate plugin ("pluggable.php on line 868" error) (23 posts)

  1. omerosen
    Member
    Posted 4 years ago #

    I installed a plugin that didn`t allow me to access the admin, so I turned all plugins off through PHPMYADMIN and deleted the plugin through FTP.
    Now I can access my blog, but when I try to activate any of the plugins I get this error:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /mounted-storage/home39c/sub001/sc30862-QUJV/sundsvallexpress.se/wp-admin/includes/plugin.php on line 297

    Warning: Cannot modify header information - headers already sent by (output started at /mounted-storage/home39c/sub001/sc30862-QUJV/sundsvallexpress.se/wp-admin/includes/plugin.php:297) in /mounted-storage/home39c/sub001/sc30862-QUJV/sundsvallexpress.se/wp-includes/pluggable.php on line 868

    Warning: Cannot modify header information - headers already sent by (output started at /mounted-storage/home39c/sub001/sc30862-QUJV/sundsvallexpress.se/wp-admin/includes/plugin.php:297) in /mounted-storage/home39c/sub001/sc30862-QUJV/sundsvallexpress.se/wp-includes/pluggable.php on line 868

    I uploaded even the development version (2.9) and it didn't work. I also changed the theme to see if it is only with the one I am using, but the error remained.

    PLZ help!!!

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    I turned all plugins off through PHPMYADMIN

    Did you remember to turn them back on again?

  3. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    It is usually due to spaces, new lines, or other garbage at opening/closing PHP file <?php tag or after a closing ?> tag in wp-config.php. It can be other file too so need to check error message as it may list file name where the error occurred.

    One can either upload error file from the backup or edit erroneous file. To edit the file one need to check below mentioned points:

    1. Download the file mentioned in the error message.
    2. Open that file in a plain text editor
    3. Check that the very first characters are <?php
    4. Check that the very last characters are ?>
    5. Place the cursor between the ? and >
    6. Now press the DELETE key on your computer and keep that key pressed for at least 15 seconds.
    7. Now type > and
    8. Save without pressing any other key at all.

    That’s it!

    Thanks,

    Shane G.

  4. omerosen
    Member
    Posted 4 years ago #

    But if I will put the cursor between the last "?>" press it for 15 sec it will start erasing all the code.

  5. omerosen
    Member
    Posted 4 years ago #

    Esmi, I changed the a:{} to a:0{} at PHPMYADMIN. After I managed to access my admin again I left it like that. Do I need to change the a:{} so the "a:" will have a number again?
    If so, which number it need to be? I forgot what was it in the first place before I changed it.

  6. omerosen
    Member
    Posted 4 years ago #

    Help anyone?
    I have been searching the net and found nothing that helped me solve this and right now key features of my blog are not working because of that error.

  7. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    But if I will put the cursor between the last "?>" press it for 15 sec it will start erasing all the code.

    Place the cursor after last ?> and press the Del key for 15 secs - not the Backspace key.

  8. Mark / t31os
    Moderator
    Posted 4 years ago #

    Maybe i'm old or something, but what do steps 6 - 8 aim to do?

    What does holding that key do, and won't adding an additional > invalidate the closing tag by now becoming..

    ?>>

    .. or does this whole 15 delete thing remove one..

    Is it a Mac thing?

  9. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    They remove spaces you may not be able to see. and you should end up with just ?> - not ?>>.

    http://codex.wordpress.org/Answers-Trouble_Shooting#Headers_already_sent

  10. Mark / t31os
    Moderator
    Posted 4 years ago #

    Oh i see, i didn't even know that... oh god, all these years using computers and something so basic has escaped me... lol..

    Learn something new every day.. :)

  11. bestfoot
    Member
    Posted 4 years ago #

    I had the same problem ... I had added a custom color to header in my functions file ... worked most of the time but created this error the rest of the time. Just in case it happens to you ...

  12. Anton M
    Member
    Posted 4 years ago #

    Or you can press Ctrl+Shift+End after ?>, this will select everything to the end of the file including white spaces. I had that problem too, and removing the white spaces fixed it. Thanks!

  13. Peter94
    Member
    Posted 4 years ago #

    Hi !

    1. Open lesson.php first into an ascii editor.
    2. Then, go to the end of file.
    3. Remove the blank last line and blank spaces with backspace tab.
    4. Keep the '?>' no space behind.

    That's it !
    It works now.

  14. nsxall
    Member
    Posted 4 years ago #

    Hello! I have also encountered the same problem, I think should be the config.php file out of order. My solution is to download a new wondpress source code.
    Then remove the inside of the config.php file. And the old config.php to fill the same mysql data and text encoding, and then replace the FTP upload files, the problem solved.
    Want to help to you, I wish you good luck!

  15. epape
    Member
    Posted 4 years ago #

    i had the same problem and notebook doesn't fixe it. i use another editor that gives you all the spaces in letters. its called Hex Editor Neo

    i believe this can also happen if you migrate your wordpress to another domain and use the same sql database without changing the domain

  16. yli
    Member
    Posted 3 years ago #

    i get this message when i try to connect to my new site to the backend.

    Warning: Cannot modify header information - headers already sent by (output started at http://imresult.com/b/wp_p.inc:1) in /**/**/public_html/**/wp-includes/pluggable.php on line 868

    http://blogmagia.com.br

    how to fix it? thanks
    http://topanuncio.com.br

  17. yli
    Member
    Posted 3 years ago #

    hmm just realized i was hacked.

    http://imresult.com/b/wp_p.inc

    this create a hidden div on my blog.

    <script language="javascript" type="text/javascript">document.write("<div style='display:none;'>");dating websitesdating websites<script language="javascript" type="text/javascript">document.write("</div>");</script>

  18. severus
    Member
    Posted 3 years ago #

    The solution to this problem is much simpler:

    It happens because some programs are configured to add a character known as BOM (Byte Order Mark) at the beginning of the file when it is saved as UTF-8. This character is not necessary and is the reason for this error since there is "something before the <?php

    This BOM is not visible and not possible to delete, however it is enough just open the file with a plain Text processor (Notepad) and save it again using the option ANSI.

    Upload the file and ready, problem solved.

  19. craigblaze
    Member
    Posted 3 years ago #

    Please help. I can provide all login credentials and will provide PayPal payment to anyone who can resolve without reinstalling WP.

    +++++++++++++++

    I cannot access the login page. I receive the warning below. I've tried every step recommended above: disabled plugins, attempted to removed invisible BOM characters at beginning/end of file and still cannot access.

    Warning: Header may not contain more than a single header, new line detected. in /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php on line 662
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php:662) in /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php on line 663
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php:662) in /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php on line 664
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php:662) in /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php on line 666
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php:662) in /home/content/s/t/e/stepstomastery/html/programs/wp-includes/pluggable.php on line 865

    PHP is pointing to a cookie issue, pasted lines below: (lines 654 - 678)

    $auth_cookie = wp_generate_auth_cookie($user_id, $expiration, $scheme);
    	$logged_in_cookie = wp_generate_auth_cookie($user_id, $expiration, 'logged_in');
    
    	do_action('set_auth_cookie', $auth_cookie, $expire, $expiration, $user_id, $scheme);
    	do_action('set_logged_in_cookie', $logged_in_cookie, $expire, $expiration, $user_id, 'logged_in');
    
    	// Set httponly if the php version is >= 5.2.0
    	if ( version_compare(phpversion(), '5.2.0', 'ge') ) {
    		setcookie($auth_cookie_name, $auth_cookie, $expire, PLUGINS_COOKIE_PATH, COOKIE_DOMAIN, $secure, true);
    		setcookie($auth_cookie_name, $auth_cookie, $expire, ADMIN_COOKIE_PATH, COOKIE_DOMAIN, $secure, true);
    		setcookie(LOGGED_IN_COOKIE, $logged_in_cookie, $expire, COOKIEPATH, COOKIE_DOMAIN, false, true);
    		if ( COOKIEPATH != SITECOOKIEPATH )
    			setcookie(LOGGED_IN_COOKIE, $logged_in_cookie, $expire, SITECOOKIEPATH, COOKIE_DOMAIN, false, true);
    	} else {
    		$cookie_domain = COOKIE_DOMAIN;
    		if ( !empty($cookie_domain) )
    			$cookie_domain .= '; HttpOnly';
    		setcookie($auth_cookie_name, $auth_cookie, $expire, PLUGINS_COOKIE_PATH, $cookie_domain, $secure);
    		setcookie($auth_cookie_name, $auth_cookie, $expire, ADMIN_COOKIE_PATH, $cookie_domain, $secure);
    		setcookie(LOGGED_IN_COOKIE, $logged_in_cookie, $expire, COOKIEPATH, $cookie_domain);
    		if ( COOKIEPATH != SITECOOKIEPATH )
    			setcookie(LOGGED_IN_COOKIE, $logged_in_cookie, $expire, SITECOOKIEPATH, $cookie_domain);
    	}
    }
    endif;
  20. craigblaze
    Member
    Posted 3 years ago #

    Also points to line 865, which is this:

    header("Location: $location");

    Any ideas to resolve?

  21. peruservis
    Member
    Posted 3 years ago #

    como dice es simple habrir el archivo config.php con el blog de notas y guardarlo en modo ANSI no como UTF-8 y subirlo a nuestro servidor claro esta reemplazando el actual :)

  22. erwinwp
    Member
    Posted 3 years ago #

    Hello

    If i type : http://erwinlist.com i get this message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/erwin/public_html/wordpress/wp-blog-header.php:3) in /home/erwin/public_html/wordpress/wp-includes/pluggable.php on line 868

    But if i type http://www.erwinlist.com it is fine.

    Help

  23. erwinwp
    Member
    Posted 3 years ago #

    I fix it i uncompress wordpress zip again and it fix it.

Topic Closed

This topic has been closed to new replies.

About this Topic