WordPress.org

Ready to get started?Download WordPress

Forums

OGraphr
[resolved] Cannot activate - fatal error (4 posts)

  1. phillxfx
    Member
    Posted 1 year ago #

    Hi,

    I'm getting the error "Fatal error: Class 'OGraphr_Admin_Core' not found in /home/user/public_html/wp-content/plugins/meta-ographr/meta-ographr_admin.php on line 20" when I try to activate the plugin.

    I've tried installing both automatically and manually. I'm logged in as admin, not in debug mode, and PHP version is 5.3.22.

    Do you have any ideas what would be causing this? Anywould be much appreciated, as this looks like a very useful plugin!

    Thanks,
    Phil

    http://wordpress.org/extend/plugins/meta-ographr/

  2. phillxfx
    Member
    Posted 1 year ago #

    PS. As far as I'm aware xcache (or similar) isn't installed

  3. idleberg
    Member
    Plugin Author

    Posted 1 year ago #

    i take it you mentioned xcache because of this. i was pretty clueless about it and kind of glad that the problem could be traced down to xcache. i'm not familiar with that at all and have no possibility to test it on my own servers. maybe you can do a little investigation yourself to rule out there's xcache involved.

  4. phillxfx
    Member
    Posted 1 year ago #

    Thanks for the quick reply. I got in touch with the hosting company and it turns out xcache is enabled.

    A bit more searching suggests that this is a well-known problem with xcache - somebody has logged it as a bug: http://xcache.lighttpd.net/ticket/300. The person who posted this suggests it's something to do with using multiple namespaces within a PHP file (I don't know a great deal about PHP so this doesn't mean anything to me!)

    Hopefully it'll get resolved by xcache, as I'd rather not ask the hosting company to disable xcache if it's improving the performance of the site.

    Cheers,
    Phil

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic