WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot access /wp-admin or any other page after upgrade to 3.0 (23 posts)

  1. particle
    Member
    Posted 4 years ago #

    Installed 3.0 after upgrading 2 plugins, Akismet and Sitemap Generator. Now I get
    Too many redirects occurred trying to open “http://Xxxxxxxxxxxxxxx.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2Fupgrade.php%3F_wp_http_referer%3D%252Fwp-admin%252Fupgrade.php%253F_wp_http_referer%253D%25252Fwp-admin%25252Fupgrade.php%25253F_wp_http_referer%25253D%2525252Fwp-admin%2525252Fupgrade.php%2525253F_wp_http_referer%2525253D%252525252Fwp-admin%252525252Fupgrade.php%252525253F_wp_http_referer%252525253D%25252525252Fwp-admin%25252525252Fupgrade.php%25252525253F_wp_http_referer%25252525253D%2525252525252Fwp-admin%2525252525252Fupgrade.php%2525252525253F_wp_http_referer%2525252525253D%252525252525252Fwp-admin%252525252525252Fupgrade.php%252525252525253F_wp_http_referer%252525252525253D%25252525252525252Fwp-admin%25252525252525252Fupgrade.php%25252525252525253F_wp_http_referer%25252525252525253D%2525252525252525252Fwp-admin%2525252525252525252Fupgrade.php%2525252525252525253F_wp_http_referer%2525252525252525253D%252525252525252525252Fwp-admin%252525252525252525252Fupgrade.php%252525252525252525253F_wp_http_referer%252525252525252525253D%25252525252525252525252Fwp-admin%25252525252525252525252Fupgrade.php%25252525252525252525253F_wp_http_referer%25252525252525252525253D%2525252525252525252525252Fwp-admin%2525252525252525252525252Fupgrade.php%2525252525252525252525253F_wp_http_referer%2525252525252525252525253D%252525252525252525252525252Fwp-admin%252525252525252525252525252Fupgrade.php%252525252525252525252525253F_wp_http_referer%252525252525252525252525253D%25252525252525252525252525252Fwp-admin%25252525252525252525252525252Fupgrade.php%25252525252525252525252525253F_wp_http_referer%25252525252525252525252525253D%2525252525252525252525252525252Fwp-admin%2525252525252525252525252525252Ftools.php”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

    If I try an login, to direct to wp-admin, plugins, dashboard so I can't try the permalinks solution I read elsewhere.

    I also deleted plugins to no avail.

    Using Headway 1.5 Theme

  2. BeerInBaltimore
    Member
    Posted 4 years ago #

    Same here. YIKES!!!!!
    Site: http://beerinbaltimore.com

  3. ashsmh
    Member
    Posted 4 years ago #

    Hi,

    I too can't login with my admin username and password after the upgrade. I get a wrong password/username error message.

    http://xboxgameskinect.com

  4. ncpc
    Member
    Posted 4 years ago #

    Help! I am having the same problem after upgrading to 3.0. This is the message I get when trying to login to WordPress and trying to view website:
    Fatal error: Cannot redeclare class wp_locale in /home/northc8/public_html/wp-includes/locale.php on line 14

  5. BeerInBaltimore
    Member
    Posted 4 years ago #

    I'm getting the same error message as above. This is not good.

  6. fswebdesign
    Member
    Posted 4 years ago #

    Hello,

    We upgraded today and now we cannot get any access whatsoever to our website: http://www.4wardeveruk.org.

    All we see is a white screen with this message:

    Fatal error: Cannot redeclare is_rtl() (previously declared in /home/content/07/4705707/html/wp-includes/locale.php:347) in /home/content/07/4705707/html/wp-includes/locale.php on line 349

    Please advise any one!
    Larry

  7. ncpc
    Member
    Posted 4 years ago #

    Are any of you still able to login to Word Press? I've read other posts and it sounds like it's necessary to disable the plugins, but I don't know how to do that without being able to log in to the site.

  8. BeerInBaltimore
    Member
    Posted 4 years ago #

    You can log into your site via FTP, which is what I'm doing right now (and the only way I'm able to get in!).. but don't know how to disable plugins.

  9. fswebdesign
    Member
    Posted 4 years ago #

    Hey ncpc,

    No, we cannot login at all.
    From our hosting account (via GoDaddy) we can see the plugin files but they cannot be deactivated via that route, only deleted.

    This is really not good - what's going on WP?

    Larry

  10. mrmist
    Forum Janitor
    Posted 4 years ago #

    If you want to temporarily disable your plugins via FTP, then just log in to your FTP, find the wp-content/plugins directory, and copy it to someplace else, then delete the plugin files. That will get you back in, and you can copy the plugin files back later if you want. (or just delete them anyway and re-download)

  11. ncpc
    Member
    Posted 4 years ago #

    How do I login via FTP? This is all foreign to me...

  12. BeerInBaltimore
    Member
    Posted 4 years ago #

    Thanks! Trying now

  13. BeerInBaltimore
    Member
    Posted 4 years ago #

    That worked, thanks again. Now just gotta find which plugin was causing the trouble.

  14. ncpc
    Member
    Posted 4 years ago #

    I was able to figure out how to access FTP and followed mrmist's advice. The site is up and running again. Now I'm trying to reinstall plugins. Thanks for the help!

  15. particle
    Member
    Posted 4 years ago #

    I have deleted plugins and still no go on trying to log in. Still getting error and still not bale to access any admin or dashboard pages. Site is working.

  16. csw11235
    Member
    Posted 4 years ago #

    We're having a similar problem - we can see all the front-end pages, but can't get to the admin pages. We know the login page itself isn't the problem - when we try to log in with a deliberately bad password it responds with the right "ERROR: Incorrect password." message. However, any valid login attempt or any attempt to access .../wp-admin/ causes a redirect loop. We have no plugins installed (all plugin folders are empty currently).

    Any ideas, anyone?

  17. fatdiver
    Member
    Posted 4 years ago #

    Similar problem here. Upgraded a single site to WordPress 3 and enabled multi user. Everything works fine on the main site but I can't get at the backend of any new sites I create - same symptom as csw11235 above - just keep getting bounced back to the login page.

    I've created new users, recreated sites, hacked around with the tables and config files but still no luck. There must be a better way to debug this type of problem?

  18. fatdiver
    Member
    Posted 4 years ago #

    Aha! - found the answer (for me at least) here:

    http://wordpress.org/support/topic/413901

    Added this line to wp-config.php and can now access admin for other hosted sites.

    define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST']);

    As an aside WordPress, this would be a good idea to document/fix. I'm guessing lots of people using WP 3.0 for multi site will be hosting multiple domains too.

  19. particle
    Member
    Posted 4 years ago #

    I tried adding define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST']);
    Still not able to access any admin pages. This is messed up. I have deleted all plugins.

    I wish someone would resolve this.

    Too many redirects occurred trying to open “http://ASDFlkjh.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2Fupgrade.php%3F_wp_http_referer%3D%252Fwp-admin%252Fupgrade.php%253F_wp_http_referer%253D%25252Fwp-admin%25252Fupgrade.php%25253F_wp_http_referer%25253D%2525252Fwp-admin%2525252Fupgrade.php%2525253F_wp_http_referer%2525253D%252525252Fwp-admin%252525252Fupgrade.php%252525253F_wp_http_referer%252525253D%25252525252Fwp-admin%25252525252Fupgrade.php%25252525253F_wp_http_referer%25252525253D%2525252525252Fwp-admin%2525252525252Fupgrade.php%2525252525253F_wp_http_referer%2525252525253D%252525252525252Fwp-admin%252525252525252Fupgrade.php%252525252525253F_wp_http_referer%252525252525253D%25252525252525252Fwp-admin%25252525252525252Fupgrade.php%25252525252525253F_wp_http_referer%25252525252525253D%2525252525252525252Fwp-admin%2525252525252525252Fupgrade.php%2525252525252525253F_wp_http_referer%2525252525252525253D%252525252525252525252Fwp-admin%252525252525252525252Fupgrade.php%252525252525252525253F_wp_http_referer%252525252525252525253D%25252525252525252525252Fwp-admin%25252525252525252525252Fupgrade.php%25252525252525252525253F_wp_http_referer%25252525252525252525253D%2525252525252525252525252Fwp-admin%2525252525252525252525252Fupgrade.php%2525252525252525252525253F_wp_http_referer%2525252525252525252525253D%252525252525252525252525252Fwp-admin%252525252525252525252525252Fupgrade.php%252525252525252525252525253F_wp_http_referer%252525252525252525252525253D%25252525252525252525252525252Fwp-admin%25252525252525252525252525252F”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

  20. bwoeller
    Member
    Posted 4 years ago #

    I have the same problem as Particle...

    I tried deleted all the plugins, but still can't login to the admin area...anyone with anymore ideas?

    Getting pretty desperate here...

    Thanks

  21. insistimento
    Member
    Posted 4 years ago #

    I solve my problem, renaming plugins folder to plugins.hold, creating a new empty plugins folder and deleting this line from my wp-config.php:
    define ('COOKIE_DOMAIN', 'www.mydomain.com');

  22. sanda33
    Member
    Posted 3 years ago #

    HELP!

    I'm having the exact problem now, after upgrading WP. Seems that some of you found the fix... but I'm reading the answers and cannot figure it out. I'm green at this. Does someone have th etime to give me a step-by step fix?

    I'm getting desperate here... and feeling ignorant.

    thank you

  23. sanda33
    Member
    Posted 3 years ago #

    PLEASE HELP!

    I found the wp-content/plugins, as mrmist advised, and renamed it something else, then created an empty plugin as isistimento did.

    I could not find the line he deleted in my wp-config.php, so I didn't delete anything.

    Still not able to open admin page.

    Any suggestion?

    thanks

Topic Closed

This topic has been closed to new replies.

About this Topic