WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot access sub on multisite - changed old single install to multisite (10 posts)

  1. Dennis1001
    Member
    Posted 1 year ago #

    Hi all.

    I have an VPS account and changed my 2 year old single install (latest 3.5.2) to multisite and after adding a few subs I cannot access the new subs, the original site runs just fine and I can access the admin panel for the old site.

    Just to test my VPS I put up a fresh MU install and everything works just fine.

    I've searched this forum and other sites, tried a lot of "fixes" but nothing I found has solves my problem.

    I have the wildcard, changed the .htaccess to .txt and tried some other things but still, I cannot access the subs, just get "this page cannot be found".

    I have not been into MySQL and don't know if the problem can be found there?

    Any help to solve this issues is greatly appreciated.

  2. JHouse
    Member
    Posted 1 year ago #

    What happens when you visit one of your subs-sites...what kind of error?
    Maybe post the contents of your htaccess file here. Never heard of making an htaccess file "htaccess.txt," seems like that would crash.

  3. htaccess.txt won't crash, it just won't work. It's ignored.

    Subdomains or subfolders?

  4. Dennis1001
    Member
    Posted 1 year ago #

    It is a sub domains. The error is the same you'll get when the browser cannot find the page.

    "Oops! Google Chrome could not find subdomain.mysite.com"

    I C&P the content of the fresh install .htaccess into the buggy site .htaccess file, no change and the site just work as before, without access to the sub domains. The fresh install has a few sub domains that I can browse just as it should be.

    [ Moderator note: please wrap code in backticks or use the code button. Not the blockquote. ]

    # Turn on Expires and set default to 0
    ExpiresActive On
    ExpiresDefault A0
    
    # Set up caching on media files for 1 year (forever?)
    <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav)$">
    ExpiresDefault A29030400
    Header append Cache-Control "public"
    </FilesMatch>
    
    # Set up caching on media files for 1 week
    <FilesMatch "\.(gif|jpg|jpeg|png|swf)$">
    ExpiresDefault A604800
    Header append Cache-Control "public"
    </FilesMatch>
    
    # Set up 2 Hour caching on commonly updated files
    <FilesMatch "\.(xml|txt|html|js|css)$">
    ExpiresDefault A7200
    Header append Cache-Control "proxy-revalidate"
    </FilesMatch>
    
    # Force no caching for dynamic files
    <FilesMatch "\.(php|cgi|pl|htm)$">
    ExpiresActive Off
    Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
    Header set Pragma "no-cache"
    </FilesMatch>
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    Options -Indexes
    
    # securescanpro code
    # protect wpconfig.php
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    # end securescanpro code
    
    <IfModule mod_headers.c>
      Header unset X-Powered-By
      Header unset Server
    </IfModule>
    
    Options -Indexes
  5. tjbetz
    Member
    Posted 1 year ago #

    I have the same thing going on with not being able to access the sub domain sites. Everything else seems to function properly. Just getting that error: Server not found at subdomain.mainsite.com

    I set-up an existing single WP install (3.5.1 that was undeveloped with no content) as a network and everything went very smooth with no issues that I can tell of except that error.

    Just saw some info about setting up DNS wildcard and I was wondering what that was about? I did not make any DNS changes and I was wondering if that is the problem.

  6. tjbetz, per forum rules please create your own topic with your own details.

    http://wordpress.org/support/forum/multisite#postform

    It really is the best way for you to get support for your problem. It's considered rude when you interrupt other people's problem with your own.

  7. tjbetz
    Member
    Posted 1 year ago #

    thanks. I never used this forum or any other forum before.

  8. We're good. Just use that link I posted and try to include as much information as you can, that way your problem will get the attention you deserve. ;)

  9. Dennis1001
    Member
    Posted 1 year ago #

    I just found this post and wonder if this does matter at all?

    Just make it subdomain, in the normal set up, but BEFORE you make a subsite, change it to subfolder :)

  10. Dennis1001
    Member
    Posted 1 year ago #

    I found the issue. When using cloudflare, a special plugin needs to be installed to allow access to sub domain.

    https://support.cloudflare.com/entries/22053042-How-do-I-use-WordPress-Multi-Site-WPMU-With-CloudFlare-

Topic Closed

This topic has been closed to new replies.

About this Topic