WordPress.org

Ready to get started?Download WordPress

Forums

Google Webfonts For Woo Framework
[resolved] Cannot access Google Webfonts? (4 posts)

  1. M97i8c21h8a9e74l
    Member
    Posted 5 months ago #

    Hi Jason,

    Thanks much for the great plugin!

    I just created our Webfonts API key and have entered the key into the plugin's "Google Developer API Key" field. After saving changes I get this error:

    "Cannot access Google Webfonts. Check your API key. Using fallback font list instead."

    Any ideas?

    In our project, we have "Web Fonts Developer API" turned on...

    Thanks in advance!

    Michael

    https://wordpress.org/plugins/google-fonts-for-woo-framework/

  2. Jason Judge
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Michael,

    I have seen this happen when hosted on a Mac or Windows server. The Google API is accessed using a secure HTTPS connection, and sometimes the right plugin is not installed into the web server to allow that to happen.

    I did try at one point to display any error messages that are returned by Google for additional clues, but the return codes were not easy to decipher and Google did not publish what the format was, so I left it.

    There may also be some clues in the error logs of the web server.

    However, you won't be lacking any fonts or weights or styles, as they are all in the fallback file. Google is long overdue an update (they have a load of new fonts waiting in the wings) and I'll keep my eye on that and provide an update when they appear.

  3. Jason Judge
    Member
    Plugin Author

    Posted 5 months ago #

    There beta release linked in another ticket will display some additional error details from the Google API. It may be worth giving it a try to see if it tells you what is happening:

    http://wordpress.org/support/topic/control-which-weights-get-downloaded?replies=3

  4. Jason Judge
    Member
    Plugin Author

    Posted 4 months ago #

    The release that should tell you more about the error has been out for a week now. I'll assume your install is working, and will close this ticket, but feel free to reopen it with more details if you are still have a problem.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.