WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Can Tiled Gallery images NOT link to anything? (10 posts)

  1. yousirareunbelievable
    Member
    Posted 1 year ago #

    Hi. Hopefully I'm explaining this well.

    a) I love the way the Tiled Gallery looks as it is on the page
    b) I do not want my images viewed large/high res
    c) it's annoying when you click on an image and a whole other page loads

    That said, is it possible for the images to tile, but not to link anywhere? to just be images on a page that are tiled and that's it?

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I'm afraid that's not possible. WordPress Galleries do not include an option to remove the link. You can either link to the Media File, or to the attachment URL:
    http://codex.wordpress.org/Gallery_Shortcode

    An alternative would be to use the Jetpack Carousel module, thus avoiding the redirection to another page when the reader clicks on one of your images.

  3. Vishy Moghan
    Member
    Posted 10 months ago #

    May I just ask a slightly modified version of the same question?
    I like the layout of the tiled system, and as a photographer would like to deploy it on my blog. But, and it really is a big but, I want it to make the images link to the image at full size utilising the fancybox plugin I have there. Why is it not possible to do this?
    I have always removed the linking system default of opening images on a new page, it creates pointless clicks. So since my Fancybox settings tell the plugin to take over the image links site wide I am wondering why Jetpack overrides this and where I may be able to modify this function.I would like to be able to display groups of photos in the tiled style, but for the images to open in a Fancybox pop up when clicked. Any likelihood of this being possible?

    The site in question is at http://f5.fluxink.com/blog/

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    @Vishy If you disable the Jetpack Carousel module, you should be able to use both the Tiled Galleries and your own Fancybox plugin.

    You can find out how to deactivate a Jetpack module here:
    jetpack.me/support/#turn-off-jetpack-modules

    Once you have deactivated Carousel, try inserting a gallery into your post using the gallery shortcode, and setting your gallery options so each image will link to the image file, like so:

    [gallery type="rectangular" ids="xx, xy, xz" link="file"]

    Once you have done so, your galleries should use both plugins.

    If you still experience issues, could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

  5. Vishy Moghan
    Member
    Posted 10 months ago #

    Hi Jeremy
    I don't have carousel active. I just want the images to link to the original sized image from any size thumbnail that is generated by Jetpack. But even though in the gallery settings I have the link to images they still open in a new media page. That is just annoying. Did you visit the blog site? On the first page I have two thumbnails below the main image. I would have liked them to be put on the page with your plugin but have the behaviour you see there now. And this seems not to be possible

    Thanks

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    @Vishy Could you please create a new thread, as I mentioned above?

    Thank you.

  7. Vishy Moghan
    Member
    Posted 10 months ago #

    Thanks Jeremy no need it works, so in fact there is no way of doing it without writing in the code... Thanks and keep up the good work

  8. skelsey
    Member
    Posted 2 months ago #

    We just updated jetpack and this is still an issue, so I've add this to my css as a workaround. It isn't perfect, I think some versions of IE won't work with this, but better than nothing. Maybe it will help some people while they wait:

    .tiled-gallery .tiled-gallery-item a {
    pointer-events: none;
    cursor: default;}

    /* if you have links in the captions that you want to work, add this */

    .tiled-gallery-caption a {
    pointer-events: auto !important;
    cursor: pointer !important;

    }

  9. dafman
    Member
    Posted 1 month ago #

    Try the WP Gallery Custom Links plugin. It lets you set a custom url per image per gallery. It did the trick for me.

  10. avalasoft
    Member
    Posted 3 weeks ago #

    I solves this.
    I installed this plugin:
    tiled-gallery-carousel-without-jetpack
    Find file:
    tiled-gallery.php
    you have to make some changes:
    1. u have to disable carousel function like I made:
    //include( plugin_dir_path( __FILE__ ) . 'jetpack-carousel.php');

    2. key steps is to remove HTML codes ( + href) in conjunction with PHP codes. Where ever you find href delete it syntactically.
    Find these and delete it !!!
    and its end

    and its end

    and its end

    and its end

    THIS STEP WILL WORKS 100% !!!
    Here is my example:
    http://fotos.mediatvbgd.com/razno/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic