WordPress.org

Ready to get started?Download WordPress

Forums

Supra CSV
[resolved] Can the default description be turned off? (4 posts)

  1. WebsThatRock
    Member
    Posted 1 year ago #

    Hello,

    I have a conflict with the Types and Views Plugin with the Supra CSV Plugin. The Types and Views Plugin sets the description with its plugin to display correctly if a trail is added manually but if I import a csv datasheet of trail information it sets the description to blank or whatever I type into the configuration.

    To get around this I entered the Types and Views Plugin shortcode in the csv sheet for the predefined description and the trail displays correctly, but when it tries to display it on the website with the shortcode for the description in the csv and the shortcode created from the Types and Views Plugin it creates an infinite loop that creates a 500 internal server error.

    I discovered that I can upload all 12,000 trails just fine and manually delete the shortcode in the trail then it displays the correct trail information just fine and gets rid of the infinite error loop. But to manually delete that shortcode in 12,000 trails would defeat the point of using Supra CSV.

    Is there a way to turn off or delete Supra CSV from inputing the predefined description field?

    I have tried the following that did not work. . .

    - making the content for the column description blank in the csv and uploading
    - deleting the column of description in the csv and uploading
    - deleting the text in the configuration for default description in the Supra CSV Plugin
    - turned auto publish from true to false then publishing manually
    - adding the shortcode to the default description got an escape sequence error
    - adding the shortcode to the default description using escape sequences

    Currently I am looking at the source code of the plugin itself to see if I can find the code to delete manually in the plugin itself. But am not to comfortable with this.

    Is there something that I can do with Supra CSV>Configuration>Ingestion Settings>Custom Terms?

    Or is there some other setting that I am not seeing that will keep Supra CSV from trying to apply the predefined description?

    Michael

    http://wordpress.org/extend/plugins/supra-csv-parser/

  2. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    this may entail modifying the xmlrpc call builder class

  3. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    try this now with version 2.8.1

  4. WebsThatRock
    Member
    Posted 1 year ago #

    I have version 2.8 right now and see that I can update to 2.8.5. Anyway, I found a work around solution to this. I redid the csv file for description to be blank, created the preset to blank, reuploaded and ingested everything. Still no definition showing up but under View>Settings where the definition is supposed to show up it still was there so I deactivated it, saved it, reactivated it, saved it then the definitions came online.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.