WordPress.org

Ready to get started?Download WordPress

Forums

Can someone help me with a few questions about mod_rewrite? (4 posts)

  1. redhousepainter
    Member
    Posted 6 years ago #

    My problem is this...

    I have a gallery website using WordPress and Zenphoto.

    1. Google Webmasters shows that all of my gallery pages come back as 404 errors.
    2. When I upgraded to WP 2.6 the browser bar said 'nothing found' for all of my ZP pages.
    3. Google has zero of my 2000 Gallery images indexed.

    A few months back I posted something about this and got a lot of feedback about alt tags etc.

    As it turns out it's an issue with mod_rewrite.

    As I...

    a) Used this method to include my WordPress header into Zenphoto.
    b) Use WP pretty permalinks structure /%category%/%postname%/
    c) Enabled Zenphoto mod_rewrite.

    ... all of my Zenphoto pages came back as (silent) errors.

    So, what can we do about it? How do I make a b c consistent with each other? I don't have a lot of experience with this particular issue. Can someone explain to me what's happening here?

    I want to keep my header include, pretty permalinks and be included in the Google club.

    What should we do? I have disabled mod_rewrite of the time being. I want to test it out. Have a look at my site if you like. Some of the links may be temporarily broken.

    I'm more than willing to be a try out any thoughts you may have as long as it allows me to keep my theme and my header include!

    My site is here.

  2. redhousepainter
    Member
    Posted 6 years ago #

    Just wondering if any of you day dwellers can point me in the right direction?

  3. Jetoile
    Member
    Posted 6 years ago #

    Hehe, Jods here. I just followed your link over from Ruzee's. I'm still having the exact same problem, and by the looks of it, I've got pretty much the same WP settings.

    Setting the permalinks to default also removes the silent 404 errors for me... but I'd also like to keep the pretty permalinks. At least now I know it's a permalink issue.

  4. redhousepainter
    Member
    Posted 6 years ago #

    Hey, yeah, since Zenphoto upgraded I decided to rebuild my gallery template to take advantage of the new custom 404 option. I took out all of Ruzee's code and added...

    <?php require_once("../wp-blog-header.php");?>
    <?php get_header(); ?>

    in between the </head> & <body> tags. You will have to style your gallery using it's own CSS.

    It seems to have done the trick. I'll post back if I find out otherwise.

    Art
    Illusion

Topic Closed

This topic has been closed to new replies.

About this Topic