WordPress.org

Ready to get started?Download WordPress

Forums

Can see homepage, everything else is a 404! (10 posts)

  1. ssatish88
    Member
    Posted 4 years ago #

    Hey guys,
    I did a manual upgrade to 2.9 after which none of the inside pages work!
    Please help!

    Blog link > http://www.satishsays.com

  2. ssatish88
    Member
    Posted 4 years ago #

    Guys, please help!

  3. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 4 years ago #

    Maybe your permalinks need resaving

    go into settings -> permalinks and hit the [save changes] button

  4. wimego
    Member
    Posted 4 years ago #

    I had the same problem. I did what numeeja suggested and it worked. But now I have another problem. When i try to activate the get the image plugin i get the following error: Fatal error: Call to undefined function add_theme_support() in /home/mekeliki/public_html/wp-content/plugins/get-the-image/get-the-image.php on line 29

    Any ideas here?

    Thanks

  5. southsidecanuck
    Member
    Posted 4 years ago #

    I'm in the same boat, but after a new install. Resaving the permalinks did nada.

    Any help would be appreciated. Thanks!

  6. directorysieve
    Member
    Posted 4 years ago #

    satish, your blog is not opening, not even the homepage. others, i guess, its a permalink/htaccess issue. however, you can always just backup your database and install wordpress fresh, would more likely solve the problem.

  7. Permalinks shouldn't matter for the homepage of a site. They only matter for posts and pages.

    Both ssatish88 and southsidecanuck's sites open the main page for me. Actually, ssatish88 is fine all through.

    southsidecanuck - Did you update your .htaccess file as the permalinks page suggests?

    Does your site work with permalinks turned off?

  8. archondigital
    Member
    Posted 4 years ago #

    If everything used to work properly then it's possible a plugin overwrote something in the .htaccess file. try removing any recent plugins by deleting them from the plugin folder via FTP and delete all entries on your .htaccess and then re-save your permalinks.

  9. royshap
    Member
    Posted 4 years ago #

    fix ur permalinks and set an .htaccess file

  10. southsidecanuck
    Member
    Posted 4 years ago #

    The site does work with the default permalinks.

    I looked for an .htaccess file, but couldn't find one (i had view hidden files turned on), so I created one with this snippet and made sure it was writable.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Honestly, I'm kinda lost with the .htaccess part.

    Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic