WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
Can only see posts on Facebook page if I am logged in (14 posts)

  1. chloegeorge
    Member
    Posted 1 year ago #

    Hi there

    I have installed the plugin successfully and it is all working fine, but the problem is now, that it only shows the post on the fan page when we I am logged in as myself. If I login in as someone else or if I am logged out and visit the fan page, the post doesn't appear.

    Is there some setting that I am missing?

    I am an administrator on the page (ie it is not directly linked to my profile - I have access to make changes etc) but there are lots of people who will be posting on the blog and who are administrators like me where we want those posts added. Does it only work if you are the page owner?

    Would be really glad of any advice you can give.
    Many thanks in advance.

    Clojo

    http://wordpress.org/extend/plugins/simple-facebook-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    The plugin doesn't try to set any privacy settings, so you need to check what your default settings are on FB to make posts to your pages public and such.

  3. chloegeorge
    Member
    Posted 1 year ago #

    Hi thanks for this. But I have now gone in and changed the settings on Facebook to Public under App settings (it was originally set to Friends) but it is still not working and only shows if I am logged in. I have even created a new App and on the initial connect I changed it to post to Public, but it still doesn't work. Are there any other settings that I am missing. I have looked at Privacy settings and nothing in here seems relevant.

    Any advice you can give would be great.

    Many thanks in advance.

  4. air7walk
    Member
    Posted 1 year ago #

    I'm also having this same problem. I can see all the posts the app posts, but nobody else can. I'm an admin. My page is: https://www.facebook.com/runtheworlds

    There should be a "Testing!" post that came from the plug-in posting, but nobody else can see it but me.

  5. chloegeorge
    Member
    Posted 1 year ago #

    No, I can't see it on there. That is exactly the problem I have. Did you change your app settings to public too?

  6. air7walk
    Member
    Posted 1 year ago #

    I did! That's why it's bugging me -- it's even showing as public on the page itself, but no one else can see it.

  7. chloegeorge
    Member
    Posted 1 year ago #

    I know. It is driving me mad. I have been trying to fix it all day. Are you the main admin on yours? ie is the page linked to your profile page directly? I was invited by the person who set the page up to be an administrator on the page, so thought that might be the problem. But that doesn't make sense cause I have full access to the page.

    Otto, have you got any other suggestions?

    Many thanks in advance.

  8. air7walk
    Member
    Posted 1 year ago #

    Yes, I am the admin on the page, and it's linked to my personal page.

  9. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Sorry guys, but I don't have any control over Facebook or their behavior. The plugin doesn't do anything with privacy and cannot actually post anything with specific view settings. So I have no idea how to make FB behave the way you want it to.

    I use the SFC Publishing myself on my own sites, and in fact we use it here on WordPress.org's Blog page (which automatically publishes to http://www.facebook.com/WordPress ), so I know that it's working fine there.

    Beyond that, I have no helpful advice. Sorry.

  10. graphmaster
    Member
    Posted 1 year ago #

    I had the same problem, but I disabled Sandbox mode in the Facebook app and it seems to be working.

  11. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Oh, well, yes. You definitely have to turn off Sandbox mode. Didn't even think of that one. :)

  12. air7walk
    Member
    Posted 1 year ago #

    aha! Now we're getting somewhere!

    Sandbox mode is enabled for me! When I disable it, it says:

    Error
    Secure Page Tab URL is required when Sandbox Mode is disabled.

    Any idea what to put for that URL? Can I just put something like https://www.runtheworlds.com for anything that it asks for a secure URL for?

    If you visit http://www.facebook.com/runtheworlds/ , can you see a post out there that says "Testing 1 2 3!" ? I THINK IT MIGHT BE WORKING!!

  13. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    If you get that message, go to the Basic settings for the App and turn off the "Page Tab" settings dropdown. The only integration you need to have active is the "Website with Facebook Login" one.

  14. chloegeorge
    Member
    Posted 1 year ago #

    OMG! Thank you graphmaster! It works! Halleluyah!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic