WordPress.org

Ready to get started?Download WordPress

Forums

WP Quadratum
[resolved] Can not to connect to foursquare (6 posts)

  1. rudomilov
    Member
    Posted 1 year ago #

    Sounds good, but it does not work in several parts.

    1. The plugin says that I have to use https://foursquare.com/oauth/register , but page with API credentials is on https://foursquare.com/developers/apps actually.

    2. Foursquare disabled http-pages for pushing, now only https-pages in allowed. Therefore I selected "Disable pushes for this app".

    2. I use https://foursquare.com/developers/apps to create Client ID and Client Secret, then drop them into plugin settings. It is OK, but when I am clicking on "Connect to Foursquare button", I have got a system error 500.

    Any ideas? It is because of disabled pushes?

    http://wordpress.org/extend/plugins/wp-quadratum/

  2. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    1. The plugin says that I have to use https://foursquare.com/oauth/register , but page with API credentials is on https://foursquare.com/developers/apps actually.

    You're absolutely correct; Foursquare changed the URL of their app registration page. The next version of the plugin (which is currently being finished and polished) corrects this and refers to the new URL.

    2. Foursquare disabled http-pages for pushing, now only https-pages in allowed. Therefore I selected "Disable pushes for this app".

    WP Quadratum doesn't support push notifications (in fact, I'm not even sure this is possible via a plugin except via some AJAX cleverness and even then only maybe).

    When creating a Foursquare app, the download/welcome page and redirect URI fields are mandatory. Push API Notifications should be set to disabled. All other fields should be left as is.

    3. I use https://foursquare.com/developers/apps to create Client ID and Client Secret, then drop them into plugin settings. It is OK, but when I am clicking on "Connect to Foursquare button", I have got a system error 500.

    I can't seem to reproduce this ...

    I've just gone through a clean (re)install and activation of the plugin on a test WordPress install, that's public facing (needed due to the OAuth callback). I did the following.

    1. Uninstalled and deleted WP Quadratum
    2. Re-installed and activated the plugin
    3. In the plugin's admin settings, entered the Client ID and Client Secret from the Foursquare My Apps page, then clicked on Save Foursquare Settings.
    4. When the page reloaded, I clicked on Connect to Foursquare and was able to authenticate via OAuth and my Foursquare credentials.

    All worked fine (but see the last part of this post below for another caveat). This might be down to another plugin or theme issue that I've not come across. Have you tried the standard disable all (other) plugins and revert to a stock WordPress theme to see whether this recurs?

    One final point, due to a change in the way in which GitHub serves up files via raw.github.com, Mapstraction, the underlying API that provides the map for WP Quadratum is not currently working. I'm in the process of fixing this and this should be the last hurdle to overcome before releasing the next version of the plugin which fixes this issue as well as several others, including the point you raised in 1) above.

    Hope this all helps

    -Gary

  3. rudomilov
    Member
    Posted 1 year ago #

    Gary, thanks for you reply, but it did not help :(

    Step-by-step what I am doing for my blog (for example, http://www.homepage.com):
    1. Create a app at https://foursquare.com/developers/register with following options:
    1.1 "Your app name" as "homepage"
    1.2 "Download / welcome page url" as "http://www.homepage.com"
    1.3 "Redirect URI(s)" as "http://www.homepage.com/wp-content/plugins/wp-quadratum/includes/wp-quadratum-callback.php"
    2. Install your plugin to WP
    3. Copy "Foursquare Client ID" and "Foursquare Client Secret" from https://foursquare.com/developers/apps to http://www.homepage.com/wp-admin/options-general.php?page=wp-quadratum/includes/wp-quadratum-admin.php
    4. Click on "Save foursquare settings" on the bottom
    5. Click on "Connect to Foursquare"
    6. I am redirected into Foursquare website to grant rights for the webpage. Therefore I am clicking on "Allow"
    7. Error 500!

    Thats all. I have to idea how to fix it.

    I am using:
    - Apache/2.2.16 (Debian)
    - PHP 5.4.4-11
    - WordPress 3.6

  4. rudomilov
    Member
    Posted 1 year ago #

    I found a problem:
    [Tue Aug 20 17:26:49 2013] [error] [client 147.32.108.160] PHP Fatal error: Call to undefined function curl_init() in /var/www/ilya/data/www/rudomilov.ru/wp-content/plugins/wp-quadratum/includes/foursquare-helper/foursquare-helper.php on line 126

    Therefore I am installing curl now.

  5. rudomilov
    Member
    Posted 1 year ago #

    Solved!

  6. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Glad to hear you resolved this; there's a new version of the plugin appearing today/tomorrow by the way.

    -Gary

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.