WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can not log on to subdomain or admin (8 posts)

  1. chevyfixr
    Member
    Posted 1 year ago #

    I am unable to log on to a subdomain admin nor the subdomain.
    I can log on to my main site iconmatrix.com and in to the network admin

    I created 2 subdomains
    http://creativio-im-red.iconmatrix.com/
    http://creativio-im-blue.iconmatrix.com/

    When trying to log on to the admin I receive a 404 error not found

    I have added a wildcard subdomain
    www.*.iconmatrix.com. A 184.154.14.138

    our VPS apache httpd.conf is set
    ** Directory “/” Options [?]
    FollowSymLinks default
    SymLinksIfOwnerMatch default

    my .htaccess is
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName http://www.iconmatrix.com
    AuthUserFile /home/icon/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/icon/public_html/_vti_pvt/service.grp

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) wp/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ wp/$2 [L]
    RewriteRule . index.php [L]

    # END WordPress

    I did notice after install my db increased and reads as, I assume this is the subdomain creation.
    wp_2_commentmeta
    wp_2_comments
    wp_2_links
    wp_2_options
    wp_2_postmeta
    wp_2_posts
    wp_2_terms
    wp_2_term_relationships
    wp_2_term_taxonomy
    wp_4_commentmeta
    wp_4_comments
    wp_4_links
    wp_4_options
    wp_4_postmeta
    wp_4_posts
    wp_4_terms
    wp_4_term_relationships
    wp_4_term_taxonomy
    wp_blogs
    wp_blog_versions
    wp_cf7dbplugin_submits
    wp_commentmeta
    wp_comments
    wp_links
    wp_options
    wp_postmeta
    wp_posts
    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta
    wp_terms
    wp_term_relationships
    wp_term_taxonomy
    wp_usermeta
    wp_users

  2. Subdomains are wrong.

    http://creativio-im-red.iconmatrix.com/ redirects to http://creativio-im-red.iconmatrix.com/cgi-sys/defaultwebpage.cgi

    That's your server's default subdomain page, which means you didn't point the subdomains to the right place.

  3. chevyfixr
    Member
    Posted 1 year ago #

    Hi Mike, Thanks for the quick response.

    http://iconmatrix.com/wp-admin/network/site-info.php?id=4

    Domain creativio-im-red.iconmatrix.com
    Path = /

    I am a little lost where else I would point it

    Thanks,
    Steve

  4. It's not WP, it's cpanel.

    You made the subdomains wrong.

  5. chevyfixr
    Member
    Posted 1 year ago #

    This is what I have in Advanced DNS
    *.iconmatrix.com. 14400 IN A 184.154.14.138

  6. chevyfixr
    Member
    Posted 1 year ago #

    Success!

    I was able to resolve the subdomain by deleting from Advanced DNS in Cpanel
    *.iconmatrix.com. 301 IN A 184.154.14.138

    Then add a subdoman at Add Subdomains in Cpanel like this
    Subdomain : * . iconmatrix.com
    Document Root : /public_html/

    Where I found the direction to complete this was in the book WordPress_Multisite_101
    page 16, Thank you Mike :)

  7. chevyfixr
    Member
    Posted 1 year ago #

    Hey Mike, you might see a reference from ipodnewsonline, That is me! Thanks again for your support!

  8. You're welcome :) Glad it's working!

Topic Closed

This topic has been closed to new replies.

About this Topic