WordPress.org

Ready to get started?Download WordPress

Forums

Can not install. please help (18 posts)

  1. rayson7
    Member
    Posted 2 years ago #

    I transferred all the files to my database and modified them but when i enter the following address in my adressbar http://www.irayson.co.cc/wp-admin/install.php It Gives me the following error.

    Parse error: syntax error, unexpected $end in /home/a7204682/public_html/wp-includes/query.php on line 2160

    I can not figure it out plz help me. Really Appreciated.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Try re-uploading all files & folders from a fresh download of WordPress.

  3. rayson7
    Member
    Posted 2 years ago #

    Now its giving me this error. I re uploaded this file but its still not fixing. Thanks for the help in advance.

    Fatal error: Class 'WP_List_Table' not found in /home/a7204682/public_html/wp-admin/includes/list-table.php on line 76

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Try re-uploading all files & folders from a fresh download of WordPress.

  5. rayson7
    Member
    Posted 2 years ago #

    Still the same error.. any more help please

  6. Tim S
    Member
    Posted 2 years ago #

    Hi rayson7,

    Have you tried do what esmi said and re-uploading ALL the files again? I know it seems redundant, but it sounds like your files are corrupted. Download WordPress again and start over uploading them. I hope this helps!

  7. rayson7
    Member
    Posted 2 years ago #

    I have reuploaded all the files again, the one which i already downloaded last night. But i should reupload the latest version which is 3.3.1 but its not downloading its too slow, do u have any other link? or if u could upload it to fileape.com or filedude.com or mediafire.com or somewhere else So that i can download it...

  8. ommunist
    Member
    Posted 2 years ago #

    Do you have a backup of your old wp-content directory AND xml backup from export?

  9. rayson7
    Member
    Posted 2 years ago #

    I do have the old wp-content directory, right now i am uploading the new version files from 3.3.1 except the folder wp-content I hope it works

  10. rayson7
    Member
    Posted 2 years ago #

    I did what I mentioned above now i am seeing this and this one is sooo annoying...

    Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the database_name_here database.

    Are you sure it exists?
    Does the user a7204682_rayson7 have permission to use the database_name_here database?
    On some systems the name of your database is prefixed with your username, so it would be like username_database_name_here. Could that be the problem?
    If you don't know how to set up a database you should contact your host. If all else fails you may find help at the WordPress Support Forums.

  11. ommunist
    Member
    Posted 2 years ago #

    Upgrade sequence:
    0) consider what files from wp-include or/and wp-admin you tweaked, backup them.
    1) Sync (do not just overwrite) new 3.3.1 to old WP install (its just 20 files instead of 994+). Check if you wp-config.php is the correct one. I prefer to keep debug info parameter as true in it.
    2) Put your old wp-content back if you removed it :-)
    3) If it is a new hosting, import your export file and see if website looks ok. If it is the same old hosting, no need in step 3.
    4) check if sync was applied to files you tweaked before, if so, check whether you can re-apply them (in my case some lines in post-template).

  12. ommunist
    Member
    Posted 2 years ago #

    username_database_name_here. - yes, stick to your hosting provider naming conventions for database and username.

  13. rayson7
    Member
    Posted 2 years ago #

    OK i have solved that and installed WordPress Successfully but now its showing me this error on Login...http://www.irayson.co.cc/wp-login.php

    Fatal error: Class 'WP_Styles' not found in /home/a7204682/public_html/wp-includes/general-template.php on line 2088

    Thanks for your help in advance but i still need help. Please

  14. ommunist
    Member
    Posted 2 years ago #

    Looks like some plugin problem for me. Temporarily remove your plugins and custom themes from wp-content on server and see if this fixes the problem.

  15. rayson7
    Member
    Posted 2 years ago #

    which folders shall i remove. Can u please give me the names

  16. rayson7
    Member
    Posted 2 years ago #

    I renamed them to Pluginsa and Themsa. so that they seem unavailable. Is that Ok ????
    But this is not working... Still the same error

  17. rayson7
    Member
    Posted 2 years ago #

    I reset-ed everything now i will upload WordPress 3.3.1 after creating a Database. I hope it Works.. Please Reply to me

  18. ommunist
    Member
    Posted 2 years ago #

    No, no, man. in /plugins folder there have to be only default akismet and hellodolly. In themes - default Twentyeleven and Twentyten. Put your own stuff back to local machine. Do not "rename", leave names. Put your plugins off physically and leave only the default ones in /plugins.

    By the way - have you used some autoinstaller script on your hosting, or uploaded WP installation files manually?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.