WordPress.org

Ready to get started?Download WordPress

Forums

Can Not Get Permalinks to Work with `/index.php/` (11 posts)

  1. hendrixf
    Member
    Posted 8 years ago #

    I am on NetFirms and they do not allow full use of the .htaccess except for creating passwords for DIR's. I know a new host is needed but I have about 10 months left on my acct so that is not an option at this time.

    What steps do I need to do to use the method /index.php/ for permalinks to work?

    I have tried using the /index.php/ method with several structure examples and still get my custom error 404 page.

    My WordPress address (URI): is http://frhendrix.netfirms.com/blog2
    My Blog address (URI): is http://www.blankmindblog.com
    After many attempts to use permalinks using /index.php/ I can see in my FF status bar this link `http://www.blankmindblog.com/index.php/whatevercat/this-is -a-post/ and then my error 404 loads...

    any help is appreciated,

    richard

  2. DianeV
    Member
    Posted 8 years ago #

    Hm. It seems to work okay, although perhaps I'm not seeing what you're seeing. Did you check the codex.wordpress.org about permalink methods?

  3. schestowitz
    Member
    Posted 8 years ago #

    I see that you have conceded all attempts to form permalinks for the time being.

    Confer: http://codex.wordpress.org/Using_Permalinks

    [snip]
    Using Permalinks Without mod_rewrite

    For permalinks in general, you must use mod_rewrite, and IIS (common on Windows servers) does not support mod_rewrite. If you are using Apache 2.0.54, on Windows, mod_rewrite may work. If you put a filename at the beginning, WordPress will attempt to use that to pass the arguments and bypass the necessity for mod_rewrite.

    [/snip]

  4. hendrixf
    Member
    Posted 8 years ago #

    @DianeV --- I have checked the Codex and I can not get permalinks to work like they should. If I set the permalinks to /index.php/%year%/%monthnum%/Úy%/%postname%/ I get my 404 error page.

    @schestowitz --- I had to concede since when I have permalinks active no one can get to my site except for the 404 error page.

    WP1.5.2 for some reason is not/can not understand to use the index.php file.

    Any suggestions?

  5. Honestly, I would suggest that you move to a hosting provider which allows full access to the .htaccess file. It's actually a "standard feature" these days. But, if you don't want to move, check the following section of Permalink article again, starting with, "This option may not always work, especially in cases of WordPress running on IIS 6...":

    http://codex.wordpress.org/Using_Permalinks#Using_Permalinks_Without_mod_rewrite

    If your hosting provider does not allow you to make alterations to the php.ini file, then I would suggest moving to a hosting provider which at least allows full access to the .htaccess file.

  6. VxJasonxV
    Member
    Posted 8 years ago #

    /�y%
    Sorry, proof of concept. Ignore this post.

  7. hendrixf
    Member
    Posted 8 years ago #

    @macmanx --- Thanks for the suggestions but I guess why I am so frustrated is that my understanding is even without access to the .htaccess file I still should be able to use the /index/ prefix on the permalinks and get it to work but it doesn't work with the prefix. I get a 404 error message with the prefix.

    So there is no way to get WP1.5.2 to work with the /index/ prefix unless I change providers and use the .htaccess file?

    richard

  8. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    It should work. If it's not, it's a bug. To help me debug, provide the information I requested in this post.

  9. angsuman
    Member
    Posted 8 years ago #

    Try this:
    WordPress Tip on Permalink Options

    Let me know how it goes.

  10. hendrixf
    Member
    Posted 8 years ago #

    @ryan --- I've been out of town and am leaving again tomorrow for a few days. I will provide the info you requested when I return.

    @angsuman --- Thanks for this link. Actually this is the link that got me re-started on trying to get permalinks working on my site again. I tried a few times in the past and gave up. This link helped rekindle my interest in getting it working again. I have tried the examples and still receive the 404 error message.

    richard

  11. hendrixf
    Member
    Posted 8 years ago #

    @ryan --- I have sent the requested information to the email address you provided in the other topic link. Let me know what else, if anything, I need to do.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.