WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Can not apply a page template per language (13 posts)

  1. dontheo70
    Member
    Posted 1 year ago #

    I have a puzzle.
    As I have described in an earlier post I have a wordpress MU install with 15 sites. Polylang is set on each one of them. The setup was on my local machine where I can associate without a sweat thanks to your amazing plugin a template page per language.
    I have just transferred everything to the production site, no problems for 14 sites. And then there is the one that apply the same template to all four languages.
    I have deleted the site recreated it from scratch, created the four pages applied the four templates(so far so good) and then when I link them, the page I link from will force its template on the others.
    If I am in the English page, it will apply its template to the three others, If I go to Spanish page to amend, the Spanish template is applied to all others. The funny thing is that each page has four sub-pages with its own template and they are linked to the other sub-pages without problem.

    I installed another instance of wordpress on the production machine, same problem with this site (1 out of 15) which works perfectly locally.

    Any hint on where I should look to debug?

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    If you don't want the same template for all the translations of a page, you should go to Polylang settings and uncheck the synchronization for page template.

  3. dontheo70
    Member
    Posted 1 year ago #

    Chouby, thanks a lot, it did the trick!!!.

    For your information, I would like to point out that on my local machine and the other 14 sites on the production machine this setting is checked and the problem does not appear: each language-page has its own unique template file.
    In other words, only 4 pages out of 120 on the production machine were being synchronized when they should not have been and none on my local machine.?!?!

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    That's really curious as all my tests do the synchronization when it is requested (and only when it is requested). Could it be a theme or plugin conflict? Anything present on your 14 sites and not on the last one?

  5. dontheo70
    Member
    Posted 1 year ago #

    Chouby,

    I have found one difference when I stumbled on another problem:
    on my home machine I had setup (by mistake)the home page to display the most recent posts while on the production machine it was set as a static page (which is what it is supposed to be).

    Set as a static page even with the translated pages I was unable to access to the registration page, any attempt to get there would redirect me to the home page. This was puzzling because I had no trouble with the login and reset password pages.

    I deinstalled all plugins but polylang, this is when I found the difference. I switched the front page settings to display the latest posts on the production page and it resolved my problems for the register-page.

    It was such a "small" nuisance compared to all the benefits of your plugin and the amount of work that I still have to do to complete the site that, I am afraid, I contented myself with this quick fix.

    Further down the line, if I can , I´ll try different pairing of plugins to find the source of the original misbehavior.

  6. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Could you give me more information for the register-page issue? Do you mean the 'wp-signup.php' page which should be redirected to 'wp-login.php?action=register'?

    I understand you are using a static page. Are you using default or pretty permalinks? What are your Polylang settings?

  7. dontheo70
    Member
    Posted 1 year ago #

    No I meant the "Register" link from the wp-login.php page is sending to the home page instead of /wp-login.php?action=register
    when the "Lost your password?" link is doing its job

    Permalink settings:
    common settings with day and name

    then polylang:
    Default language: English

    Detect browser language checked

    URL Modifications: the language is set from content
    remove /language/ in pretty permalinks

    Media checked

    Synchronization: only page template is unchecked

  8. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I am not sure I understand exactly where is the issue. But I do not reproduce any issue, even with your settings, on:
    wp-signup.php
    wp-login.php?action=register
    wp-login.php?action=lostpassword
    In all cases, I am kept on the right page (no redirection to homepage) and the language is set as expected.

    You wrote that you tried without any plugin except Polylang. Did you try with a default theme?

  9. dontheo70
    Member
    Posted 1 year ago #

    I am using twenty twelve

  10. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I use twenty twelve to for my tests :( Is it a standard install or a multisite install (in that case is Polylang activated at network or site level)?

  11. dontheo70
    Member
    Posted 1 year ago #

    It is a MU install with sub-directory option. Polylang is activated at network level

  12. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I believe I got it. Could you test the development version?
    http://downloads.wordpress.org/plugin/polylang.zip

  13. dontheo70
    Member
    Posted 1 year ago #

    Sorry Chouby, I just got your email, damn gmail mail organization.

    I will give a try at the end of the week.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic