WordPress.org

Ready to get started?Download WordPress

Forums

Can not add a new category on "Edit Post" page (9 posts)

  1. allieai
    Member
    Posted 4 years ago #

    Hi there,

    I can't add a new category on a "Edit Post" page by clicking the "+ Add New Category" link located at the bottom of the "Categories" box on the left-hand sidebar. This issue started to occur after I installed the WP Super Cache plugin, configured the Permalinks setting to use the "/%year%/%monthnum%/%postname%/" format and added the tag cloud to my blog. I got a JavaScript error: post.php, line 224, Object Expected. However, I can add new categories via the Posts -> Categories page. I am using WP 2.9.1 on Windows and have tried both IE and Firefox. Has anyone had similar problems or know what may be causing the problem?

    Thanks in advance!

  2. allieai
    Member
    Posted 4 years ago #

    I meant the Categories box in the right-hand sidebar. I do not have any customizations - mainly a out-of-the-box installation of WP 2.9.1 with several plugins, including those mentioned in my previous post and additionally the more fields and popular posts plugins.

    More info on the JS errors: in IE, when I load an "Edit Post" page for a given post (http://mysite.com/my-wp-installation-directory/wp-admin/post.php?action=edit&post=35#category-add), the JS error says: Line 223, Object expected; If I click on the "+ Add New Category" link in the right-hand sidebar, the JS error syas: Line 407, makeSlugeditClickable is undefined. And this JS error popup appears every minute or so.

    Any ideas would be appreciated!

  3. s_ha_dum
    Member
    Posted 4 years ago #

    You've got a javascript error. Disable you plugins and see if it goes away. If it doesn't, I'd guess you have a missing or corrupt core file, meaning you need to reupload the wp-admin and wp-includes directories.

  4. allieai
    Member
    Posted 4 years ago #

    I need those plugins. Then what if I identify which plugin causes the problem? Am I supposed to start fixing the plugin myself? Sorry that I am new to WP development - Is fixing downloaded plugins ourselves the best way to resolve such issues? I was hoping WP support would be able to provide some answers: adding new tags works, but not adding new categories via the Edit Post page. what are the known issues of using those popular plugins, etc. Thanks.

  5. allieai
    Member
    Posted 4 years ago #

    The error comes from the More Fields plugin: more-fields/post.js line 223 make_slugedit_clickable() is not defined and line 407 makeSlugeditClickable is not defined. Once I disable this plugin, I am able to add a new category on the "Edit Post" page.

    Has anyone run into the same problem?

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    Checking out that plugin:
    http://wordpress.org/extend/plugins/more-fields/

    it seems quite obvious that its broken, it's pretty much not working for anyone.

    Look for a plugin that has the same capability I guess....

  7. kalstrom
    Member
    Posted 4 years ago #

    We have a new beta release for you.

    Both these cases (slug and category) works for me in my test cases.

  8. s_ha_dum
    Member
    Posted 4 years ago #

    Then what if I identify which plugin causes the problem? Am I supposed to start fixing the plugin myself?

    Well, yes. Or don't use the broken plugin. Or contact the developer of the plugin (who in this case seems to have already stepped up). Or get someone to fix it for you.

    I was hoping WP support would be able to provide some answers...

    We are all, as far as I know, volunteers here and we do provide a fair number of answers but if the plugin is broken its broken. Fixing it means editing code. I, or someone else, here can walk you through most of those changes.

    what are the known issues of using those popular plugins, etc.

    You can usually work that our by reading through the comments on the plugin's page like RVoodoo did, or by searching for the plugin here.

  9. micharo
    Member
    Posted 4 years ago #

    thanks Kal

    upgraded from 1.3 to 1.4 and it works!

Topic Closed

This topic has been closed to new replies.

About this Topic