WordPress.org

Ready to get started?Download WordPress

Forums

can not activate the plugin umapper (17 posts)

  1. thefabs
    Member
    Posted 5 years ago #

    Hi,
    i'm getting the following error:
    Fatal error: Cannot redeclare class Zend_Loader in /xxx/wp-content/plugins/umapper/Zend/Loader.php on line 31

    anyone else have this problem?
    kind regards,
    thefabs

    http://wordpress.org/extend/plugins/umapper/

  2. umapper
    Member
    Posted 5 years ago #

    Hello,
    I suppose you have Zend_Framework installed and included to your WordPress. Umapper uses several ZF classes (see Zend folder in plugins installation) - so when plugin tries to include Zend_Loader once again error occurs. In order to solve the problem, you could add include path of you ZF library, and remove Zend folder from plugin's install directory, that way plugin would be able to load necessary classes directly from your installation of ZF.

    Let me know if you need more clarification on this.

  3. Anonymous
    Unregistered
    Posted 5 years ago #

    Hi,
    I can not activate the plug because:

    Parse error: syntax error, unexpected $end in C:\wamp\www\wp-content\plugins\umapper\Umapper\Pages\GeneralConfig.php on line 94

    what is the problem?

    thanks.

  4. umapper
    Member
    Posted 5 years ago #

    Well, could the problem be that I didn't include closing ?> sequence? You see it's perfectly valid (and actually preferred way in Zend Framework), use opening <?php declaration and omit the closing ?>. Could you please add closing tag manually and if error disappears provide me with your php.ini file?

    Thx

  5. umapper
    Member
    Posted 5 years ago #

    Hi,
    I can not activate the plug because:

    Parse error: syntax error, unexpected $end in C:\wamp\www\wp-content\plugins\umapper\Umapper\Pages\GeneralConfig.php on line 94

    what is the problem?

    thanks.

    This error has been fixed - upgrade to plugin ver 1.3.3+

    Thanks,
    Victor

  6. maceman
    Member
    Posted 5 years ago #

    You have stated

    In order to solve the problem, you could add include path of you ZF library, and remove Zend folder from plugin's install directory, that way plugin would be able to load necessary classes directly from your installation of ZF.

    How Where

    Was working great before upgrade so any help would be welcome

  7. Kijac
    Member
    Posted 5 years ago #

    I cann't activate the plugin because:
    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /var/www/web195/html/sabrina/blog/wp-content/plugins/umapper/Umapper.php on line 27

    What can I do???

    Kijac

  8. umapper
    Member
    Posted 5 years ago #

    I cann't activate the plugin because:
    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /var/www/web195/html/sabrina/blog/wp-content/plugins/umapper/Umapper.php on line 27

    What can I do???

    Kijac

    Your question is answered in FAQ - PHP5 is required for running the plugin.

    Thnx.

  9. basheem
    Member
    Posted 5 years ago #

    Hi,

    I'm quite a newbee, but since extensive search on the subject did not result in resolving the issue I'm posting my problem here: I cannot activate my Umapper plugin because the validation fails:

    Unable to Connect to tcp://www.umapper.com:80. Error #111: Connection refused.

    Did someone have similar issues?

    Thanx!

  10. Start1
    Member
    Posted 5 years ago #

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /mounted-storage/home21a/sub002/sc20921-AMCE/www/asphaug/wp-content/plugins/umapper/Umapper.php on line 27

    And I have php 5

  11. still giving
    Member
    Posted 5 years ago #

    WP 2.6.1, PHP5 ... Does not work

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in usr/home/site/public_html/wgo/wp-content/plugins/umapper/Umapper.php on line 27

  12. umapper
    Member
    Posted 5 years ago #

    Hello,
    This error keeps coming up, so anyone having the same issue - pls, contact me via "victor ~at~ afcomponents ~dot~ com", stating the problem, so that we can work in real-time to resolve the issue.

    Thanks,
    Victor

  13. bluehole
    Member
    Posted 5 years ago #

    Sent an email earlier today, but thought I'd also post here:

    Hi Victor,

    I am trying to implement your plugin at http://porblogs.com/ -- I am one of those people getting an error at the activation attempt:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/bluehole/public_html/porblogs.com/wp-content/plugins/umapper/Umapper.php on line 37

    Although I don't know PHP -- I am good at following steps and would love help troubleshooting.

    Thanks.
    Al

  14. umapper
    Member
    Posted 5 years ago #

    Alan,
    I have answered your e-mail, giving my msn and skype details.
    Have you received it?

  15. bluehole
    Member
    Posted 5 years ago #

    Yes. Thank you. I added you to Skype and will try to talk soon.

  16. jmanney
    Member
    Posted 5 years ago #

    I get the following fatal error when I try to activate the plugin in WordPress 2.6.5:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home5/peopleof/public_html/cardoner/wp-content/plugins/umapper/Umapper.php on line 37

  17. umapper
    Member
    Posted 4 years ago #

    Guys, honestly, it has been answered in plug-in's FAQ and I have stated it several times in this post, this error means you are having PHP version 4, which is outdated, and is not supported by UMapper plug-in. This error translates into human language as the following:

    you have used private|public|protected (or some other perfectly valid PHP5 function access modifier) in PHP4 context.

    Again, if anyone is absolutely sure he has PHP5, and still gets the error, feel free to contact me directly: "victor ~ at~ afcomponents ~dot~ com".

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags