WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can not access subdirectory WPMU sites! (wp 3.0.2) Help (12 posts)

  1. blogcreator
    Member
    Posted 3 years ago #

    I am having trouble installing WPMU with sub-directories!

    I have setup sub-domains fine!
    http://zogz.info
    http://dittome.info
    But I have started my new site http://pokerxtra.com and would like the sub-directories working!

    http://pokerxtra.com/pkr/ seems to have a broken theme, but that is not the problem, I dont know what I have done wrong, can somebody please help me and point me in the right direction :)

    Tried fresh installs with no plugins or themes installed, but still get the same issue!

    cannot even loginto subdirectory sites :(

    Realy fustrating!
    could do a subdomain option, but that is not what I want!

    I assume the rewite works as I can semmi access this page http://pokerxtra.com/pkr/2010/12/04/hello-world/

  2. You're enabling a network, not installing WPMU. WPMU is a separate program. If you're on 3.0.2 of WordPress, then you're creating a network. It's not WPMU.

    With that out of the way....
    The subdirectories work via htaccess. Check you have the right one (under the Tools -> Network page) and check to make sure mod_rewrite is enabled on the server and actually reading that pile. Do pretty permalinsk work on that blog? Yes? No?

  3. blogcreator
    Member
    Posted 3 years ago #

    Thank you for reply :)

    First of all I can not access the subdirectory admin!
    therefor cannot enable permalink options!

    permalink works fine on my main site :)

    Also cannot see TOOLS>NETWORK from main admin!
    (only see 'category/tag converter', and 'press this')

    Im confused :(

    I never had any issues installing subdomain network!

    did you look at my non-functional sub site?
    http://pokerxtra.com/pkr/

    This should be simple, I thought subdomian was ment to be more tricky to setup, but I found that simple :)

  4. Also cannot see TOOLS>NETWORK from main admin!

    Did you remove the define? The one you put in for the very FIRST STEP in enabling the network?

    http://codex.wordpress.org/Create_A_Network

  5. blogcreator
    Member
    Posted 3 years ago #

    umm...

    I used the 'multi site' plugin, to enable my network!

    http://jgwebdevelopment.com/plugins/wordpress-multi-site-enabler-plugin

    I should have mentioned that in first post!

    I still have the define line in config.php
    is there anything wrong with the following lines in my config.php?

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = "/";
    define( 'DOMAIN_CURRENT_SITE', 'pokerxtra.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

  6. blogcreator
    Member
    Posted 3 years ago #

    my .htaccess

    #Made Multi-Site with Multi-Site Enabler 1.4#
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]

    RewriteRule . index.php [L]

  7. blogcreator
    Member
    Posted 3 years ago #

    THANK YOU VERY MUCH FOR THE HELP :)))))))))))

    FIXED

    was my .htaccess file DOH!

    changed to the correct settings and works fine :)

    Thank you for the help!

    If anyone else has same issues from using the enable multisite plugin, you need to change your .htaccess to the below code:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

  8. Yeah, MANY people are having an issue with the plugin, which only does some of the steps anyway.

    Everyone really shoudl learn how to do it manually.

    If anyone else has same issues from using the enable multisite plugin, you need to change your .htaccess to the below code:

    only if they pick the same option. Readers, use the htaccess code the backend menu gives you.

  9. Copywriting123
    Member
    Posted 3 years ago #

    Hi,
    I have the same problem. I used the htaccess code that the backend menu gave me but I still cannot access the sites I created as subdirectories. when I try to login the new sites I get "page not found". What could be the problem?

    Here is my .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
  10. Tim Moore
    Moderator
    Posted 3 years ago #

    Make sure you have mod_rewrite enabled in Apache.

  11. Copywriting123
    Member
    Posted 3 years ago #

    checked that and mod_rewrite is enabled...will be glad to hear other suggestions?

  12. Copywriting123
    Member
    Posted 3 years ago #

    Found it :-) the problem was saving the htaccess file as htaccess.txt instead of .htaccess. Everything is working now!
    Thanks for your help...

Topic Closed

This topic has been closed to new replies.

About this Topic