WordPress.org

Ready to get started?Download WordPress

Forums

Can login but Can't access dasboard, redirect / reauth (2 posts)

  1. mobileaudioheadquarters
    Member
    Posted 2 years ago #

    my site for reference is http://www.mobileaudioheadquarters.com

    So i have been doing some optimizations and trying out several plugins and have encountered this stupid error. I have done research on it but nothing that helps me. The problem is that I can login and I can register, but I cannot access the dashboard. If I try it redirects me to the login page with this in the address bar "http://www.mobileaudioheadquarters.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.mobileaudioheadquarters.com%2Fwp-admin%2F&reauth=1"

    At first I thought this was a register plugin I was using (Pie register) that was causing this. Luckily, I keep a backup of my site on my computer so I logged in via ftp and removed that plugin. It still didn't work. So I just copied over my public_html and www folder then the site was back up and running again. I wanted to test it again to i disable other plugins that I had recently installed and installed pie register again. No issues. Everything worked fine. So I left and then a few hours later I decided to check it again and now its giving me the redirect again. I don't understand. So I decided that I can't use that plugin because it is causing an issue. I removed it and restored my files as before. I went on to try some other plugins, these of a different type. These ones were optimization plugins (w3 total cache, wp optimize, smush it) and i didn't encounter any errors. Everything was fine. The last one I downloaded was (wp hide dashboard) which by the way worked but I logged in as a subscriber and even though the dashboard was hidden the settings tab was still available in the subscribers profile panel which showed my backup settings. But on the real problem. I logged out of that subscriber role then back into my admin role and i get this stupid redirect again. It wont let me access the dashboard. So, I removed it and restored as before and site was back. Again, I tried the plugin again to make sure that was causing the problem. I installed it and did the same as before. logged in as subscriber,then out and back in as admin. This time I noticed that the same redirect/reauth link from above was there in the address bar but it was still allowing me access to the dashboard. I tried several times. logging in and out with different roles. same redirect link was there but it wasnt stopping me. So I am beginning to think that any time I use a plugin that has to do with users/dashbaord/login/register it is conflicting with something. what could be causing this??

  2. mobileaudioheadquarters
    Member
    Posted 2 years ago #

    UPDATE:

    I removed the wp hide dashboard and logged in out a few times. everything was working. I wrote this post, came back to my site and now I'm getting the redirect again. WTH!! anyone?

Topic Closed

This topic has been closed to new replies.

About this Topic