WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
can insert product image (3 posts)

  1. serge512
    Member
    Posted 2 years ago #

    Hi i get a lot of errors in diferent parts. when i first enter the admin dashnboard i get:

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/vmba512/bluminton/wp-content/plugins/wp-e-commerce/wpsc-admin/admin.php on line 578

    when i try to use an image from the multimedia, wich i already uploaded i get:

    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/vmba512/bluminton/wp-content/plugins/wp-e-commerce/wpsc-admin/includes/display-items-functions.php on line 1018

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/vmba512/bluminton/wp-content/plugins/wp-e-commerce/wpsc-admin/includes/display-items-functions.php on line 1018

    since version 3.2 of WP i have this errors. I update to 3.2.1 and still got the errors, then i update WPEC to 3.8.5 and still errors!

  2. Nicholas R. Batik
    Member
    Posted 2 years ago #

    serge512,

    Got the same error. It didn't show up for me until 3.2.1.

    It is showing up for me in a couple different plugins, so I started a thread at http://wordpress.org/support/topic/multiple-plugins-failing-on-reference-to-metadatasizes?replies=1#post-2245466.

    The other plugin I had trouble with was scissors-continued (same error).

    There is a discussion at http://getshopped.org/forums/topic.php?id=22342&replies=11#post-91630 that helped with that, and some explanation by edwardra3 at http://getshopped.org/forums/topic.php?id=22395#position-11 that might get you started in the right direction.

    I tried ralcus's fix and it worked for me.

  3. jodamo5
    Member
    Posted 2 years ago #

    I just received an almost identical error:
    "Warning: array_merge() [function.array-merge]: Argument #2 is not an array in" ....

    It happened just after I had chosen "Duplicate" for a product in WP e-commerce. I found it made a whole second copy of the image I had uploaded for that product. So on my images tab I deleted the second one. And now the error has disappeared.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic