WordPress.org

Ready to get started?Download WordPress

Forums

Posts in Sidebar
[resolved] Can I remove the spaces between entries? (15 posts)

  1. nickysgaypattaya
    Member
    Posted 1 year ago #

    I've made some lovely categories and lists using this plugin. The only thing is the list is rather long since there is a space between each line

    http://www.cambodiagaytravel.com/siem-reap/hotels-sr/

    Is there an easy way to remove this space?

    Thanks

    http://wordpress.org/extend/plugins/posts-in-sidebar/

  2. aldolat
    Member
    Plugin Author

    Posted 1 year ago #

    Add this line at the end of style.css (or style.min.css) file of your current theme:

    p.pis-title { margin-bottom: 0; }

    Bye.

  3. mike churcher
    Member
    Posted 1 year ago #

    Hi Aldolat and Nickysgaypattaya. Yep, I'm struggling with this one too. Dropped into the style.css of my 2010 theme: p.pis-title { margin-bottom: 0; } I went into Appearance> editor> edit themes> css stylesheet; dropped it in at the end as directed ... and nothing.

    All my posts in the sidebar have a small gap and unfortunately the presentation of the plugin is incongruous due to the wider spacing. Same as Nickysgaypattaya, I need all the land I can get.

    It's a cracking plugin, much better than the 6 or so I've tried already!

    Thanks very much for your help and time.

    Mike

  4. mike churcher
    Member
    Posted 1 year ago #

    The widget is just below the twitter feed on http://www.wokinghamremembers.com/

  5. aldolat
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Mike,
    I just looked at the code of your theme and surely you only have to add that line at the end of your style.css file. Make sure you type correctly the code (copy-and-paste is better).

    Also, make sure you have installed the 1.3 version of the plugin.

    Let me know if you need further help.

  6. mike churcher
    Member
    Posted 1 year ago #

    Hi Aldo, many thanks for coming back to me so quickly. Yep, it's 1.3 and I c and p'd the text. I took some snaps to define the problem - the gaps between the lines and also the code in the css. I must be doing something basically idiotic. The snaps are on the page: http://www.wokinghamremembers.com/spaces-in-widget/

    Thanks again Aldo,

    Mike

  7. mike churcher
    Member
    Posted 1 year ago #

    I'm using wordpress 3.5.1. Any issues there do you think?

  8. aldolat
    Member
    Plugin Author

    Posted 1 year ago #

    Mike,
    follow carefully these instructions:

    1)remove this line:
    p.pis-title { margin-bottom: 0;

    2) Leave the last } untouched

    3) Scroll up a little and just before this line:
    /* =Print Style
    paste this:
    { p.pis-title { margin-bottom: 0; }

    You're done.

    Let me know.

  9. mike churcher
    Member
    Posted 1 year ago #

    Hi Aldo,

    Many thanks, lovely job.

    I took out the first curly bracket in the code and it worked a treat: p.pis-title { margin-bottom: 0; }

    Thanks again.

    Mike

  10. aldolat
    Member
    Plugin Author

    Posted 1 year ago #

    Oops, you're right. The first curly bracket was a "copy & paste" error.

    @me
    Just a reminder: do not give help when you just left your bed on early morning... :-)

  11. mike churcher
    Member
    Posted 1 year ago #

    Yes I noticed the email time stamp was 5 am ! I thought you must be much further east to the UK, but instead you're an insomniac. Your excellent widget now sits between flexi pages and a recent post widgets, all in harmony, but yours provides a lot more options. I had a look at quite a few other similar widgets and they didn't provide the flexibility. I wonder if it might be worth narrowing the gaps in your next version as default, have a look (I've titled it Posts in sidebar for you to see). http://www.wokinghamremembers.com/

  12. mike churcher
    Member
    Posted 1 year ago #

    Gulp, the gap returned ! Or at least I thought. The widget defaults with excerpt settings switched on. When excerpts are included, the gap returns. I need the land so I removed the excerpts and the gap disappeared. Great.

  13. aldolat
    Member
    Plugin Author

    Posted 1 year ago #

    Every element generated by the plugin is wrapped in a p HTML element. So, if your theme defines that every p element must have a space after itself, every p element generated by the plugin will have that space.

    If you want to show the excerpt too, you have to compensate the extra space declaring that every p element with a particular class must have a space-after equal to zero (or what you like).

    In fact, for the title we have declared:

    p.pis-title { margin-bottom: 0; }

    For the excerpt you have to declare (just below this line):

    p.pis-excerpt { margin-bottom: 0; }

    or, better, you can put together those two styles:

    p.pis-title, p.pis-excerpt { margin-bottom: 0; }

    Hope this will help.

  14. mike churcher
    Member
    Posted 1 year ago #

    Thank you again Aldo for putting so much effort into helping me, both with the creation of the widget and enabling me to adjust it for my website. I am very grateful.

  15. aldolat
    Member
    Plugin Author

    Posted 1 year ago #

    You're very welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic