WordPress.org

Ready to get started?Download WordPress

Forums

Can I Import 9MB of posts? (14 posts)

  1. smgct
    Member
    Posted 5 years ago #

    Hi. After setting up 2 WordPress websites almost a year ago, I didn't get back to them until this week and am determined to make the switch from Typepad to WordPress/Lunar complete. One blog went through with no problem. But my original weblog from 2003 is now 5300 posts and the export file looks to be 9 megabytes.

    Is there a 2 mb limit to importing? Any other way to do this so I have the complete file transferred?

    Thanks for any help you can offer. I'm new here, but I'm excited about having more control over my sites (as soon as I learn how to wield that control!)
    susan

  2. Shane G
    Member
    Posted 5 years ago #

    Hi,

    I think that you can import 9MB data from your wordpress if you are facing any error message regarding 2MB limit then you need to contact your hosting service provider and set limit to 10MB from PHP.INI file from the server. It should be fix the case.

    [signature moderated Please read the Forum Rules]

  3. smgct
    Member
    Posted 5 years ago #

    Thanks, Shane. But the 2 mb restriction is from the WordPress Import/Export page itself, and it refers to importing from a file on the hard drive rather than Typepad to WordPress direct. I think there's another way, via the server and a change to import.txt that might take are of it.

  4. figaro
    Member
    Posted 5 years ago #

    But the 2 mb restriction is from the WordPress Import/Export page itself,

    Yes, but that is controlled by the settings in php.ini on the server. There are two settings that need to be changed...don't remember the exact names without looking, but they're something like max_file_size and max_post_size. Search these forums, or even just through Google...this is a common issue, so you'll get a lot of hits.

  5. andrewtayloruk82
    Member
    Posted 5 years ago #

    Couldn't you split the post database into 2mb chunks and import it like that?

  6. smgct
    Member
    Posted 5 years ago #

    Typepad doesn't show a way of exporting just portions; Tho I may be able to make a change in lunar's import.txt and put it in there for retrieval. My php.ini file is:

    register_globals = Off

    zend_extension="/usr/local/IonCube/ioncube_loader_lin_4.4.so"
    zend_extension_ts="/usr/local/IonCube/ioncube_loader_lin_4.4_ts.so"

    [Zend]
    zend_optimizer.optimization_level=15
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3
    zend_optimizer.version=3.3.3

    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

  7. Try adding to that php.ini file these lines

    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 15M

    I picked 15MB arbitrarily; anything more than 9M should work.

    Once you change that file restart your apache2 webserver to make sure it takes.

  8. smgct
    Member
    Posted 5 years ago #

    Whew! Got it done finally, and here's how:
    I did change the php.ini file to reflect the larger size by adding those two lines. However, the WordPress Importer still wouldn't take it. So I tried plan #2, which was to duplicated and rename the export file (download_export.htm because it was done on a Mac) to the WordPress suggested mt-export.txt even though it wasn't a txt file per se. I then uploaded it to my server at Lunar via Filezilla, filing it in the wp-content folder. Going back to the Worpress Importer, I then clicked on the choice to download the mt-export.txt file and lo and behold, it worked! all 5,309 entries, comments, images, were exported without a glitch (except for the permalink problem which is another whole can of worms).
    Thanks so much for your help guys!

  9. godmoney
    Member
    Posted 5 years ago #

    Can you explain what did you do in the Import page? I want to try your method.
    I uploaded mt-export.txt to wp-content folder. now what?

  10. smgct
    Member
    Posted 5 years ago #

    Under your Dashboard/Tools/Import, you'll see two options:

    Howdy! We’re about to begin importing all of your Movable Type or Typepad entries into WordPress. To begin, either choose a file to upload and click "Upload file and import," or use FTP to upload your MT export file as mt-export.txt in your /wp-content/ directory and then click "Import mt-export.txt"
    Choose a file from your computer: (Maximum size: 2MB) ( ) Browse
    (Button: Upload file and import)

    Or use mt-export.txt in your /wp-content/ directory
    (Button mt-export.txt)

    Once you have the mt-export.txt (make sure it's got the hyphen) in the wp-content folder on your server, all you have to do is click this second button on the WordPress Importer page and voila!

  11. godmoney
    Member
    Posted 5 years ago #

    I don't have that... I have:

    If you have posts or comments in another system, WordPress can import those into this blog. To get started, choose a system to import from below:

    and then a list of blog sites

  12. smgct
    Member
    Posted 5 years ago #

    Oops! Sorry! I missed that step: choose "Movable Type and Typepad"

    Let us know if it works.

  13. dwcouch
    Member
    Posted 5 years ago #

    I've not been able to import mt-export.txt, it's 10.2 MB (10,794,389 bytes), I've uploaded it to wp-content. once I click the button to import, I get the following: Sorry, there has been an error. File is empty. Please upload something more substantial. I've allowed full permissions on that file too. grr.

  14. rjhayton
    Member
    Posted 5 years ago #

    I had an issue with an 11 MB file that was a WordPress export from wordpress.com. How I ended up getting almost everything to work was by splitting up the file into several smaller files. You have to keep all the heading up until the first <item> and then keep the </channel></rss> at the end. I found out I only needed to add the categories and tags info on one file and then the rest just had the beginning of the file and the footer, and items. I kept cutting them in half, copying the date/time stamp, to use for Ctl F so I remembered where I had cut it off. I found files sized around 200 KB worked best. It took a while but worked.

Topic Closed

This topic has been closed to new replies.

About this Topic