WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can edit but can not view site (14 posts)

  1. juliatrops
    Member
    Posted 8 years ago #

    when I go to view the site, here is the error:

    Warning: main(./wordpress/blog/wp-blog-header.php): failed to open stream: No such file or directory in /mnt/web_e/d31/s01/b0267acb/www/wordpress/index.php on line 4

    Fatal error: main(): Failed opening required './wordpress/blog/wp-blog-header.php' (include_path='.:/usr/local/nf/lib/php') in /mnt/web_e/d31/s01/b0267acb/www/wordpress/index.php on line 4

    here is my index.php

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wordpress/blog/wp-blog-header.php');
    ?>

    root directory for this installation

    wordpress/

    in this directory is

    index.php
    crawlpage.html
    .htaccess

    all other files are in:

    wordpress/blog

    I can edit the site no problem. The options are working, I can upload no problem, but I can not view the site. I get the above error.

    Any ideas?
    Thank you!

  2. juliatrops
    Member
    Posted 8 years ago #

    is there anyone who can help me with this? :)

  3. juliatrops
    Member
    Posted 8 years ago #

    last time I posted, I received tremendous help. Hmm. Either that, or no one knows the answer!!!

  4. jimatwork
    Member
    Posted 8 years ago #

    This doesn't look like the standard install structure. Did you modify it? Was it ever working?

  5. planetthoughtful
    Member
    Posted 8 years ago #

    At a guess, try editing this line:

    require('./wordpress/blog/wp-blog-header.php');

    To this:

    require('blog/wp-blog-header.php');

    Let me know if that helps.

    Much warmth,

    planetthoughtful

  6. juliatrops
    Member
    Posted 8 years ago #

    hi planetthoughtful, I did what you suggested, here is the error:

    Warning: main(.blog/wp-blog-header.php): failed to open stream: No such file or directory in /mnt/web_e/d31/s01/b0267acb/www/wordpress/index.php on line 4

    Fatal error: main(): Failed opening required '.blog/wp-blog-header.php' (include_path='.:/usr/local/nf/lib/php') in /mnt/web_e/d31/s01/b0267acb/www/wordpress/index.php on line 4

    hi jimatwork:

    The blog was working when I had index.php in the root - but I also had index.html in the root, and the php would override the html. I needed the html to come up first. As I moved the system previously with no problems...

    here is the topic..

    http://wordpress.org/support/topic/54463?replies=20

  7. juliatrops
    Member
    Posted 8 years ago #

    I should clarify -

    the index.php is not in the root of the website at present, but it is in the subdirectory of wordpress...

    the directory for this installation

    wordpress/

    in this directory is

    index.php
    crawlpage.html
    .htaccess

    all other files are in:

    wordpress/blog

    Could this be the problem? I am wondering if I moved some files incorrectly, and it is expecting to find a file that is not there...?

  8. juliatrops
    Member
    Posted 8 years ago #

    I just tried an absolute address as well for index.php:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('http://juliatrops.netfirms.com/wordpress/blog/wp-blog-header.php');
    ?>

    and

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('http://www.juliatrops.com/wordpress/blog/wp-blog-header.php');
    ?>

    Did not work.

  9. juliatrops
    Member
    Posted 8 years ago #

    Okay! got it with the following index.php:
    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./blog/wp-blog-header.php');
    ?>

    but with errors:

    Warning: fopen(./wordpress/wp-content/plugins/lastsubmit.txt): failed to open stream: No such file or directory in /mnt/web_e/d31/s01/b0267acb/www/wordpress/blog/wp-content/plugins/rssautosubmit.php on line 44

    Warning: fgets(): supplied argument is not a valid stream resource in /mnt/web_e/d31/s01/b0267acb/www/wordpress/blog/wp-content/plugins/rssautosubmit.php on line 45

    Warning: fseek(): supplied argument is not a valid stream resource in /mnt/web_e/d31/s01/b0267acb/www/wordpress/blog/wp-content/plugins/rssautosubmit.php on line 63

    Warning: fwrite(): supplied argument is not a valid stream resource in /mnt/web_e/d31/s01/b0267acb/www/wordpress/blog/wp-content/plugins/rssautosubmit.php on line 64

  10. Glo
    Member
    Posted 8 years ago #

    There seems to be a problem with the rssautosubmit.php plugin. Try deactivating that plugin and see if the problem is fixed.

  11. spencerp
    Member
    Posted 8 years ago #

    I just went there, and it's spitting out errors for that plugin. Either turn off that plugin once or edit that plugin file for the same changes you made above.. cause it's calling the /wp-blog-header.php as well.


    require('blog/wp-blog-header.php');

    To this, for the plugin file:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./blog/wp-blog-header.php');
    ?>

    Maybe try changing that part of the plugin's header section, to call the same as what you did with blog once..or shut off the plugin..

    spencerp

    The above that I posted is what you had changed it to, but the original part of that code in the plugin's file should be changed to that as well maybe.... Or whatever you're using for it...I dunno off hand lol..

  12. juliatrops
    Member
    Posted 8 years ago #

    Hi Glo and spencerp, thank you very much for the direction! I turned off the rss plugin, and all is well.

    I tried adding the /blog/ portion to the calling addresses (2 of them) in the rss plugin . php file, but this did not work either. Still an error in calling. I dont know anything about php, and know only enough to get me into trouble. :) I guess I will leave the rss submit plugin off. It is working wonderfully now, and I am happy.

    Thank you very very much for all your help!!!
    All the best,
    Julia

  13. spencerp
    Member
    Posted 8 years ago #

    No problem Julia.. =) On a side note, maybe the rest of the plugin's file's need changed a tad bit as well as the main one. Because it's expecting the bland same old WordPress wp-blog-header.php to be called..mmm.

    I'm not sure, but if you're fine with what you have now and it doesn't matter about that other stuff...then I'd just leave it alone. Don't need to make more work for yourself.... =)

    spencerp

  14. niggel
    Member
    Posted 8 years ago #

    YES!!!!!!!
    had the exact same problem. ok, i modified the index file by leaving out the ./ part in front of the "require"-tag. now everything is working perfectly! man, this makes my day. thanks a lot!

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('wp-blog-header.php');
    ?>

    All the best!
    Niklas

Topic Closed

This topic has been closed to new replies.

About this Topic