WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can Anyone Fix the Stupid Permalinks Issue? 'Default' Setting is LAME (11 posts)

  1. julesmaas
    Member
    Posted 5 years ago #

    I am so unbelievably irritated that I lost my custom permalinks (and categories) after upgrading to 2.6, 2.6.1 AND 2.6.2

    My website & blog is hosted through Yahoo! Small Business. Do I need access to my .htsaccess or not? Is it a tagging issue or not? Is anyone working this or not?

    I've lost all my google results and folks who have bookmarked anything on my site.

    I know I'm NOT the only one with this problem,(http://wordpress.org/support/topic/189533?replies=10) so I'm surprised there's so little information for SOME sort of fix.

    WP PLEASE RESPOND

  2. julesmaas
    Member
    Posted 5 years ago #

    also, my permalinks do not include "index.php" anywhere in the url

  3. Dgold
    Member
    Posted 5 years ago #

    Have you tried going WP Admin > Settings > Permalinks

    and resave your permalinks there?

    That should rewrite the permalinks and they'll instantly be back to normal.

  4. moshu
    Member
    Posted 5 years ago #

    Also, there are quite a few posts about permalinks on Yahoo (where nothing ever works as on normal hosts...)
    http://wordpress.org/search/permalinks+yahoo?forums=1

  5. julesmaas
    Member
    Posted 5 years ago #

    OMG, I wish that would work. I've tried it soooo many times.

    Here's an example of my process:
    * go to WP Admin > Settings > Permalinks
    * change Common Settings from 'default' to "Month & name"
    * Save
    * go to blog & refresh
    * click post
    * get 404 error

    * go BACK to WP Admin > Settings > Permalinks
    * Set Optional field 'Category base' to "category"
    * Set Optional field 'Tag base' to "tag"
    * Save
    * go to blog & refresh
    * click post
    * get 404 error

    * go BACK to WP Admin > Settings > Permalinks
    * Reset Common Settings to "Default"
    * Save
    * go to blog & refresh
    * click post
    * post works - but with lame 'default' permalink URL

    * go BACK to WP Admin > Settings > Permalinks
    * Reset Common Settings to "Month & date"
    * Save
    * go to blog & refresh
    * click post
    * get 404 error
    * BLOW UP DAMN COMPUTER

  6. julesmaas
    Member
    Posted 5 years ago #

    thanks for the search results, moshu. I'll check them out.

  7. julesmaas
    Member
    Posted 5 years ago #

    MOSHU!!! MARK!! You are geniuses! YOU HAVE MADE ME SO HAPPY! *kisses!*

    Anybody else using Yahoo! with WordPress and having permalinks problems, GO HERE and download Mark's plugin RIGHT NOW:

    http://markjaquith.wordpress.com/2007/09/25/wordpress-23-canonical-urls/

    LOVE IT!!

  8. spiff06
    Member
    Posted 5 years ago #

    Worked nicely for me as well, to force a newly-updated Yahoo blog to use Permalinks.

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    ... Mark's Canonical URL's are built into WordPress, starting with version 2.5. The plugin should not be necessary.

  10. spiff06
    Member
    Posted 5 years ago #

    Yet it proved necessary when I upgraded a client's blog to the latest version three weeks ago, on a Yahoo Small Business account.

    Just for kicks, I just uninstalled Mark's Canonical URL there, refreshed the front page, clicked on the first link, which was canonical, and watched Firefox go into an endless "Waiting/Connected" loop, ending in a "Redirect Loop" error. I reinstalled the plugin, and the canonical URL loaded instantly.

    So, yes, Otto42, it should not be necessary. But it still is, with the latest version of WordPress (2.6.5), on this particular installation on Yahoo.

  11. mp3sattack
    Member
    Posted 5 years ago #

    My example, i wanted to use /category/postname then in custom structure i typed: /%category%/%postname%/
    saved.. and didn't work.. why?? if i am using that in other blogs.. then i check those... and when i change something in permalinks, those DO tell one needs to add this to the .htaccess file of the site:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    that should make it work with any structure you want for example
    /%category%/%postname%/%day%/ or even make one like /ilovepotatochips/%month%/%day%/%postname%/ or anything you like
    I hope that helps, i don't know why version 2.7.1 does NOT tell you that part of the .htaccess

Topic Closed

This topic has been closed to new replies.

About this Topic